Jump to content
unnamed8848

TVDB no primary cover images and wrong metadata language

Recommended Posts

unnamed8848

I know, we probably all have issues with thetvdb, but I haven't found anyone having the problem I have.

 

I'm using the latest version of the plugin as of today. All the metadata gets downloaded in english, even though german is selected. And it doesn't find any primary cover images, all others e.g. background are found.

Share this post


Link to post
Share on other sites
Luke

Hi there, did you check to see what tvdb has for the show you tested?

Share this post


Link to post
Share on other sites
unnamed8848

Of course, it has multiple languages for the text and images, including german. But I observed something interesting, if I switch the image metadata language for the library to english, I get cover images with the edit images option ( but only in english )

Share this post


Link to post
Share on other sites
Luke

@@Dibbes are you able to reproduce?

Share this post


Link to post
Share on other sites
Dibbes

I don't have any libraries in German and the default for my server is set to UK English, I do not see this issue with the two movie libraries I've set to Spanish and Dutch respectively...

 

The only thing I do see is this issue, which I do not believe is really an issue:  https://emby.media/community/index.php?/topic/79172-ik-wil-season-inplaats-van-seizoen/&do=findComment&comment=834009

 

@@unnamed8848 Can you step by step write down what to do to reproduce this issue, please?

Share this post


Link to post
Share on other sites
Luke

@@unnamed8848

 

Are you still running into this?

Share this post


Link to post
Share on other sites
Happy2Play

Yes, I made a quick screen recording: https://gfycat.com/blindcomposedagama

@@Luke in this this example a Spanish language image appears for all translations on TVDB, but Emby does not see it if all languages are selected.

 

Setting preferred download language to Spanish, the image appears from TVDB.

 

But my system returns images from FanArt in en, and it when all languages is selected.

 

tested on Windows 4.4.0.11 

TVDB 1.0.28.0

Edited by Happy2Play
  • Like 1

Share this post


Link to post
Share on other sites
Luke

Are  you still running into this?

Share this post


Link to post
Share on other sites
unnamed8848

Yes, nothing has changed

  • Like 1

Share this post


Link to post
Share on other sites
unnamed8848

Any news on this? Still have this problem... The solution would be just to download in another language if the preferred one isn't found. Before theTVDB changed their API a while ago, this was the case.

Share this post


Link to post
Share on other sites
Happy2Play

There are to many issues with TVDB to do anything right now.  Best bet if possible is try TMDB.

 

I really don't see anything changing until TVDB release v4 api, as that is where they are pushing all their fixes to current issues or v3 shortcomings.

Share this post


Link to post
Share on other sites
Luke

Are you still having an issue with this?

Share this post


Link to post
Share on other sites
ricknds

I had the same problem here. The only way to import images from TVDB was to choose English in the image search settings.

Even the option to choose all languages (when looking for an image) didn't show anything if my real language (Brazilian Portuguese) was selected.

  • Like 1

Share this post


Link to post
Share on other sites
JBou
On 20/08/2020 at 20:41, ricknds said:

I had the same problem here. The only way to import images from TVDB was to choose English in the image search settings.

Even the option to choose all languages (when looking for an image) didn't show anything if my real language (Brazilian Portuguese) was selected.

Exact same problems, but for german movies.
 

In addition, it would be really nice if the image search falls back to english images (or a configurable fallback language) if there are no german ones, as requested here too:

 

 

I hope this feature is going to be added, I currently have a lot of missing posters. Thanks

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...