Jump to content
mrtwopoints

Apple TV direct streaming video freeze

Recommended Posts

mrtwopoints
Posted (edited)

I've had major issues over the last three days with playback over the local network on my Apple TV. All other Emby apps work perfectly (iOS, Roku, Emby Theater, Web player). A few minutes into playback the video will begin freezing for several seconds at a time and then start up again. It might play for a few more seconds and then freeze again for 5-7 seconds. This goes on continuously with no end. At this point it's been three days since I've been able to get farther than a few minutes into a video and appears to be an issue, no matter the time of day, or how many users are accessing the server. My AppleTV is direct streaming the video files, and I have attempted multiple video codecs (h264 and HEVC, with a variety of audio codecs) and the problem persists across all file types. Other users outside the local network are not reporting issues with there Apple TVs while transcoding, though I haven't verified this in person. I am on a wired gigabit connection, and have switched Ethernet outlets to eliminate a bad link. All other Emby clients stream without issue though, wired or wireless. 

 

Music playback seems to work better, but occasionally the song will restart on its own. All other streaming apps on the Apple TV playback without issue.

 

I am using Apple TV version 13.3 and Emby app version 1.4.3.04

 

My Emby server version is 4.3.1.0

 

*** EDIT *** I have also force closed the app, and restarted. I have restarted the Apple TV, and I have uninstalled the app, and reinstalled from the App Store. 

 

I have attached a log file showing a reboot of the Emby server, followed a few minutes later by a failed attempt to playback a movie on the Apple TV. The movie began failing about 2-3 minutes in. During this there are other successful files playing for outside users.

 

As always, your support is extremely appreciated!

Edited by mrtwopoints

Share this post


Link to post
Share on other sites
corey

Hi @@mrtwopoints

 

I’m sorry to hear you’re having these issues. A couple of quick things you can try if you haven’t already. Can you try force closing the app? Alternatively have you tried rebooting the Apple TV itself?

 

Thanks!

Share this post


Link to post
Share on other sites
mrtwopoints

Thanks for the quick reply!

 

I should have noted that those steps have been tried several times. I have both force closed the app on occasion, as well as rebooted the Apple TV itself.

Share this post


Link to post
Share on other sites
mrtwopoints

Any thoughts on this issue? I switched the Apple TV to WiFi and still get the same problem. It doesn’t appear to be the network connection.

 

I also reset to factory defaults and reinstalled with no change.

Edited by mrtwopoints

Share this post


Link to post
Share on other sites
Luke

@@corey Apologies, it doesn't look like my logs attached correctly. I am attaching the server log and a remux log of the file that experienced the freezing playback. If you need anything else, please let me know. Thanks!

 

Hi, from this example, at what time in the video did the problem occur? If you play the video again, does it happen again at the same spot?

Share this post


Link to post
Share on other sites
mrtwopoints

It happens with the same approximate regularity, but not at the same spots. I can’t discern a pattern, and I did not make notes as to the exact times of each playback freeze.

Share this post


Link to post
Share on other sites
Luke

As a test, if you turn off the server transcoding throttle feature, does that make a difference?

Share this post


Link to post
Share on other sites
mrtwopoints

That does not make a difference. Yesterday, the freezing started to occur on my iPad as well. 2-3 minutes of good playback, followed by freezing for a few seconds, playing for a few seconds, then freezing again, continuously. Rokus are fine, Emby Theater is fine. Does not occur when transcoding videos for playback outside the local network on other Apple TVs. Only on the local network when direct playing or direct streaming using iOS or Apple TV clients. This started about 5 days after upgrading my server from 2012 to Windows Server 2019. I am considering reformatting and trying again.

Share this post


Link to post
Share on other sites
mrtwopoints

Reformatted and installed with a fresh version of Windows Server 2019. Installed Emby and added only a handful of movies for testing purposes. Set up all clients new. All Apple clients (Apple TV, iOS) begin freezing after 1-2 minutes. All Roku and Emby Theater clients play perfectly. Web play is fine as well.

Share this post


Link to post
Share on other sites
vdatanet

Can you post media info of movies freezing?

 

If you want, you can ask for a beta invitation to test native player, seems that mpv player is having trouble to play those movies.

Share this post


Link to post
Share on other sites
vdatanet

What are you Apple TV video settings? Resolution, Dynamic Range...

Edited by vdatanet

Share this post


Link to post
Share on other sites
mrtwopoints

What are you Apple TV video settings? Resolution, Dynamic Range...

 

I'm using 1080 60 Hz SDR for the resolution, and Match Content frame rate and Match Content Dynamic Range are both on. Although I am not playing back any HDR content on this Apple TV.

Share this post


Link to post
Share on other sites
mrtwopoints

Can you post media info of movies freezing?

 

If you want, you can ask for a beta invitation to test native player, seems that mpv player is having trouble to play those movies.

 

I have attached 4 examples. Two movies and two television episodes. The movies direct stream, the tv shows direct play, all freeze on Apple TV and iOS for iPad.

Media 1.txt

Media 2.txt

Media 3.txt

Media 4.txt

Share this post


Link to post
Share on other sites
mrtwopoints

I reformatted again and switched back to Windows Server 2012. All issues with Apple products have stopped. I’m sorry I didn’t have more time to troubleshoot this issue, but I needed it working.

Share this post


Link to post
Share on other sites
mrtwopoints

I reformatted again and switched back to Windows Server 2012. All issues with Apple products have stopped. I’m sorry I didn’t have more time to troubleshoot this issue, but I needed it working.

Share this post


Link to post
Share on other sites
Luke

Thanks for the feedback.

Share this post


Link to post
Share on other sites
MrL0c0

i have a an issue with direct play on the atv4

 

hardware:

atv4

win2019

SMB share

direct stream

720p dts mkv file

 

 

when playing:

* glitching

* freezing

Share this post


Link to post
Share on other sites
Luke

Is it only happening on that one video?

Share this post


Link to post
Share on other sites
MrL0c0

Is it only happening on that one video?

every 720p and up 4k is not even worth it.

480 mkv runs soothly

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...