Jump to content


Photo

All Marked as Watched??

watched unwatched

  • Please log in to reply
20 replies to this topic

#1 Mechanical Whispers OFFLINE  

Mechanical Whispers

    Member

  • Members
  • 27 posts
  • Local time: 06:54 PM

Posted 05 December 2019 - 04:39 PM

I'm using Emby for Kodi on Windows 10, with the latest Kodi 18.5, and the latest Emby Server updated. Recently, I've had all of my movies and TV shows marked as "watched" without me doing anything. Every single one. I have no idea where to start troubleshooting why this happened. But it keeps happening.

I drop a new movie into my library. Start up Kodi, Emby sees the new movie and adds it to the database and shows it as "unwatched". After watching something else for a little while, I come back to browse my movies, and the movie is marked as watched. Can someone please provide some assistance in troubleshooting this?

Update: All my libraries were removed automatically from the Emby server last night while I was watching a show in Kodi, leaving nothing in my metadata. I did a full rescan of my library from the Emby server. Took a while, but it loaded everything back in. Then I launched Kodi and did a full reset/resync of the Emby library. Everything is back, and I marked everything as "unwatched". Today I load up Kodi, and everything is marked as watched again. Log files attached. Hopefully someone can help me figure out what's going on? Also, a whole lot of Emby Server Metadata keeps getting dumped in my recycle bin every session, without me putting it there.

Attached Files



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156920 posts
  • Local time: 07:54 PM

Posted 05 December 2019 - 05:11 PM

Hi there, how does the web app compare?



#3 Mechanical Whispers OFFLINE  

Mechanical Whispers

    Member

  • Members
  • 27 posts
  • Local time: 06:54 PM

Posted 05 December 2019 - 07:58 PM

Can you explain what you want me to look up? I am guessing you mean the web interface for the server? I don't really use it other than to refresh my library, or sometimes fix some metadata. So if you could please be specific about what you want me to report on, I'd be happy to. Thanks.



#4 Angelblue05 OFFLINE  

Angelblue05

    Advanced Member

  • Developers
  • 12738 posts
  • Local time: 05:54 PM

Posted 06 December 2019 - 12:55 AM

You can completely ignore Kodi @Luke It is just echoing events it's receiving, I've seen the Kodi log and it showed played True in the userdata events received. I'm guessing the webclient reflects that change as well.

 

I was hoping you could see something in the Emby logs that would explain it.



#5 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156920 posts
  • Local time: 07:54 PM

Posted 06 December 2019 - 01:48 AM

Is it all marked played in the web app? Are you sure you didn't click the check mark on a parent folder to mark everything played?

#6 Angelblue05 OFFLINE  

Angelblue05

    Advanced Member

  • Developers
  • 12738 posts
  • Local time: 05:54 PM

Posted 06 December 2019 - 02:09 AM

If it was, it was not captured in the Kodi log provided. And that would also require user interaction. The fact that it keeps happening over and over sounds very unlikely to me.



#7 Mechanical Whispers OFFLINE  

Mechanical Whispers

    Member

  • Members
  • 27 posts
  • Local time: 06:54 PM

Posted 06 December 2019 - 06:47 AM

I went into the web app (and by web app, I still assume you mean my localhost dashboard for Emby?), and all the movies and TV series are marked as played there as well.

 

Just as an experiment, I opened Kodi, marked a movie as "unwatched", then closed Kodi and opened the Emby web dashboard, checked my libraries, and the movie was now marked as unplayed. I also looked around, and I'm not even sure where I would click to mark an entire parent folder as "played". But I would love to find that, so I can mark everything as "unplayed", instead of going through Kodi and doing it one-by-one.

 

And clicking into the metadata on a random movie, "save metadata to nfo" is checked, in case that matters. I assume everything is that way, since I haven't ever touched anything and left it all default.

 

I'm waiting to see if the movie I marked as "unwatched", gets marked back to "watched" automatically over time, as everything else did. I will update if it does. Edit: Yep, about 5 minutes later, everything was marked as "watched" again in Kodi. I even tried marking a movie as "unplayed" inside the Emby web server, and that too was marked as "watched" by Kodi automatically after a bout 5-10 minutes.


Edited by Mechanical Whispers, 06 December 2019 - 06:53 AM.


#8 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 19164 posts
  • Local time: 04:54 PM
  • LocationWashington State

Posted 06 December 2019 - 07:11 AM

I went into the web app (and by web app, I still assume you mean my localhost dashboard for Emby?), and all the movies and TV series are marked as played there as well.

 

Just as an experiment, I opened Kodi, marked a movie as "unwatched", then closed Kodi and opened the Emby web dashboard, checked my libraries, and the movie was now marked as unplayed. I also looked around, and I'm not even sure where I would click to mark an entire parent folder as "played". But I would love to find that, so I can mark everything as "unplayed", instead of going through Kodi and doing it one-by-one.

 

And clicking into the metadata on a random movie, "save metadata to nfo" is checked, in case that matters. I assume everything is that way, since I haven't ever touched anything and left it all default.

 

I'm waiting to see if the movie I marked as "unwatched", gets marked back to "watched" automatically over time, as everything else did. I will update if it does. Edit: Yep, about 5 minutes later, everything was marked as "watched" again in Kodi. I even tried marking a movie as "unplayed" inside the Emby web server, and that too was marked as "watched" by Kodi automatically after a bout 5-10 minutes.

You can do this via the multi-select box in the top left of library card on the Home Screen, then click the three dot menu on the top right of the screen.

 

By default Emby is not enabled to write nfo files, this is a per library option (enable Show Advanced Settings and scroll to Metadata Saver).



#9 Mechanical Whispers OFFLINE  

Mechanical Whispers

    Member

  • Members
  • 27 posts
  • Local time: 06:54 PM

Posted 06 December 2019 - 07:30 AM

You can do this via the multi-select box in the top left of library card on the Home Screen, then click the three dot menu on the top right of the screen.

 

By default Emby is not enabled to write nfo files, this is a per library option (enable Show Advanced Settings and scroll to Metadata Saver).

I can now see in my Library folders where the Metadata Saver has "nfo" checked. Is this not recommended? Will it have any effect on the problems I'm facing here?



#10 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 19164 posts
  • Local time: 04:54 PM
  • LocationWashington State

Posted 06 December 2019 - 07:34 AM

I can now see in my Library folders where the Metadata Saver has "nfo" checked. Is this not recommended? Will it have any effect on the problems I'm facing here?

Personally I recommend writing nfo file as this information can be reused instead of refetched.  But I wouldn't think this would be related to your issue.  I was just commenting on what you posted in post 7.



#11 Mechanical Whispers OFFLINE  

Mechanical Whispers

    Member

  • Members
  • 27 posts
  • Local time: 06:54 PM

Posted 06 December 2019 - 08:11 AM

Personally I recommend writing nfo file as this information can be reused instead of refetched.  But I wouldn't think this would be related to your issue.  I was just commenting on what you posted in post 7.

Thanks. Yeah, it doesn't seem to be related. As a test, I unchecked "nfo" in one single library folder, marked those movies as unwatched. Then marked another library folder as unwatched with the "nfo" remaining checked. Refreshed the metadata... everything still okay in Emby server, marked as unwatched. I opened up Kodi... all those movies were shown as unwatched. But after 5-10 minutes, they were all automatically marked as watched again in Kodi and in Emby server. Every last one.

 

Could it be a Windows 10 permissions thing, where it's not being allowed to write the "watched" status somewhere onto the hard drive where Emby stores that info?


Edited by Mechanical Whispers, 06 December 2019 - 08:35 AM.


#12 Angelblue05 OFFLINE  

Angelblue05

    Advanced Member

  • Developers
  • 12738 posts
  • Local time: 05:54 PM

Posted 06 December 2019 - 12:27 PM

Can you eliminate Kodi from the equation here?

Mark as unwatched in the webclient, don’t turn on Kodi, does it happen?

When I saw your Kodi log, which I’ve rechecked several times since, there is no indication Kodi itself is somehow marking your content as watched. So it would be great to confirm that.


Edited by Angelblue05, 06 December 2019 - 02:29 PM.


#13 Mechanical Whispers OFFLINE  

Mechanical Whispers

    Member

  • Members
  • 27 posts
  • Local time: 06:54 PM

Posted 06 December 2019 - 03:41 PM

I might be getting closer to figuring out what's going on...

 

I tried your suggestion. I restarted my Windows 10 machine, and didn't do anything except load Emby Server, and pull up the web interface. I marked 9 movies as "unwatched" and let it sit there for 20 minutes. No change at all. I played one of the movies, scrubbed to half way, and stopped it. Let it sit there and nothing happened. All movies were still marked as "unwatched" except the one I scrubbed to half way, and it showed partially watched. So all was as it should be.

 

Then I loaded up Kodi. It showed all those movies as "unwatched", except for the one I scrubbed and showed it partially watched. I didn't touch anything and let it sit there for 20 minutes. No change. All was as it should be.

 

Then I decided to try playing a video I had been playing recently... it's a sort of background video I play when I'm working, and it has a direct submenu item from my main Aeon Nox: Redux skinned menu. It's a custom submenu that plays that video directly. I've been using it for years that way. So I press the submenu to start the video, and a dialog pops up, looking like a context menu asking if I want to "info", "mark watched", "set favorite", "delete", "refresh emby metadata", or "refresh cached images". This dialogue box never popped up before the last Emby update. It would just play the video, or ask if I want to resume. Now, there's no way to play the video unless I select "mark watched", then click the submenu again and then it says "resume" or "play from beginning" as it used to. I think I was doing this before, thinking it had only set this one video as "watched". But this time, I selected "mark watched", then selected the menu again, and played the video. Then I quit out of the video and watched what happened... a box popped up saying "Emby for Kodi: 59% Processing updates:" and it looked like it was scanning my entire library. And once it finished, all my movies were marked as watched again. So either it's something with the last update to Emby that makes this new dialogue box pop up when I try to play a video from my main submenu of Kodi, or my custom menu command is no longer a valid way to play a video from the main submenu.

 

Here is my custom menu code:

PlayMedia("M:\\...path...video.webm",return)

 

And ...path... is the hard drive path to the video file. Thoughts?


Edited by Mechanical Whispers, 06 December 2019 - 03:43 PM.


#14 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156920 posts
  • Local time: 07:54 PM

Posted 06 December 2019 - 03:48 PM

If you mark it watched in the web app, how does that compare?



#15 Mechanical Whispers OFFLINE  

Mechanical Whispers

    Member

  • Members
  • 27 posts
  • Local time: 06:54 PM

Posted 06 December 2019 - 04:56 PM

It remains marked as "watched" in Kodi, too.... unless I try that menu item. Although, I just tried that menu item, and the popup dialogue box isn't showing now. So weird. Are there more updates happening in the background?



#16 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156920 posts
  • Local time: 07:54 PM

Posted 06 December 2019 - 05:28 PM

What I'm trying to ask is, if you only use the web app to mark things watched, do you end up in the same situation?



#17 Angelblue05 OFFLINE  

Angelblue05

    Advanced Member

  • Developers
  • 12738 posts
  • Local time: 05:54 PM

Posted 06 December 2019 - 05:31 PM

Could you provide an updated kodi log that specifically replicate this issue now that you know how? Thanks. @Luke I think I might have been wrong, at least if it’s some Kodi behavior, it wasn’t in that previous kodi log. So let’s wait for the new log. Thank you.

#18 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156920 posts
  • Local time: 07:54 PM

Posted 06 December 2019 - 05:47 PM

Yea I'm not trying to pinpoint any blame by asking these questions, just looking to gather information. Thanks.


  • Angelblue05 likes this

#19 Mechanical Whispers OFFLINE  

Mechanical Whispers

    Member

  • Members
  • 27 posts
  • Local time: 06:54 PM

Posted 07 December 2019 - 05:45 PM

I'll try to post a new Kodi log when I have a chance. Though last night I spent about 3 hours just trying to get some new (and older) TV show episodes to show up. I would drop them into my hard drive folder for the TV show, but they wouldn't sync into Emby or Kodi. Then I did a manual library sync in Emby server, and some would show up. But not in Kodi. Then I did a complete re-sync of my Kodi library, and the new files I dropped in would show up, but not the ones in there since before 11-29-2019 when the last Emby server update happened. It seems I've got a whole lot of problems going on, that I know I didn't have prior to the last update.

 

But I will try to post a new Kodi log when I have a chance, and I will update you on marking things watched in Emby server. But like I said, whatever I do in Emby server, it remains that way in Kodi and Emby both. So I think the previous situation was created by that menu item in Kodi not acting like it was supposed to.



#20 Mechanical Whispers OFFLINE  

Mechanical Whispers

    Member

  • Members
  • 27 posts
  • Local time: 06:54 PM

Posted 07 January 2020 - 03:13 PM

I haven't had the time to post a new log, but nothing seems to be getting marked as watched anymore (unless I mark it myself). So that's good and fixed. It was probably that menu button, which has lost its functionality for some reason.

 

There are other issues I'm having, but I'll post them in a new thread when I have a chance, since they are not related to this. But hopefully in the mean time, things will smooth out with further updates to Kodi and Emby. Thanks for your help!







Also tagged with one or more of these keywords: watched, unwatched

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users