Jump to content

4.3.0.30 How to enable real-time monitor


enr00ted

Recommended Posts

Hi there everyone, 

 

I found a relatively older thread in this forum about this problem related to some Synology issue. I did a fresh install of the latest version today and it doesn't seem to detect changes. I have 10 movies and 4 series quite a small library. I added a new episode and a new movie.

 

Not that much of a deal but I'd like to know if it's still an issue or if other people are experiencing the same.

 

Cheers.  B)

Link to post
Share on other sites

Hi, did you read the other threads about this? The issues on Synology are not an emby problem and can often be solved by configuring certain things on your machine.

Link to post
Share on other sites

Hi there everyone, 

 

I found a relatively older thread in this forum about this problem related to some Synology issue. I did a fresh install of the latest version today and it doesn't seem to detect changes. I have 10 movies and 4 series quite a small library. I added a new episode and a new movie.

 

Not that much of a deal but I'd like to know if it's still an issue or if other people are experiencing the same.

 

Cheers.  B)

 

The link contained in the below message on similar topic solved the inotify limit issue on my DS + survives Synology DSM updates as well.

 

https://emby.media/community/index.php?/topic/69684-emby-version-4-real-time-monitoring-is-not-working-synology-241315-and-all-other/?p=757675

Link to post
Share on other sites
  • 3 months later...
Angus2064

Hi, did you read the other threads about this? The issues on Synology are not an emby problem and can often be solved by configuring certain things on your machine.

 

Hello !

 

I encounter similar problem, after updating Emby to 4.3.1.0, real-time monitoring stop working. 

 

I actually don't changed anything on my Synology and don't updated DSM since a while so I really don't understand why I need to configure certain things on my machine if everything worked well just before updating to 4.3.1.0 (from 4.0.2.0). Have you change anything about the way Emby use his real-time monitoring ? 

Link to post
Share on other sites
Luke

Hello !

 

I encounter similar problem, after updating Emby to 4.3.1.0, real-time monitoring stop working. 

 

I actually don't changed anything on my Synology and don't updated DSM since a while so I really don't understand why I need to configure certain things on my machine if everything worked well just before updating to 4.3.1.0 (from 4.0.2.0). Have you change anything about the way Emby use his real-time monitoring ? 

 

No, but i would check the settings for each library to ensure the realtime monitor is enabled. Then the next thing I would do is take a look at this:

https://emby.media/community/index.php?/topic/69684-emby-version-4-real-time-monitoring-is-not-working-synology-241315-and-all-other/?p=757675

 

Please let us know if this helps. Thanks.

Link to post
Share on other sites
Angus2064

Thanks for your response :)

 

I already checked if each of my library have realtime monitor enabled and everything are enabled correctly.  

Also ,I took a look at the other post and I made everything described in this link https://forum.syncth...station/12221/3 but without any change. 

I restart my NAS and also tried to disable and re-enable realtime monitor but no result. 

 

I want to precise again ,this problem occurred only after updating from 4.0.2.0 to 4.3.1.0 ,without any change on my NAS (no DSM update ,no change of any setting ,no adding of any package ...) the hour before updating ,I add 2 movies in my library and 30s later these 2 movies appears in my library (like usually) ,but some hours after updating I add 1 movie in the same library (not a new one) and nothing occur .... the only way actually for add a new movie to my library is to made a manual scan. 

Link to post
Share on other sites
Angus2064

Example :

 

I added "Avengers - Endgame" and "Joker" in my folder named "Film4K" ,this folder is include in my "Movies" library. After waited more than 15 minutes, none of this movies has been added in my "Movies" library. If I want them to be added I need to made a manual scan of this library.

 
I attach my more recent Log

embyserver.txt

Edited by Angus2064
Link to post
Share on other sites
Luke

Example :

 

I added "Avengers - Endgame" and "Joker" in my folder named "Film4K" ,this folder is include in my "Movies" library. After waited more than 15 minutes, none of this movies has been added in my "Movies" library. If I want them to be added I need to made a manual scan of this library.

 

I attach my more recent Log

 

What time you add Avengers? And what did you do in relation to the steps in the other threads with INotify? If you're certain this is the right log, then your problem appears to be outside Emby Server because no notifications were received about file system events.

Link to post
Share on other sites
Angus2064

I follow this link for increase the INotify watches limit https://forum.syncthing.net/t/setting-inotify-limit-permanently-on-synology-diskstation/12221/4

 

After that I restart my Synology and check if the script worked correctly with this command in SSH : cat /proc/sys/fs/inotify/max_user_watches

and the result is = 1048576 ,so it work. 

 

I don't know what to try anymore ...have you any idea ?

Link to post
Share on other sites
Luke

@@Seger do you have any tips? is there a way to monitor inotify events on Synology?

Link to post
Share on other sites
Angus2064

By the way ,I don't know if Plex also use INotify for his real time monitoring but just in case, I install Plex on my NAS and create a library selecting my "Movie4K" folder, after the initial scan finished, I added a new movie in my folder and Plex instantly detect it and add it in the library. 

Link to post
Share on other sites
Seger
 
I have been resting with the real-time monitoring for half decade now and can recommend the setting I set to everyone.
 
Please set the following setting in your Synology Task Scheduler:
sh -c '(sleep 90 && echo 204800 > /proc/sys/fs/inotify/max_user_watches)&'

5e7b0675650be_Syncthingsysctlinotifyfix_

 
5e7b068675cee_Syncthingsysctlinotifyfix_
 
If it still doesn't work, we can go another way via SSH, but I don't think that will be necessary.
 
EDIT: make sure that you have the number written by me: 204800 and the user is "root"!
 
Please provide feedback...
 
Best regards,
Seger
Edited by Seger
Link to post
Share on other sites
Angus2064

Hello Seger ! and thanks for your help !

 

I already do exactly this but with a higher number. So I tried with your number but with no result.

 

After rebooting my NAS and wait some minutes, I tried to add a new movie in my library and Emby still not detect it. In the same time Plex detect it instantly (5-10s).

So if Plex also use inotify for his realtime monitoring ,the problem clearly do not come from here. 

Link to post
Share on other sites
Seger

  1. Edit /etc/sysctl.conf as root: with WinSCP -> see my file in Upload
  2. Set (or add if it's not present) the "fs.inotify.max_user_watches" parameter. Set this to the desired number of watches:fs.inotify.max_user_watches=204800
  3. Save sysctl.conf and exit.

     

  4. root: Either reboot the system or execute the following command: sysctl -p /etc/sysctl.conf

sysctl.zip

Edited by Seger
Link to post
Share on other sites
Angus2064

Done ,no change.
Do you know if Plex also use inotify for realtime monitoring ? That could be helpful for eliminate inotify problem. 

Link to post
Share on other sites
Seger
then I can't figure it out, are you on Synology's current DSM?

 

I can confirm that the realtime monitoring does not work for me even if I update Emby, but with the described way it works for me and all other users.

 

how exactly did you mount your drive into Emby? Can I view on Synology or Windows machine using Teamviewer?  

Link to post
Share on other sites
Angus2064

Yes I'm on Synology's current DSM.

 

Important things to know : all my others app using inotify still working correctly beside of EMBY since the last update. At least Plex and Syncthing both use inotify and everything work perfectly. Also I use Emby since 5 years with this NAS and I never had any problem with realtime monitoring. I do not change anything in the config of the NAS or EMBY, the only thing is the update from 4.0.2.0 to 4.3.1.0. 

 
I reboot Emby server and I attached a log. Please can you take a look and see if everything look okay in boot-up processes ?
 
 

Startup_Log.txt

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...