Jump to content


Photo

4.3.0.30 How to enable real-time monitor

library monitoring

  • Please log in to reply
44 replies to this topic

#1 enr00ted OFFLINE  

enr00ted

    Newbie

  • Members
  • 7 posts
  • Local time: 02:06 PM

Posted 30 November 2019 - 08:15 AM

Hi there everyone, 

 

I found a relatively older thread in this forum about this problem related to some Synology issue. I did a fresh install of the latest version today and it doesn't seem to detect changes. I have 10 movies and 4 series quite a small library. I added a new episode and a new movie.

 

Not that much of a deal but I'd like to know if it's still an issue or if other people are experiencing the same.

 

Cheers.  B)



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156872 posts
  • Local time: 09:06 AM

Posted 30 November 2019 - 11:00 AM

Hi, did you read the other threads about this? The issues on Synology are not an emby problem and can often be solved by configuring certain things on your machine.

#3 patje57 OFFLINE  

patje57

    Advanced Member

  • Members
  • 58 posts
  • Local time: 03:06 PM
  • LocationBelgium

Posted 30 November 2019 - 02:19 PM

Hi there everyone, 

 

I found a relatively older thread in this forum about this problem related to some Synology issue. I did a fresh install of the latest version today and it doesn't seem to detect changes. I have 10 movies and 4 series quite a small library. I added a new episode and a new movie.

 

Not that much of a deal but I'd like to know if it's still an issue or if other people are experiencing the same.

 

Cheers.  B)

 

The link contained in the below message on similar topic solved the inotify limit issue on my DS + survives Synology DSM updates as well.

 

https://emby.media/c...other/?p=757675



#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156872 posts
  • Local time: 09:06 AM

Posted 30 November 2019 - 02:57 PM

Thanks @patje57 !



#5 enr00ted OFFLINE  

enr00ted

    Newbie

  • Members
  • 7 posts
  • Local time: 02:06 PM

Posted 30 November 2019 - 03:13 PM

Thanks I'll give it a try !



#6 Angus2064 OFFLINE  

Angus2064

    Member

  • Members
  • 21 posts
  • Local time: 03:06 PM

Posted 21 March 2020 - 10:25 PM

Hi, did you read the other threads about this? The issues on Synology are not an emby problem and can often be solved by configuring certain things on your machine.

 

Hello !

 

I encounter similar problem, after updating Emby to 4.3.1.0, real-time monitoring stop working. 

I actually don't changed anything on my Synology and don't updated DSM since a while so I really don't understand why I need to configure certain things on my machine if everything worked well just before updating to 4.3.1.0 (from 4.0.2.0). Have you change anything about the way Emby use his real-time monitoring ? 



#7 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156872 posts
  • Local time: 09:06 AM

Posted 21 March 2020 - 10:37 PM

Hello !

 

I encounter similar problem, after updating Emby to 4.3.1.0, real-time monitoring stop working. 

I actually don't changed anything on my Synology and don't updated DSM since a while so I really don't understand why I need to configure certain things on my machine if everything worked well just before updating to 4.3.1.0 (from 4.0.2.0). Have you change anything about the way Emby use his real-time monitoring ? 

 

No, but i would check the settings for each library to ensure the realtime monitor is enabled. Then the next thing I would do is take a look at this:

https://emby.media/c...other/?p=757675

 

Please let us know if this helps. Thanks.



#8 Angus2064 OFFLINE  

Angus2064

    Member

  • Members
  • 21 posts
  • Local time: 03:06 PM

Posted 22 March 2020 - 05:09 PM

Thanks for your response :)

 

I already checked if each of my library have realtime monitor enabled and everything are enabled correctly.  

Also ,I took a look at the other post and I made everything described in this link https://forum.syncth...station/12221/3 but without any change. 

I restart my NAS and also tried to disable and re-enable realtime monitor but no result. 

 

I want to precise again ,this problem occurred only after updating from 4.0.2.0 to 4.3.1.0 ,without any change on my NAS (no DSM update ,no change of any setting ,no adding of any package ...) the hour before updating ,I add 2 movies in my library and 30s later these 2 movies appears in my library (like usually) ,but some hours after updating I add 1 movie in the same library (not a new one) and nothing occur .... the only way actually for add a new movie to my library is to made a manual scan. 



#9 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156872 posts
  • Local time: 09:06 AM

Posted 22 March 2020 - 05:21 PM

Please discuss an example. Thanks.



#10 Angus2064 OFFLINE  

Angus2064

    Member

  • Members
  • 21 posts
  • Local time: 03:06 PM

Posted 22 March 2020 - 06:00 PM

Example :

 

I added "Avengers - Endgame" and "Joker" in my folder named "Film4K" ,this folder is include in my "Movies" library. After waited more than 15 minutes, none of this movies has been added in my "Movies" library. If I want them to be added I need to made a manual scan of this library.

 
I attach my more recent Log

Attached Files


Edited by Angus2064, 22 March 2020 - 06:00 PM.


#11 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156872 posts
  • Local time: 09:06 AM

Posted 23 March 2020 - 12:52 AM

Is the media also on the Nas?

#12 Angus2064 OFFLINE  

Angus2064

    Member

  • Members
  • 21 posts
  • Local time: 03:06 PM

Posted 23 March 2020 - 08:27 PM

Yes



#13 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156872 posts
  • Local time: 09:06 AM

Posted 23 March 2020 - 09:16 PM

Example :

 

I added "Avengers - Endgame" and "Joker" in my folder named "Film4K" ,this folder is include in my "Movies" library. After waited more than 15 minutes, none of this movies has been added in my "Movies" library. If I want them to be added I need to made a manual scan of this library.

 
I attach my more recent Log

 

What time you add Avengers? And what did you do in relation to the steps in the other threads with INotify? If you're certain this is the right log, then your problem appears to be outside Emby Server because no notifications were received about file system events.



#14 Angus2064 OFFLINE  

Angus2064

    Member

  • Members
  • 21 posts
  • Local time: 03:06 PM

Posted 24 March 2020 - 09:56 PM

I follow this link for increase the INotify watches limit https://forum.syncth...station/12221/4

 

After that I restart my Synology and check if the script worked correctly with this command in SSH : cat /proc/sys/fs/inotify/max_user_watches

and the result is = 1048576 ,so it work. 

 

I don't know what to try anymore ...have you any idea ?



#15 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156872 posts
  • Local time: 09:06 AM

Posted 24 March 2020 - 11:45 PM

@Seger do you have any tips? is there a way to monitor inotify events on Synology?



#16 Angus2064 OFFLINE  

Angus2064

    Member

  • Members
  • 21 posts
  • Local time: 03:06 PM

Posted 25 March 2020 - 12:23 AM

By the way ,I don't know if Plex also use INotify for his real time monitoring but just in case, I install Plex on my NAS and create a library selecting my "Movie4K" folder, after the initial scan finished, I added a new movie in my folder and Plex instantly detect it and add it in the library. 



#17 Seger OFFLINE  

Seger

    Advanced Member

  • Members
  • 145 posts
  • Local time: 02:06 PM

Posted 25 March 2020 - 03:22 AM

 
I have been resting with the real-time monitoring for half decade now and can recommend the setting I set to everyone.
 
Please set the following setting in your Synology Task Scheduler:
sh -c '(sleep 90 && echo 204800 > /proc/sys/fs/inotify/max_user_watches)&'

5e7b0675650be_Syncthingsysctlinotifyfix_

 
5e7b068675cee_Syncthingsysctlinotifyfix_
 
If it still doesn't work, we can go another way via SSH, but I don't think that will be necessary.
 
EDIT: make sure that you have the number written by me: 204800 and the user is "root"!
 
Please provide feedback...
 
Best regards,
Seger

Edited by Seger, 25 March 2020 - 03:42 AM.


#18 Angus2064 OFFLINE  

Angus2064

    Member

  • Members
  • 21 posts
  • Local time: 03:06 PM

Posted 25 March 2020 - 01:57 PM

Hello Seger ! and thanks for your help !

 

I already do exactly this but with a higher number. So I tried with your number but with no result.

 

After rebooting my NAS and wait some minutes, I tried to add a new movie in my library and Emby still not detect it. In the same time Plex detect it instantly (5-10s).

So if Plex also use inotify for his realtime monitoring ,the problem clearly do not come from here. 



#19 Seger OFFLINE  

Seger

    Advanced Member

  • Members
  • 145 posts
  • Local time: 02:06 PM

Posted 25 March 2020 - 03:05 PM

  1. Edit /etc/sysctl.conf as root: with WinSCP -> see my file in Upload
  2. Set (or add if it's not present) the "fs.inotify.max_user_watches" parameter. Set this to the desired number of watches:fs.inotify.max_user_watches=204800
  3. Save sysctl.conf and exit.
     
  4. root: Either reboot the system or execute the following command: sysctl -p /etc/sysctl.conf

Attached Files


Edited by Seger, 11 April 2020 - 03:05 AM.


#20 Angus2064 OFFLINE  

Angus2064

    Member

  • Members
  • 21 posts
  • Local time: 03:06 PM

Posted 25 March 2020 - 04:24 PM

Done ,no change.
Do you know if Plex also use inotify for realtime monitoring ? That could be helpful for eliminate inotify problem. 







Also tagged with one or more of these keywords: library, monitoring

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users