Jump to content

Troubleshooting loading problems ubuntu 16.04


kjenkins46214
 Share

Recommended Posts

kjenkins46214

Recently my Emby server (version 4.2.1.0) has been pausing and reloading some but not all video episodes in my library. I use roku, a homerun hd device for live tv and a secondary roku (older) in another room.  The videos pause the loading message comes up after a few moments.  I have switched rokus, replaced router and even the mobile apps do same thing.The live tv via emby freezes but the other roku apps are fine, no problems  I did donwgrade one version to 4.2.0.40 but same issues.

Thanks

 

ffmpeg-transcode-1f62c5e0-2a2f-4d4a-bdfe-27c01f698d1d_1.txt

ffmpeg-transcode-b460c20d-d3a0-435b-a927-f351352b97e0_1.txt

embyserver.txt

Link to comment
Share on other sites

kjenkins46214

I updated back to the current version. The mobile version of emby seems to be working but the roku still has trouble.  I tested some of the video series in the browser Windows 7 Firefox version 70.0.1 And was freesing.  Viewing the server status page the videos freezing seem to be one that transcode.  Direct play looks to be fine.  Attached are a couple of log files.

 

Thanks

 

ffmpeg-transcode-b3a501b7-a1ef-4963-b9e7-29bb71afef66_1.txt

ffmpeg-transcode-953c74e3-84c0-4537-b81f-bfcec26c97c6_1.txt

ffmpeg-transcode-c45e1bbd-0298-4510-a11f-d83e82947343_1.txt

ffmpeg-transcode-88798717-cd58-4dfb-929c-b030cf1d2482_1.txt

Link to comment
Share on other sites

kjenkins46214

I did find the problem, I believe.  The Videos that are freezing up are using ac3 audio codex (Dolby) which is not compatable with my equipment.  Those videos that are playing fine use aac audio codex.  So Im trying to find a script to change the codex relatively easy. I have about 9tb of video with mixed codex.

 

Will keep you posted. This might help others having simular problems.

 

Link to comment
Share on other sites

I updated back to the current version. The mobile version of emby seems to be working but the roku still has trouble.  I tested some of the video series in the browser Windows 7 Firefox version 70.0.1 And was freesing.  Viewing the server status page the videos freezing seem to be one that transcode.  Direct play looks to be fine.  Attached are a couple of log files.

 

Thanks

 

You're not getting fast enough transcoding for this to be playable smoothly, see here:

elapsed=00:01:05.61 frame=  407 fps=6.2 q=29.0 size=    1238kB time=00:00:13.67 bitrate= 741.7kbits/s dup=80 drop=0 throttle=off speed=0.208x 

Are you sure your machine can handle this? This is not an issue with Emby Server, but rather, it sounds like you want to focus your video playback on files that your Roku can direct play without any transcoding.

Link to comment
Share on other sites

kjenkins46214

You are correct.  I did some checking with the videos causing the problems.  They are transcoding due to the audio ac3 codec. The server is a basic converted dell that obviously can not handle the transcoding but streams direct fine (its only job is streaming).  I did solve the issue, thanks to the community guiding where to look.  I modified a bash script to fix the problems and now it works without problems.

 

#!/bin/bash

mkdir fixed     #did not want to change file names

for i in *.mp4;

do ffmpeg -i "$i" -c:v copy -c:a aac "${./fixed/i%.*}.mkv;

done

 

will be adding a line to delete original files and move content from fixed folder back to original folder (1 level).

Hope this script helps others

Thank you for your guidence.

Situation fixed.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...