Jump to content


Photo

Troubleshooting loading problems ubuntu 16.04

Ubuntu Freezing Loading

  • Please log in to reply
6 replies to this topic

#1 kjenkins46214 OFFLINE  

kjenkins46214

    Newbie

  • Members
  • 4 posts
  • Local time: 12:45 PM

Posted 09 November 2019 - 01:46 AM

Recently my Emby server (version 4.2.1.0) has been pausing and reloading some but not all video episodes in my library. I use roku, a homerun hd device for live tv and a secondary roku (older) in another room.  The videos pause the loading message comes up after a few moments.  I have switched rokus, replaced router and even the mobile apps do same thing.The live tv via emby freezes but the other roku apps are fine, no problems  I did donwgrade one version to 4.2.0.40 but same issues.

Thanks

 

Attached Files



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142520 posts
  • Local time: 12:45 PM

Posted 09 November 2019 - 01:47 AM

Hi, i would suggest updating back to the latest version of the server, and then let's help you on that version if the issue persists. thanks.



#3 kjenkins46214 OFFLINE  

kjenkins46214

    Newbie

  • Members
  • 4 posts
  • Local time: 12:45 PM

Posted 10 November 2019 - 12:34 AM

I updated back to the current version. The mobile version of emby seems to be working but the roku still has trouble.  I tested some of the video series in the browser Windows 7 Firefox version 70.0.1 And was freesing.  Viewing the server status page the videos freezing seem to be one that transcode.  Direct play looks to be fine.  Attached are a couple of log files.

 

Thanks

 



#4 kjenkins46214 OFFLINE  

kjenkins46214

    Newbie

  • Members
  • 4 posts
  • Local time: 12:45 PM

Posted 10 November 2019 - 09:28 PM

I did find the problem, I believe.  The Videos that are freezing up are using ac3 audio codex (Dolby) which is not compatable with my equipment.  Those videos that are playing fine use aac audio codex.  So Im trying to find a script to change the codex relatively easy. I have about 9tb of video with mixed codex.

 

Will keep you posted. This might help others having simular problems.

 



#5 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142520 posts
  • Local time: 12:45 PM

Posted 11 November 2019 - 12:00 AM

I updated back to the current version. The mobile version of emby seems to be working but the roku still has trouble.  I tested some of the video series in the browser Windows 7 Firefox version 70.0.1 And was freesing.  Viewing the server status page the videos freezing seem to be one that transcode.  Direct play looks to be fine.  Attached are a couple of log files.

 

Thanks

 

You're not getting fast enough transcoding for this to be playable smoothly, see here:

elapsed=00:01:05.61 frame=  407 fps=6.2 q=29.0 size=    1238kB time=00:00:13.67 bitrate= 741.7kbits/s dup=80 drop=0 throttle=off speed=0.208x 

Are you sure your machine can handle this? This is not an issue with Emby Server, but rather, it sounds like you want to focus your video playback on files that your Roku can direct play without any transcoding.



#6 kjenkins46214 OFFLINE  

kjenkins46214

    Newbie

  • Members
  • 4 posts
  • Local time: 12:45 PM

Posted 11 November 2019 - 12:28 AM

You are correct.  I did some checking with the videos causing the problems.  They are transcoding due to the audio ac3 codec. The server is a basic converted dell that obviously can not handle the transcoding but streams direct fine (its only job is streaming).  I did solve the issue, thanks to the community guiding where to look.  I modified a bash script to fix the problems and now it works without problems.

 

#!/bin/bash

mkdir fixed     #did not want to change file names

for i in *.mp4;

do ffmpeg -i "$i" -c:v copy -c:a aac "${./fixed/i%.*}.mkv;

done

 

will be adding a line to delete original files and move content from fixed folder back to original folder (1 level).

Hope this script helps others

Thank you for your guidence.

Situation fixed.



#7 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142520 posts
  • Local time: 12:45 PM

Posted 11 November 2019 - 03:11 PM

Thanks for the feedback.







Also tagged with one or more of these keywords: Ubuntu, Freezing, Loading

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users