Jump to content

Pixelation and Glitching in Recorded TV using Emby DVR


EmbyKiwi
Go to solution Solved by EmbyKiwi,

Recommended Posts

On 9/22/2020 at 7:18 AM, bobdob said:

4.3.1.0 worked perfectly.

Updated to 4.5.0.50 no glitching during recording so far.

 

Thanks for the feedback !

Link to comment
Share on other sites

I am using 4.5.2.0 but I have switched to Ubuntu as my Emby server.  I have not noticed the pixelation problems with limited testing, however I have mainly been using Channels DVR.  I am currently trying Channels DVR as a tuner with Hulu Live as the source for Emby and it seems to work pretty well, though I haven't incorporated all of the channels from Hulu.  Here's the thread https://community.getchannels.com/t/use-channels-dvr-as-a-tuner-for-emby/22486  I like the interface of Emby better, but I just want something to work.  If Emby can incorporate the commercial skipping as Channels does, add TV Everywhere Integration,  and dramatically cut down on the time to tune to a channel ( when tuning to a channel in Emby it can take 5-10 seconds of 'circling' before tuning to the channel) I will probably switch back.

Link to comment
Share on other sites

6 hours ago, dougward said:

I am using 4.5.2.0 but I have switched to Ubuntu as my Emby server.  I have not noticed the pixelation problems with limited testing, however I have mainly been using Channels DVR.  I am currently trying Channels DVR as a tuner with Hulu Live as the source for Emby and it seems to work pretty well, though I haven't incorporated all of the channels from Hulu.  Here's the thread https://community.getchannels.com/t/use-channels-dvr-as-a-tuner-for-emby/22486  I like the interface of Emby better, but I just want something to work.  If Emby can incorporate the commercial skipping as Channels does, add TV Everywhere Integration,  and dramatically cut down on the time to tune to a channel ( when tuning to a channel in Emby it can take 5-10 seconds of 'circling' before tuning to the channel) I will probably switch back.

Thanks @dougward. That is certainly an interesting approach to the problem! 🙂

Seems as though much of the thread is about getting an accurate  EPG. We are lucky here in NZ that we only have one time zone and there is a pretty good XML EPG provided by the Open Source community. It's what I use in Emby itself and it works great. 

My current solution is still to just wait till the recording has finished before watching it and then the Emby native DVR works fine.  If I have something I need to watch that is more time critical, I just flick back to Mediaportal and watch it on there. Just as reliable as Channels DVR and no monthly fee! 🙂 

Link to comment
Share on other sites

I don't get the appeal of Channels DVR except for those in the USA who want to use Locast and TVEverywhere functionality.

Link to comment
Share on other sites

6 minutes ago, cayars said:

I don't get the appeal of Channels DVR except for those in the USA who want to use Locast and TVEverywhere functionality.

It seems to be one of the few DVRs for free-to-air TV with clients for Android TV etc that reliably copes with watching recordings while they are recording and skipping ads  till you catch up to live. Emby DVR does this for some users and not for others. The fact that Channels DVR doesn't provide a EPG for little places like NZ does reduce it's appeal outside the USA. 🙂

It certainly didn't have anywhere near the features or interface for other media that Emby has.

I've used Mediaportal for recording TV for over a decade and this also works perfectly... except ... it only has a Windows client so less WAF with the remote and switching between TV/Netflix/Movies etc. 

Link to comment
Share on other sites

Fortunately (or not) I live in the USA so I can get an EPG.  Using TV everywhere allows me to save on the number of concurrent streams from Hulu offsetting the cost of Channels.  As I mentioned in a earlier post, I have an HD Homerun so I get the OTA channels and Hulu Live in one guide.  One guide also adds a lot of usability convenience for others in my house.  Although it doesn't mean as much now since my kids are older, having the recordings stored on a local device can also be useful.  I agree, I like the Emby interface better.  I've already paid the lifetime for Emby so I would like to eliminate Channels if possible, but we've gotten used to the ad skipping and EPG integration of OTA channels and Hulu and a functional DVR to watch an active recording is imperative.

Link to comment
Share on other sites

  • 5 months later...

 

On 20/10/2020 at 12:36, Luke said:

No eta but it is getting closer.

@Luke

Hi Luke

Just a bit of a bump on this topic and wondering whether the 'getting closer' is 'getting any closer' ? 🙂

Cheers. 

Link to comment
Share on other sites

  • 3 months later...
  • Solution

Success!! ( I hope!)

Having tried everything I could think of to make my setup work reliably with catch-up playback while recording, I decided to bite the bullet and buy a brand new HD Homerun.... despite the fact that I already had two dual tuner versions that had worked perfectly for years with many other bits of software and worked fine recording with Emby, as long as I didn't try and playback while recording. Due to supply issues, the only one I could buy was the Quad tuner, so I was looking forward to having 8 tuners at my disposal!  🙂

I disconnected Emby from the original HDHR3-DT Dual DVB-T tuner that it had been using and connected it to the new Quad Tuner. I then ran some very basic tests and it seemed to be working OK. So, I set it up to record the news each night and tried watching it with a delayed start, skipping through the ads and... 'voila' , it appears to have been working well for the last 4/5 days!!! 😀 

After all this time chasing this problem, it appears that not all HD Homeruns are made the same!  I had applied every firmware update etc to the old units but apparently something in them upset Emby but not other software. I'll keep testing it for a bit longer but, finally, I might be able to turn off my trusty Mediaportal server and rely on Emby for ALL my media needs! Happy days!

I obviously don't know at what point the HD Homeruns changed but... if someone else is having similar issues with older HD Homeruns then it might be worth trying to beg, borrow or buy a newer model and see if it resolves your issues too.

Link to comment
Share on other sites

@cayarsIts a bit hard to remember exactly when I got them. Freeview (Digital Terrestrial) hit NZ in about 2008 and I originally had Hauppauge cards  in the media server. I probably swapped to the HD Homeruns around 3 years later so I'd guess they are around 10 years old? They have generally just kept working so I've kept using them. 🙂 They are definitely the HDHR'3'.  The new one is an HDHR'5' so a couple of generations later I guess and presumably there are HDHR'4's out there as well.

It would be interesting to understand what versions  other users have been using. Both those with no problems like yourself and the few who had problems on Windows like  @dougward and myself. Then again... someone is bound to have had no issues at all with their HDHR3s ! 🙂 

  • Thanks 1
Link to comment
Share on other sites

I have a HDHR5-4US and I have/had the pixelation problems.  I can't say that I still have the problems since I am now running Emby on Ubuntu and have been for at least the last 9 months or so.  Since running on Ubuntu, I do not have the pixelation issues.  I have not tried running the latest Emby on the latest Windows for sometime.  As I mentioned in one of my previous posts, I'm using Channels DVR on Windows which works, though I'm not thrilled with the features, but it does work.  I can also use Channels DVR as a tuner for Emby as I mentioned in one of my previous posts so I get all the Hulu Live channels in Emby via TV Everywhere from Channels.  If I'm brave, I may give Emby on Windows another shot or I may just install Ubuntu on another machine and run Emby and Channels DVR on the same box.  Glad it works for you @Embykiwi, but the pixelation problems I had did use the HDHR5-4US with the latest firmware.

Link to comment
Share on other sites

@dougward Murphy's Law! Somehow I just knew that would be the case! 🙂 

Oh well. It seems to be working OK for me so far so I'm going to take the win.... even if only temporarily! I will still be very interested to see if this new big re-write of the TV services allows me to use my older units again.... though I suspect Luke and the team have been rather busy with the 4.6.x rollouts lately so it's probably a wee way off still. 🙂 Probably safer to stick with Ubuntu for now.

I haven't had a chance to test it with longer programs (like sports games) but given how easy it was to break before, even if it's not perfect now, it's still a lot better than the older units for me.  Cheers 

Link to comment
Share on other sites

@EmbyKiwi Got a windows machine you can use just for testing while still continuing to use Ubuntu?

You can certainly use your existing Premiere Key on both servers.

Link to comment
Share on other sites

Not exactly. I have the machine I run Channels on.  It's a matter of taking the time to do it or putting a machine together to do it.

Link to comment
Share on other sites

@cayars I'm still on Windows. My comments about Ubuntu before were to @dougward who moved from Windows to Ubuntu to resolve the problem.  

I do have a 'test' Windows server I use for trying different things before I roll them into production so happy to help with testing once the new TV Services are getting close if it is any help. 🙂 

  • Like 1
Link to comment
Share on other sites

Final post on this one hopefully! 🙂 

I've been recording the nightly news all week and watching it with a delayed start and haven't had any corruptions so it certainly appears that the new HD Homerun has made a big difference for me. I also tried recording the news on 2 stations at once one evening and having a friend watch the other channel with a delayed start. Both recordings played fine with someone watching while recording... although he did have issues with not being able to FF or rewind on his Samsung Tizen TV. From what I've seen in other threads however this appears to be an issue in the Samsung client rather than at my server so we counted that as a win as well. 

Cheers

  • Like 1
Link to comment
Share on other sites

1 hour ago, cayars said:

@EmbyKiwi Do you by any chance have a spare PC you could install another Emby Server on for testing?

@cayars Absolutely! 🙂 

Happy to help with any testing that is required... on both new and old HD Homeruns! 🙂 

Link to comment
Share on other sites

What I'd like to know is if you setup a minimal Emby Server and just added one of your old Tuners to it would it work or have the same issues you had previously on your main Emby Server?

I can't help but wonder if installing the new tuner changed something that now allows it to work better.  I'd really want to know if using one of the old cards on your main system now would still have an issue but since you have things working well there I'd rather you not fool with it.

So testing the old tuners on a different PC/Server would be the next best test.

If you want to do this first install the HDHomeRun software for setup on the PC, then install Emby Server as usual.

Link to comment
Share on other sites

I have installed Emby on various other PCs previously with the old tuners to see if the issues were unique to my main Emby server.  At that stage they all had the same issues. 

One of my other PCs still has Emby installed so I'll do as you suggest and uninstall Emby, install the latest HD Homerun drivers, re-install Emby, point it at the old HD Homerun and let you know what happens. 🙂

 

Cheers

 

  • Thanks 1
Link to comment
Share on other sites

  • 3 months later...

Firstly 'Holy Thread Revival'

 

With that out of the way; I wanted to bump this topic for an update.

 

I'd been struggling with this issue for quite some time now. I record the same two programs daily - I can go a few days with perfect recordings, then, every now and then I will come accross bad patches, where this issue is present almost all the way through some recordings even.

 

screenshot of a same frame of this issue:

image.thumb.png.87ab8812fb40b1e2603d2b4af101e856.png

I've often wondered if this is happening due to poor signal; so I setup a spare Freeview DVR to record with the same shedule - I'm sorry to say its been perfect every time! - meaning the issue must lie somewhere with Emby / my setup of emby / my HD Homerun.

 

I think I can eliminate the HD Homerun - I have used this quite a lot to watch / record TV before I was using Emby for this and never had this issue.

 

my Emby instance is running on Docker on a server with 24 cores and 64GB memory availble. This server has various SQL databases, other dockers etc running on the same storage array - this has been my main suspicion for some time; however I have still encountered the same issue with everything else stopped, in addition to moving emby's storage over to a dedicaded SSD - no notcable change.

 

No physical GPU assigned, all transcoding is software.

 

I havent been able to find anything obvious to this in the log files.

 

Really beggining to reach my limits with this, having lost a fair number of episodes I've tried to record  -  all whilst pushing this on the family as a replacement for the old TV DVR, which has been irritatingly flawless!

 

Really would appreciate any help / suggestions - will natraully be happy to test and feedback if needed.

 

Is this something that is activly being looked at?

 

Thanks :)

Link to comment
Share on other sites

1 hour ago, MostlyBroken said:

Firstly 'Holy Thread Revival'

 

With that out of the way; I wanted to bump this topic for an update.

 

I'd been struggling with this issue for quite some time now. I record the same two programs daily - I can go a few days with perfect recordings, then, every now and then I will come accross bad patches, where this issue is present almost all the way through some recordings even.

 

screenshot of a same frame of this issue:

image.thumb.png.87ab8812fb40b1e2603d2b4af101e856.png

I've often wondered if this is happening due to poor signal; so I setup a spare Freeview DVR to record with the same shedule - I'm sorry to say its been perfect every time! - meaning the issue must lie somewhere with Emby / my setup of emby / my HD Homerun.

 

I think I can eliminate the HD Homerun - I have used this quite a lot to watch / record TV before I was using Emby for this and never had this issue.

 

my Emby instance is running on Docker on a server with 24 cores and 64GB memory availble. This server has various SQL databases, other dockers etc running on the same storage array - this has been my main suspicion for some time; however I have still encountered the same issue with everything else stopped, in addition to moving emby's storage over to a dedicaded SSD - no notcable change.

 

No physical GPU assigned, all transcoding is software.

 

I havent been able to find anything obvious to this in the log files.

 

Really beggining to reach my limits with this, having lost a fair number of episodes I've tried to record  -  all whilst pushing this on the family as a replacement for the old TV DVR, which has been irritatingly flawless!

 

Really would appreciate any help / suggestions - will natraully be happy to test and feedback if needed.

 

Is this something that is activly being looked at?

 

Thanks :)

Hi, yes we are working on improving it. Thanks for reporting.

Link to comment
Share on other sites

1 hour ago, Luke said:

Hi, yes we are working on improving it. Thanks for reporting.

Thanks Luke - sorry to push a little; however, is there any rough estimate on a timeline for a potential fix / improvement?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...