Jump to content


Photo

How do I stop EMBY from adding sets?

Movies Sets Metadata

  • Please log in to reply
23 replies to this topic

#1 icedragonslair OFFLINE  

icedragonslair

    Advanced Member

  • Members
  • 34 posts
  • Local time: 12:33 PM

Posted 21 October 2019 - 01:10 AM

How do I stop EMBY from adding sets? it is quite literally destroying my collection

 

Thank you,

Ice



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142514 posts
  • Local time: 12:33 PM

Posted 21 October 2019 - 01:32 AM

Hi, what do you mean by sets?



#3 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 16590 posts
  • Local time: 09:33 AM
  • LocationWashington State

Posted 21 October 2019 - 06:29 AM

Only the Auto box set plugin will automatically create collections/sets.  Emby by itself will never create them.



#4 icedragonslair OFFLINE  

icedragonslair

    Advanced Member

  • Members
  • 34 posts
  • Local time: 12:33 PM

Posted 21 October 2019 - 12:19 PM

Well, when I allow the the emby server to run, upon scanning the libraries it changes to suit it's own sets/collections. Example: i keep a lot of 'B' movies in my library (guilty pleasure) and I have each movie in its own folder than I have them all in a folder named '1950's Sci-Fi, Horror and Fantasy Movies (1920-1959)' then i set as a collection by writing my own metadata and it works flawlessly in kodi. I have been trying to move my collection to emby as a server and kodi as a headend. I have not been able to get past the initial library scan without new collections listing these movies in separate collections by themselves.

 

Another example is that it splits the marvel universe movies up and instead of keeping the structure i set for them, it changes the metadata collection # and set title to the separate collections

 

Is there any way to stop this at all, I have not downloaded anything extra at this point for this software after I decided to give it another try

 

Thank loads,

 

Ice  



#5 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 16590 posts
  • Local time: 09:33 AM
  • LocationWashington State

Posted 21 October 2019 - 12:27 PM

Sorry are you talking about folder structure or metadata?



#6 icedragonslair OFFLINE  

icedragonslair

    Advanced Member

  • Members
  • 34 posts
  • Local time: 12:33 PM

Posted 21 October 2019 - 02:53 PM

I described the folder because that is the way my media and my metadata are set up

 

first pic is an example of folder structure to show you its physical layout and the following two pics are of a before (charles Bronson) and after Death Wish. I am not running any other programs when this is occuring

 

5dadfe5a0fb8b_charlesbronsonfolders.jpg

 

5dadfe6dc72f1_metadatabefore.jpg

 

5dadff56aa054_Snap1.jpg

 

I hope this helps make it clearer.

 

thanks loads,

Ice


Edited by icedragonslair, 21 October 2019 - 02:57 PM.


#7 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142514 posts
  • Local time: 12:33 PM

Posted 21 October 2019 - 02:56 PM

Ok the set tag in the nfo comes from MovieDb. Unfortunately right now we do not have any settings to stop it apart from disabling Moviedb altogether, or locking the particular items in question. or i suppose turning off nfo saving, but if you have nfo files already, that could cause problems down the line.



#8 icedragonslair OFFLINE  

icedragonslair

    Advanced Member

  • Members
  • 34 posts
  • Local time: 12:33 PM

Posted 21 October 2019 - 06:58 PM

So it's a change that movieDB instituted?

 

Hmm, is there a way to not use anything but local data period? Since I do my own metadata (i'm sure this will have to change, metabrowser is getting real sketchy).

 

Thanks loads,

Ice



#9 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142514 posts
  • Local time: 12:33 PM

Posted 21 October 2019 - 07:05 PM

Yes you can disable nfo saving. But then just be aware that any metadata Emby downloads will not be saved to your nfo, which means those changes could end up getting lost later if the nfo ever changes and the server sync back from the nfo to the local db.



#10 pünktchen ONLINE  

pünktchen

    Advanced Member

  • Members
  • 2260 posts
  • Local time: 06:33 PM

Posted 21 October 2019 - 08:48 PM

Ok the set tag in the nfo comes from MovieDb. Unfortunately right now we do not have any settings to stop it apart from disabling Moviedb altogether, or locking the particular items in question. or i suppose turning off nfo saving, but if you have nfo files already, that could cause problems down the line.

Afaik the Emby nfo provider doesn't read or write the <set> tag.

Edit1: Or is this new? Or does it only write but not read the set tag?

Edit2: I looked at the code and it seems to read and write. But why is then overwritten with online data?

Edited by pünktchen, 21 October 2019 - 08:56 PM.


#11 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142514 posts
  • Local time: 12:33 PM

Posted 21 October 2019 - 09:34 PM

Because that's what users wanted. You can ask the same question for any other field.

#12 pünktchen ONLINE  

pünktchen

    Advanced Member

  • Members
  • 2260 posts
  • Local time: 06:33 PM

Posted 22 October 2019 - 02:52 AM

Because that's what users wanted. You can ask the same question for any other field.

What? I thought the local metadata gets only overwritten when we use "Refresh" but not when we use "Scan for new files".

#13 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142514 posts
  • Local time: 12:33 PM

Posted 22 October 2019 - 11:40 AM

That's correct yes.

#14 pünktchen ONLINE  

pünktchen

    Advanced Member

  • Members
  • 2260 posts
  • Local time: 06:33 PM

Posted 22 October 2019 - 01:35 PM

So how is the "set" changed from "Charles Bronson" to "Death Wish" in the nfo of the OP?
@icedragonslair what are you doing when you move a new movie to your library?

Edited by pünktchen, 22 October 2019 - 01:37 PM.


#15 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142514 posts
  • Local time: 12:33 PM

Posted 22 October 2019 - 01:37 PM

With the regular library scan it shouldn't be. @Happy2Play are you able to reproduce?



#16 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 16590 posts
  • Local time: 09:33 AM
  • LocationWashington State

Posted 22 October 2019 - 07:53 PM

With the regular library scan it shouldn't be. @Happy2Play are you able to reproduce?

Importing with existing nfo metadata, Scanning or Searching for missing did not change the <set> tag.  Only Replace all reset the tag in my testing on 4.2.1.0 and 4.3.0.15.


  • pünktchen likes this

#17 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142514 posts
  • Local time: 12:33 PM

Posted 22 October 2019 - 09:43 PM

Thanks that's what I expected.

#18 icedragonslair OFFLINE  

icedragonslair

    Advanced Member

  • Members
  • 34 posts
  • Local time: 12:33 PM

Posted 24 October 2019 - 04:43 PM

 

Basically i just move the file to my server and create the nfo (via metabrowser), Making sure that all collection info is blank, except for my set info as you saw it.

All i do is let it run its scheduled scans and nothing more. That is also why this is so perplexing to me as well. I only have my media server, EMBY server (different PC), emby theater,  I have kodi running on my nvidia shield but the 'display sets' is turned off and all media is set to local info only.

 

Thanks loads for any help,

 

Ice 

 

PS

I wish someone could pick up where fatal left off, but I don't think anyone has even heard from him at all...


Edited by icedragonslair, 24 October 2019 - 04:50 PM.


#19 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142514 posts
  • Local time: 12:33 PM

Posted 24 October 2019 - 04:44 PM

Unfortunately it's too late to speculate about what might have happened in the past, but currently I don't this will happen. If you see it happen again with a new title, then please capture the emby server log. thanks.



#20 icedragonslair OFFLINE  

icedragonslair

    Advanced Member

  • Members
  • 34 posts
  • Local time: 12:33 PM

Posted 26 October 2019 - 09:51 AM

I just finished cleaning up the library and logs. When I was looking through them, I didn't notice anything strange. But I do have a question about this.

Seems on my son's system I found mp2 running in the background and it had access to those two folders (movie_collections & movies). I do not know how this happened but have uninstalled this. 

 

Could MP2 have been the culprit?

 

Thanks loads,

 

Ice







Also tagged with one or more of these keywords: Movies, Sets, Metadata

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users