Jump to content


Photo

Cannot play media with subtitles

subtitles

  • Please log in to reply
32 replies to this topic

#21 pwhodges OFFLINE  

pwhodges

    Advanced Member

  • Members
  • 290 posts
  • Local time: 04:45 PM
  • LocationOxford, UK

Posted 15 October 2019 - 03:35 AM

 

Could you please try to run this command manually from the command line?
 

C:\Users\DrEngelsk\Desktop\Emby Server\system\ffmpeg.exe -f matroska -i file:"F:\Udenlandske Film\Deadpool.1080p-Danishbits.mkv" -map 0:0 -map 0:1 -c:v:0 libx264 -force_key_frames "expr:gte(t,n_forced*5)" -copyts -filter_complex "[0:0]scale=trunc(min(max(iw\,ih*dar)\,1920)/2)*2:trunc(ow/dar/2)*2,subtitles='F\:/Udenlandske Film/Deadpool.1080p-Danishbits.mkv:si=0':force_style='FontName=Droid Sans Fallback':fontsdir='C\:/Users/DrEngelsk/Desktop/Emby Server/programdata/fonts'" -avoid_negative_ts disabled -start_at_zero -pix_fmt yuv420p  -maxrate 10076743 -bufsize 20153486 -preset veryfast -profile:v:0 high -level:v:0 4.1 -crf 20 -x264opts:0 subme=0:me_range=4:rc_lookahead=10:me=dia:no_chroma_me:8x8dct=0:partitions=none -vsync -1 -map_metadata -1 -map_chapters -1 -threads 1 -codec:a:0 ac3 -metadata:s:a:0 language=eng -disposition:a:0 default -ac:a:0 6 -ab:a:0 384000 -ar:a:0 48000  -y "C:\Users\DrEngelsk\Desktop\Emby Server\programdata\transcoding-temp\a8d7351d29092d62830538ad08e5b5e5.mkv"

 

Will fail because the path with a space in requires the actual program path/name to be surrounded by quotes...


Edited by pwhodges, 15 October 2019 - 03:37 AM.


#22 softworkz OFFLINE  

softworkz

    Advanced Member

  • Developers
  • 1863 posts
  • Local time: 05:45 PM

Posted 15 October 2019 - 03:37 AM

Will fail because the path with a space in requires the command to be surrounded by quotes...

 

Sorry, you're right. 

You could quote it, or you can also just navigate to that directory and then execute starting from 'ffmpeg...'



#23 drengelsk OFFLINE  

drengelsk

    Newbie

  • Members
  • 8 posts
  • Local time: 05:45 PM

Posted 15 October 2019 - 03:38 AM

Softworkz, do you want me to run the commands in CMD or somewhere in Emby?

#24 softworkz OFFLINE  

softworkz

    Advanced Member

  • Developers
  • 1863 posts
  • Local time: 05:45 PM

Posted 15 October 2019 - 03:39 AM

in cmd



#25 drengelsk OFFLINE  

drengelsk

    Newbie

  • Members
  • 8 posts
  • Local time: 05:45 PM

Posted 15 October 2019 - 12:39 PM

It didn't seem to work quite well...

Attached Files



#26 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 16198 posts
  • Local time: 08:45 AM
  • LocationWashington State

Posted 15 October 2019 - 02:55 PM

It didn't seem to work quite well...

But you have to edit the command as mentioned above.  Either "cd" to the system folder or add quotes around the ffmpeg path do to the break in "Emby Server".

"C:\Users\DrEngelsk\Desktop\Emby Server\system\ffmpeg.exe" -f matroska -i file:"F:\Udenlandske Film\Deadpool.1080p-Danishbits.mkv" -map 0:0 -map 0:1 -c:v:0 libx264 -force_key_frames "expr:gte(t,n_forced*5)" -copyts -filter_complex "[0:0]scale=trunc(min(max(iw\,ih*dar)\,1920)/2)*2:trunc(ow/dar/2)*2,subtitles='F\:/Udenlandske Film/Deadpool.1080p-Danishbits.mkv:si=0':force_style='FontName=Droid Sans Fallback':fontsdir='C\:/Users/DrEngelsk/Desktop/Emby Server/programdata/fonts'" -avoid_negative_ts disabled -start_at_zero -pix_fmt yuv420p  -maxrate 10076743 -bufsize 20153486 -preset veryfast -profile:v:0 high -level:v:0 4.1 -crf 20 -x264opts:0 subme=0:me_range=4:rc_lookahead=10:me=dia:no_chroma_me:8x8dct=0:partitions=none -vsync -1 -map_metadata -1 -map_chapters -1 -threads 1 -codec:a:0 ac3 -metadata:s:a:0 language=eng -disposition:a:0 default -ac:a:0 6 -ab:a:0 384000 -ar:a:0 48000  -y "C:\Users\DrEngelsk\Desktop\Emby Server\programdata\transcoding-temp\a8d7351d29092d62830538ad08e5b5e5.mkv"

Edited by Happy2Play, 15 October 2019 - 02:56 PM.


#27 softworkz OFFLINE  

softworkz

    Advanced Member

  • Developers
  • 1863 posts
  • Local time: 05:45 PM

Posted 15 October 2019 - 04:34 PM

It didn't seem to work quite well...


I apologize. Here's the precise steps you need to perform:


STEP 1
 

cd "C:\Users\DrEngelsk\Desktop\Emby Server\system"

STEP 2
 

ffmpeg.exe -f matroska -i file:"F:\Udenlandske Film\Deadpool.1080p-Danishbits.mkv" -map 0:0 -map 0:1 -c:v:0 libx264 -force_key_frames "expr:gte(t,n_forced*5)" -copyts -filter_complex "[0:0]scale=trunc(min(max(iw\,ih*dar)\,1920)/2)*2:trunc(ow/dar/2)*2,subtitles='F\:/Udenlandske Film/Deadpool.1080p-Danishbits.mkv:si=0':force_style='FontName=Droid Sans Fallback':fontsdir='C\:/Users/DrEngelsk/Desktop/Emby Server/programdata/fonts'" -avoid_negative_ts disabled -start_at_zero -pix_fmt yuv420p  -maxrate 10076743 -bufsize 20153486 -preset veryfast -profile:v:0 high -level:v:0 4.1 -crf 20 -x264opts:0 subme=0:me_range=4:rc_lookahead=10:me=dia:no_chroma_me:8x8dct=0:partitions=none -vsync -1 -map_metadata -1 -map_chapters -1 -threads 1 -codec:a:0 ac3 -metadata:s:a:0 language=eng -disposition:a:0 default -ac:a:0 6 -ab:a:0 384000 -ar:a:0 48000  -y "C:\Users\DrEngelsk\Desktop\Emby Server\programdata\transcoding-temp\a8d7351d29092d62830538ad08e5b5e5.mkv"

STEP 3

ffmpeg.exe -f matroska -i file:"F:\Udenlandske Film\Deadpool.1080p-Danishbits.mkv" -map 0:0 -map 0:1 -c:v:0 libx264 -force_key_frames "expr:gte(t,n_forced*5)" -copyts -filter_complex "[0:0]scale=trunc(min(max(iw\,ih*dar)\,1920)/2)*2:trunc(ow/dar/2)*2,subtitles='F\:/Udenlandske Film/Deadpool.1080p-Danishbits.mkv':si=0:force_style='FontName=Droid Sans Fallback':fontsdir='C\:/Users/DrEngelsk/Desktop/Emby Server/programdata/fonts'" -avoid_negative_ts disabled -start_at_zero -pix_fmt yuv420p  -maxrate 10076743 -bufsize 20153486 -preset veryfast -profile:v:0 high -level:v:0 4.1 -crf 20 -x264opts:0 subme=0:me_range=4:rc_lookahead=10:me=dia:no_chroma_me:8x8dct=0:partitions=none -vsync -1 -map_metadata -1 -map_chapters -1 -threads 1 -codec:a:0 ac3 -metadata:s:a:0 language=eng -disposition:a:0 default -ac:a:0 6 -ab:a:0 384000 -ar:a:0 48000  -y "C:\Users\DrEngelsk\Desktop\Emby Server\programdata\transcoding-temp\a8d7351d29092d62830538ad08e5b5e5.mkv"


#28 drengelsk OFFLINE  

drengelsk

    Newbie

  • Members
  • 8 posts
  • Local time: 05:45 PM

Posted 17 October 2019 - 11:51 AM

Okay, so I wrote the commands in CMD on the server, and it started encoding or something like that? It took 2 hours, and there hasn't been any difference. I still have the same problem, what should I do next? 



#29 softworkz OFFLINE  

softworkz

    Advanced Member

  • Developers
  • 1863 posts
  • Local time: 05:45 PM

Posted 17 October 2019 - 11:58 AM

I only wanted you to tell us whether you get an error in one or both cases or whether it would fail in both cases or whether it will start encoding in both cases.

 

No need to let it run. You can stop it with CTRL-C.



#30 softworkz OFFLINE  

softworkz

    Advanced Member

  • Developers
  • 1863 posts
  • Local time: 05:45 PM

Posted 17 October 2019 - 12:01 PM

Did it start transcoding with both command lines or only with the last one?



#31 drengelsk OFFLINE  

drengelsk

    Newbie

  • Members
  • 8 posts
  • Local time: 05:45 PM

Posted 17 October 2019 - 12:04 PM

It started when I entered the last command, I think...



#32 softworkz OFFLINE  

softworkz

    Advanced Member

  • Developers
  • 1863 posts
  • Local time: 05:45 PM

Posted 17 October 2019 - 12:06 PM

And you received an error with the previous one, right?

 

Could you try again and post the output please?

That would be the last thing to do...



#33 drengelsk OFFLINE  

drengelsk

    Newbie

  • Members
  • 8 posts
  • Local time: 05:45 PM

Posted 17 October 2019 - 12:24 PM

Both of the commands were working. The pictures are in order (see filename)

Attached Files







Also tagged with one or more of these keywords: subtitles

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users