Jump to content
speedingcheetah

ANSWERED No sound(headphone) remote jack

Recommended Posts

speedingcheetah

Roku Ultra (2018).  When i plug in headphones into the jack on the Roku remote, there is no audio from Emby for any of the media played, Live TV, Recordings, or local files.

There is the button sound effects and other Rokus system audio, and other apps all play sound fine.

If i unlplug headphone, the sound does come back to the tv.

 

Looked in the apps settings, and Audio +subtitle settings just says "see the user menu in web app"

and Convert Muti-channel AAC...has no effect.

 

The TV and media recordings are AC3 audio...if that helps. All my tv channels are that way,

 

Edit: Also noticed, that if I change the Rokus system Audio settings to Stereo, (or anything other than Auto) the Emby app does not load any media, live tv or local. It just hangs on the loading bar of Retrieving. It lock a tuner, and the dashboard says it is playing, but it is not. Have to restart server to unlock it.

Edited by speedingcheetah

Share this post


Link to post
Share on other sites
Luke

Hi there, have you tried with music, and if so, how does that compare?

Share this post


Link to post
Share on other sites
speedingcheetah

Hi there, have you tried with music, and if so, how does that compare?

 

Don't have any just music on my server. I do have music vids and other tv series on it, under my account.

I logged into my account and everything streamed fine, even via headphones.

 

I noticed that the Stats for my account show  play method "Remux", Video is H264(Direct) and that audio is "AAC". (I gather this is direct playing video stream, but transcodeing just the audio?)

 

On the other limited account I have setup for my mother, it shows Play method: DirectStream for video (H264) and Audio "AC3 (Direct)".

 

Direct stream is the most desireable and least resource intensive on the server.

Share this post


Link to post
Share on other sites
ebr

@@speechles isn't there an audio setting on the device that can cause these problems...?

Share this post


Link to post
Share on other sites
speedingcheetah

@@speechles isn't there an audio setting on the device that can cause these problems...?

As i mentioned already, i tried adjust those, any setting other than "Auto" in the Roku settings, results is the Emby app freezing up trying to load anything.

Share this post


Link to post
Share on other sites
ebr

I think there is another setting that is kindof hidden.

 

As for the freezing, can you please try the beta version of the app?

Share this post


Link to post
Share on other sites
speedingcheetah

I think there is another setting that is kindof hidden.

 

As for the freezing, can you please try the beta version of the app?

umm.....how do u install a beta version of the app on a Roku? i was not aware that there was any kind of Beta channel setting, like on android Google Play?

Share this post


Link to post
Share on other sites
speedingcheetah

Hi.  The beta is available right from our website: https://emby.media/emby-for-roku.html

ill try it out...where i sthe changelong for the beta...the link on the page says U do not have permission to view this topic.

Share this post


Link to post
Share on other sites
speedingcheetah

Trying the beta....same issues.

 

However, think i figured out my issue.

 

I have transcoding disabled for this user. As i only want it to direct play and not stress out the server cpu. Transcode should not be needed at all.

 

The setting "Allow audio playback that requires transcoding" in the servers CP, with that disabled, these audio issue occur, enable it, it does not.

I notice the source audio, no matter the codec, is always showed as AAC Stereo when i enable this and playback mode is Remux instead of Direct.

Also setting the Roku system Audio settings to Stereo, also is infact locking the whole device to only use AAC Stereo globally.

 

I can use the Roku remote headphone jack fine with other apps, even when system is set to Auto(Dobly Digital) or even manuly selecting D.D or D.D PLus.

So i know the Roku supports AC3 etc. as it works every where else.

But for some reason, the same AC3 direct stream multi channel audio track is not being sent to, or decoded by the Roku remote.

Far as I can tell, not being able to use the remote headphone jack, is the only issue of disabling any transcoding in Emby.

 

Could you provide a detailed insight (or link to one) on what the Emby sever stream modes are and how they work, direct, Remux, transcode, HLS etc, when it comes to the adio and video track separately? 

 

A bit off topic, but, how mature/stable/ well optimized is the Emby experience on a Roku, as compared to the the other stream boxes out there, FireStick, Shield, Apple TV, etc?

Edited by speedingcheetah

Share this post


Link to post
Share on other sites
Luke

Right, please make sure to read the help text warning underneath those server transcoding settings.

 

You have to remember, Emby apps will already direct play whenever possible. If the app isn't direct playing on it's own, then there's a valid reason for that.

Share this post


Link to post
Share on other sites
speedingcheetah

Right, please make sure to read the help text warning underneath those server transcoding settings.

 

You have to remember, Emby apps will already direct play whenever possible. If the app isn't direct playing on it's own, then there's a valid reason for that.

Valid reason would be what then, in this case?  It clearly works fine Direct, and not permitting Trans. So why is Emby choosing to trans/remux the audio, even when the Rouku is support, requesting the AC3?

 

"help text warning" are u referring to the "Restricting access to transcoding may cause playback failures in Emby apps due to unsupported media formats."

 

OK...doenst say anything about what remux mode is etc...

 

Also, how does this apply when the media format IS supported on the playback device?

Edited by speedingcheetah

Share this post


Link to post
Share on other sites
speechles

I will be at home shortly. I was at a friend's helping him move the last 4 days. When I am back home I can catch up. I should be there in the next hour or so.

 

Sent from my Nexus 7 using Tapatalk

Share this post


Link to post
Share on other sites
Luke

Valid reason would be what then, in this case?  It clearly works fine Direct, and not permitting Trans. So why is Emby choosing to trans/remux the audio, even when the Rouku is support, requesting the AC3?

 

"help text warning" are u referring to the "Restricting access to transcoding may cause playback failures in Emby apps due to unsupported media formats."

 

OK...doenst say anything about what remux mode is etc...

 

Also, how does this apply when the media format IS supported on the playback device?

 

Did you explore the server dashboard during playback to learn why it was transcoding?

Share this post


Link to post
Share on other sites
speedingcheetah

Yes,...it says its Direct Streaming there...

 

see image

 

edit....this is for when i have user media transcode disabled....see next post

post-72185-0-52864600-1571167029_thumb.png

Edited by speedingcheetah

Share this post


Link to post
Share on other sites
speedingcheetah

Correction....that last post and image was when it was set to not allow any transcoding.....

 

this is when i have the option enabled for audio only.

 

see images

 

again...the reason given for transcode....makes no sense, as the Roku supports the container format, codecs just fine, as proven when i disable the user option to alow media transcoding. it plays video and sound on the TV fine, just only the headphone out does not stream audio.....perhaps the Roku is doing a passthrough to the TV itself of the Dolby AC3 stream...and when is switches the stream to the remote, it can not decode D.D? just a hunch? but, that still dont figure out why Emby is chosing to transcode the audio to AAc.

post-72185-0-46145800-1571167333_thumb.png

post-72185-0-40947200-1571167340_thumb.png

Edited by speedingcheetah

Share this post


Link to post
Share on other sites
speechles

When you plug in the headphones effectively the audio capabilities the Roku reports to the app becomes stereo only. But you must plug your headphones in BEFORE you attempt to play otherwise you may be stuck in surround. The Roku does NOT transcode/decimate on the device to produce sound from the headphones. If you play Dolby or DTS to the headphone jack it will play silence. So we must transcode the audio to AAC stereo when we recognize the Roku has stereo only support or headphones plugged into the remote or using remote listening on a smart phone/tablet.

 

That is the only way to detect the Roku has headphones plugged in. For all intents and purposes it looks just like when it is hooked up to a stereo only TV. We cannot tell the difference between headphones in and a TV that only supports stereo. We can do better and use the audio codec capabilties changed feature that debuted in firmware 9.1 to tell when the audio capabilities have changed. We can stop then respawn the video player at that moment with the updated capabilities. This would fix the issue.

 

I was busy the last few days with family stuff so now that I am back I am ready to tackle this head on. Let me see what can be done to get on-the-fly updating of the audio capabilities into the app. You will see the video player stop and restart during a headphone plugin and removal when it needs to as this restart/resume is what will correct the playback. Stay tuned. ^_^

Edited by speechles

Share this post


Link to post
Share on other sites
speedingcheetah

When you plug in the headphones effectively the audio capabilities the Roku reports to the app becomes stereo only. But you must plug your headphones in BEFORE you attempt to play otherwise you may be stuck in surround. The Roku does NOT transcode/decimate on the device to produce sound from the headphones. If you play Dolby or DTS to the headphone jack it will play silence. So we must transcode the audio to AAC stereo when we recognize the Roku has stereo only support or headphones plugged into the remote or using remote listening on a smart phone/tablet.

 

That is the only way to detect the Roku has headphones plugged in. For all intents and purposes it looks just like when it is hooked up to a stereo only TV. We cannot tell the difference between headphones in and a TV that only supports stereo. We can do better and use the audio codec capabilties changed feature that debuted in firmware 9.1 to tell when the audio capabilities have changed. We can stop then respawn the video player at that moment with the updated capabilities. This would fix the issue.

 

I was busy the last few days with family stuff so now that I am back I am ready to tackle this head on. Let me see what can be done to get on-the-fly updating of the audio capabilities into the app. You will see the video player stop and restart during a headphone plugin and removal when it needs to as this restart/resume is what will correct the playback. Stay tuned. ^_^

 

So, will that then somehow override the user restriction to not allow transcode? so that it will only override that set limit for when it detects the user plugged in headphone? because, i want it to direct stream the AC3 to the tv at all times, and only go into stereo when headphones plugged in, (the already observed native behavior of the Roku in other apps). There is no need to have the audio transcoded at all times, as it is now.

Share this post


Link to post
Share on other sites
speechles

So, will that then somehow override the user restriction to not allow transcode? so that it will only override that set limit for when it detects the user plugged in headphone? because, i want it to direct stream the AC3 to the tv at all times, and only go into stereo when headphones plugged in, (the already observed native behavior of the Roku in other apps). There is no need to have the audio transcoded at all times, as it is now.

 

The audio should not be transcoded all the time unless the audio is "out of specification" and the server notices it or just plain unsupported period. My guess is this is a .TS container. The Roku does support those in direct play. We can direct play but you cannot seek TS streams beyond the pause buffer. That means you cannot fast forward into the program. You have to linearly progress through them. As you play you then can rewind into the pause buffer and fast forward back to the linear play point. It makes these behave just like LiveTV does. Most users would find that unacceptable. 

 

Instead we transcode TS into HLS/m3u8 and send segmented slices to the Roku. This gives the benefit of being able to now copy both streams (directstream) if possible. The only time the server would choose to not copy the audio stream is when it is not supported. 

 

Right now the app IS NOT correcting the player when you unplug and plug in your headphones during playback. It only remembers how it was when you PLAY the item not anything done while it is playing.

 

What this will do is add the new capability Roku recently gave us in firmware 9.1 to detect audio capability changes on-the-fly. We can then adapt to these during playback and adjust automagically. You will literally have to do nothing. Right now the app is not reacting to audio changes while the player is playing. It cannot automatically adjust from stereo back to surround and from surround back to stereo while playing. It will be able to after we do some work. :)

Edited by speechles

Share this post


Link to post
Share on other sites
speedingcheetah

As it stands, even if i plug in the headphone jack BEFORE i even launch the Emby app, or when after launch, before playback, there is no sound in remote jack, this is when user is not allowed audio transcode and the signal is AC3 D.D. The TV can play it fine when u hot unplug.

 

When enable the user option in server, i can hot plug/unplug just fine and the audio is fine, uninterrupted in the switch.

 

With allow audio transcode, the Roku is always and only putting out AAC Stereo to the TV, even when not using the remote jack. Even when i chose under HDMI D.D., the audio mode option however, only has Auto(D.D) or Stereo. 

 

 

What is "Convert Mutil-channel AAC" option in the Emby app on Roku,  do and how it affect transcodeing or not?

I have toggled that a few times, see no difference in anything.

Share this post


Link to post
Share on other sites
speechles

What is "Convert Mutil-channel AAC" option in the Emby app on Roku,  do and how it affect transcodeing or not?

I have toggled that a few times, see no difference in anything.

 

The Roku player can downsample AAC 5.1 to AAC 2.0 on the device during direct play. This will decimate your audio from surround to stereo. Some users may find this unacceptable and would rather transcode AAC 5.1 into AC3 5.1 to keep surround. In this case you can convert multi-channel AAC when you need to with that option.

 

As it stands, even if i plug in the headphone jack BEFORE i even launch the Emby app, or when after launch, before playback, there is no sound in remote jack, this is when user is not allowed audio transcode and the signal is AC3 D.D. The TV can play it fine when u hot unplug.

 

When enable the user option in server, i can hot plug/unplug just fine and the audio is fine, uninterrupted in the switch.

 

With allow audio transcode, the Roku is always and only putting out AAC Stereo to the TV, even when not using the remote jack. Even when i chose under HDMI D.D., the audio mode option however, only has Auto(D.D) or Stereo. 

 

There is nothing wrong with the detection in the app. The problem is using AUTO on your Roku device for HDMI Audio. You may want to choose the exact codecs you want rather than letting it decide.

 

Also play an item then press the * button. This opens the options menu on the left side of the screen. On this menu will be VOLUME MODE and you need to make sure this is OFF. If it is anything but off this will report your Roku as only capable of supporting stereo.

Edited by speechles
  • Like 1

Share this post


Link to post
Share on other sites
Luke

Yes make sure to read the help text underneath the options before touching those settings. Thanks.

Share this post


Link to post
Share on other sites
speedingcheetah

The Roku player can downsample AAC 5.1 to AAC 2.0 on the device during direct play. This will decimate your audio from surround to stereo. Some users may find this unacceptable and would rather transcode AAC 5.1 into AC3 5.1 to keep surround. In this case you can convert multi-channel AAC when you need to with that option.

 

 

There is nothing wrong with the detection in the app. The problem is using AUTO on your Roku device for HDMI Audio. You may want to choose the exact codecs you want rather than letting it decide.

 

Also play an item then press the * button. This opens the options menu on the left side of the screen. On this menu will be VOLUME MODE and you need to make sure this is OFF. If it is anything but off this will report your Roku as only capable of supporting stereo.

 

On Roku,

Audio mode gives me only 2 options: Stereo, Auto(Dobly Digital)

HDMI: Auto Detect; PCM-Stereo; Dolby Digital; Dolby Digital Plus; Dolby Digital,DTS;  Dolby Digital Plus,DTS

 

I have tried all these settings and mixes of them, none of which affect the issue of Emby always doing AAC Stereo.

 

Is the TV/monitor model have anything to do with how this all works and how Emby streams things?

It is an 2015 model Vizio 1080p 43in tv. model D43-C1

It has the Dolby logos on the back of it.

However, the sound is being output via the RCA out Audio out jacks to a pair of 2.0 powered computer speakers.

The option on the tv audio settings for Surround sound is on.

Share this post


Link to post
Share on other sites
speedingcheetah

The Roku player can downsample AAC 5.1 to AAC 2.0 on the device during direct play. This will decimate your audio from surround to stereo. Some users may find this unacceptable and would rather transcode AAC 5.1 into AC3 5.1 to keep surround. In this case you can convert multi-channel AAC when you need to with that option.

 

 

There is nothing wrong with the detection in the app. The problem is using AUTO on your Roku device for HDMI Audio. You may want to choose the exact codecs you want rather than letting it decide.

 

Also play an item then press the * button. This opens the options menu on the left side of the screen. On this menu will be VOLUME MODE and you need to make sure this is OFF. If it is anything but off this will report your Roku as only capable of supporting stereo.

 

Haza!

 

I did have the Roku Volume Leveling (or the  Night mode) enabled. 

Setting that to normal, the audio is direct streamed AC3 not remuxed/trans.

And, putting in headphones before playback, sound does work, unplugging then does switch back to tv sound.

Hot switch to headphone jack when direct stream, as u mentioned before, does not work...as expected.

 

I can enable the Volume leveling fine after the stream starts though...seems to work fine and Emby still says direct AC3.

But when u close channel, load another, it then always does AAC.

 

A tad sad, the night mode would have been useful for the late night things use watches...o well.

Share this post


Link to post
Share on other sites
speechles

I can enable the Volume leveling fine after the stream starts though...seems to work fine and Emby still says direct AC3.

But when u close channel, load another, it then always does AAC.

 

That is because it remembers the last state. This will be corrected when it adapts on-the-fly when it notices the audio capabilities change. This will also automagically stop then restart/resume the video player when required to stop/start audio transcoding. You will not have to do anything or should be required to do anything. We need to do all the behind-the-scenes a little better so you can have this working as you imagine. It will soon work that way.

Edited by speechles
  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...