Jump to content


Photo

Theater Not Returning To Home At End of Movie

theater blank screen screensaver

  • Please log in to reply
16 replies to this topic

#1 Theodore OFFLINE  

Theodore

    Advanced Member

  • Members
  • 157 posts
  • Local time: 09:30 AM

Posted 10 October 2019 - 03:08 PM

So I think I am having a similar but not exactly the same issue as the one about blank/black screen on start:

 

Theater loads and connects fine, but if I let the Emby screensaver start (either the logo or backdrop) I have to use the mouse to "wake it" before I play a movie or else it just plays UNDER the screensaver - and since it is a dedicated Media Center computer that means VNC - where it didn't do this before (about the same time that thread was started, somewhere in August). Also at the end of playing a file it looks like Theater doesn't stop/close the file or player. It sits at a black/blank screen instead of going back to the front page of Theater. If I play another file while on that post-file black screen there is no problem, it just switches the player right to it and goes.

 

This behavior is NOT seen when using the browser, only Theater.

 

I tried the solution in the other thread anyways and it didn't work. It is almost like Theater isn't sending the proper end signals (screensaver and file/movie)...?



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 140182 posts
  • Local time: 11:30 AM

Posted 10 October 2019 - 03:34 PM

Hi there, can you try restarting the app and see if this happens again? thanks.



#3 Theodore OFFLINE  

Theodore

    Advanced Member

  • Members
  • 157 posts
  • Local time: 09:30 AM

Posted 10 October 2019 - 03:39 PM

Hi there, can you try restarting the app and see if this happens again? thanks.

 

It has been doing this since early to mid-August (I think, it has been a while since it started) so the app and the entire PC have been restarted multiple times. I have a scheduled task to reboot the media PC every day at 3am. I've even tried uninstalling Theater and reinstalling and get the same result.



#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 140182 posts
  • Local time: 11:30 AM

Posted 11 October 2019 - 12:16 AM

What version of Theater?



#5 Theodore OFFLINE  

Theodore

    Advanced Member

  • Members
  • 157 posts
  • Local time: 09:30 AM

Posted 11 October 2019 - 12:22 AM

What version of Theater?

 

3.0.9 is being reported to the web console.



#6 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 140182 posts
  • Local time: 11:30 AM

Posted 11 October 2019 - 01:03 AM

@Doofus are you able to reproduce?



#7 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 12618 posts
  • Local time: 08:30 AM

Posted 11 October 2019 - 07:38 AM

Ill try to remember to test it tonight

#8 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 140182 posts
  • Local time: 11:30 AM

Posted 11 October 2019 - 12:12 PM

Thanks !

#9 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 12618 posts
  • Local time: 08:30 AM

Posted 11 October 2019 - 10:18 PM

I can't even get the screensaver to start  :unsure:



#10 Theodore OFFLINE  

Theodore

    Advanced Member

  • Members
  • 157 posts
  • Local time: 09:30 AM

Posted 11 October 2019 - 10:28 PM

I can't even get the screensaver to start  :unsure:

 

The snarky answer is to wait past the time for it to start while in full screen mode  :D

 

Honestly though, while having the screensaver work would be ideal as its nice to have that playing while nothing else is happening, the real annoyance is that the screen stays at the tail of the file after playing. I just ran a movie through to the end so I could get a screen cap (https://imgur.com/PqBXMmI) and I VNCed over to the media center PC and wiggled the mouse. At the bottom you can see that the player is still active even though the movie finished playing. 

Attached Files



#11 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 12618 posts
  • Local time: 08:30 AM

Posted 11 October 2019 - 10:33 PM

How long does it take? I waited more than 5 mins. 



#12 Theodore OFFLINE  

Theodore

    Advanced Member

  • Members
  • 157 posts
  • Local time: 09:30 AM

Posted 11 October 2019 - 10:45 PM

How long does it take? I waited more than 5 mins. 

 

It depends on what setting you set in the screensaver settings but I think the default is 10 minutes.



#13 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 12618 posts
  • Local time: 08:30 AM

Posted 11 October 2019 - 10:47 PM

It depends on what setting you set in the screensaver settings but I think the default is 10 minutes.

 

I don't have an option for time.

 

But I let a movie play to the end, and it returned to the home page.



#14 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 140182 posts
  • Local time: 11:30 AM

Posted 11 October 2019 - 10:49 PM

The snarky answer is to wait past the time for it to start while in full screen mode  :D

 

Honestly though, while having the screensaver work would be ideal as its nice to have that playing while nothing else is happening, the real annoyance is that the screen stays at the tail of the file after playing. I just ran a movie through to the end so I could get a screen cap (https://imgur.com/PqBXMmI) and I VNCed over to the media center PC and wiggled the mouse. At the bottom you can see that the player is still active even though the movie finished playing. 

 

Have you customized any video settings?



#15 Theodore OFFLINE  

Theodore

    Advanced Member

  • Members
  • 157 posts
  • Local time: 09:30 AM

Posted 11 October 2019 - 10:59 PM

Have you customized any video settings?

 

I don't think so but I can check when my girlfriend finishes the current movie.



#16 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 140182 posts
  • Local time: 11:30 AM

Posted 11 October 2019 - 11:06 PM

Ok. Refresh rate switching was the one that i thought might cause it.



#17 Theodore OFFLINE  

Theodore

    Advanced Member

  • Members
  • 157 posts
  • Local time: 09:30 AM

Posted 12 October 2019 - 12:27 AM

Ok. Refresh rate switching was the one that i thought might cause it.

 

Aside from disabling "Are you still watching?", everything is still set to "Auto".







Also tagged with one or more of these keywords: theater, blank screen, screensaver

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users