Jump to content

Can't 'connect to server' through emby connect with https


zjeffer

Recommended Posts

I log in with emby connect on app.emby.media on Firefox. I try to add a server, but when I click 'connect', it shows me the following error: https://i.imgur.com/fesyi4G.png

This used to work, but a few weeks ago my public IP changed and I had to add the server again. Explicitly connecting with my IP address as the URL works fine, for both local and public IP.

Today I figured out that it does work fine in Chromium, so there must be something wrong with Firefox. Both on linux. Server is on a raspberry pi.

 

I added a copy of the debug console as an attachment. console-export-2019-10-3_19-26-57.txt

 

Things I've tried:

  • disabling all of my addons manually
  • restarting Firefox in safemode (which among other things disables all addons)
  • Tried the same thing in Windows: Edge & Chrome work fine, but Firefox (in or out of safemode) doesn't.

 

What can I do to fix this?

 

EDIT:

 

I don't know what I did, but after weeks of this not working (and trying a couple times a week), I could suddenly add a server again. I have no clue how this happened.

 

EDIT2: I edited the title now that I know the problem has something to do with https and not because of Firefox.

Edited by zjeffer
better title that more accurately describes the problem
Link to post
Share on other sites
  • 9 months later...

Hi, today I came across the same problem again on my Windows installation.

So the exact same issue doesn't happen on Linux anymore, but it does on Windows. embyserver.txt shows nothing when trying to connect, but it works fine with Microsoft Edge. On firefox  the console shows:

begin connectToServer 						connectionmanager.js:526
tryReconnect: 							connectionmanager.js:546

In Edge, after tryReconnect it shows the server's IP address. In Firefox, it shows nothing.

 

Connecting to the IP address using the browser's URL bar still works as it should.

Link to post
Share on other sites
1 hour ago, Luke said:

What about just normal mode?

Well if it worked in normal mode I wouldn't have a problem ;)

 

1 hour ago, cayars said:

Is this using the web server built into Emby Server?

Yes, the Emby Server is running on my Raspberry Pi 4 and I'm connecting to its IP address from my computer on the same network, port 8096.

1 hour ago, cayars said:

Do you get the same error/issue if using https://app.emby.media? 

Thanks for this question: I just noticed that it works fine with app.emby.media, but fails with https://app.emby.media. I found this to be the case for ALL browsers tested: Firefox on both Windows & Linux, Chromium on Linux and Edge on Windows. Same errors, same logs in browser console.

This is probably why I thought it suddenly started working again when I posted the question last year; I probably started surfing to the http url instead of https:

On 10/3/2019 at 7:59 PM, zjeffer said:

I don't know what I did, but after weeks of this not working (and trying a couple times a week), I could suddenly add a server again. I have no clue how this happened.

 

How can I troubleshoot this further, so it could work on both http and https? Thanks.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...