Jump to content
Sign in to follow this  
tara.b

Parental Controls not working in with some custom ratings

Recommended Posts

tara.b

I have a user configured with PG/TV-PG Parental Controls, including all “Block items with no or unrecognized rating information”. Most parental controls appear to be working properly. However, some movies with custom parental ratings (e.g. Ghostbusters has an original rating of PG and I’ve set a custom rating of PG-13) are visible and playable. I’ve rescanned the media library several times and double checked the ratings. I’m not sure what’s different about these titles than other ones (e.g. Indiana Jones and the Temple of Doom was also originally PG, and I’ve set a custom rating of PG-13) which are working as expected.

 

Any help figuring out what’s different between these custom ratings is appreciated.

 

I’m running Emby server version 4.2.1.0. I’ve noticed this on both the Roku and iOS app.

Share this post


Link to post
Share on other sites
Luke

Hi, where are they showing up?

Share this post


Link to post
Share on other sites
tara.b

They show up under Movies, Latest, and Search. Basically, everywhere they shouldn’t.

Share this post


Link to post
Share on other sites
ebr

Hi.  Can we please see the details for one of the ones you think isn't working properly?

 

Thanks.

Share this post


Link to post
Share on other sites
Happy2Play

@@Happy2Play are you able to reproduce this?

No any item I apply a higher custom rating on is restricted be the Maximum allowed parental rating.

Share this post


Link to post
Share on other sites
Luke

@@tara.b, how did you set the custom rating?

Share this post


Link to post
Share on other sites
ebr

By any chance did you also setup "Allow items with tag" and then these items have that tag...?

Share this post


Link to post
Share on other sites
tara.b

Let me know how best to share the details...

 

The parental controls are set as follows:
5d93f9960c419_setup.png

 

The movies (both the ones that are working properly and the ones that are not) have custom ratings set as:
5d93f9ed91ddc_movie.png

Share this post


Link to post
Share on other sites
Luke

And what content shows up?

Share this post


Link to post
Share on other sites
tara.b

I think I found the root cause... the custom parental ratings are not being updated in the nfo for all versions.

 

In the kids account with parental controls set, Ghosbusters shows up but Indiana Jones does not:

5d940939eb83e_ghostbusters_kid.png

 

5d94094e5a7c7_indiana_kid.png

 

However, I noticed that the album art for Ghosbusters is showing the DVD cover on the kids account, but the BR cover shows on the main.

5d9409a188d23_ghosbusters_parent.png

 

The movie has a 1080p and 480p version, residing in the same folder. The 480p nfo file isn't updating with the custom rating.

5d9409e7d470e_ghostbusters_file.png

 

 I edited the file manually, rescanned the library, and now the parental controls are working appropriately.  So, there's a workaround, but for some reason the custom controls aren't being applied to all versions.

  • Like 1

Share this post


Link to post
Share on other sites
Happy2Play

Yes when you are referring to multi-version, the UI only edits one version (the one being displayed).

Share this post


Link to post
Share on other sites
tara.b

Oh!  I guess it's working as intended then, just not as I expected.

 

Note to self: edit metadata for all versions next time.

 

Thanks!

Share this post


Link to post
Share on other sites
ebr

So these are actual multi-version movies meaning that only one item ever shows in the library and then there is the opportunity to select the version?

 

If so, this is not working as intended...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...