Jump to content


Photo

Alphabetical Jump To no longer working for Fire TV App

Bug

  • Please log in to reply
10 replies to this topic

#1 DarkStaff OFFLINE  

DarkStaff

    Member

  • Members
  • 15 posts
  • Local time: 05:37 PM

Posted 10 August 2019 - 04:17 PM

In the newest Fire TV App the Alphabetical Jump To found on the left side of the "TV Shows" or "Movies" screen, is no longer working.  Instead of jumping to the selected letter, it goes back to the current selection.



#2 vdatanet ONLINE  

vdatanet

    Advanced Member

  • Members
  • 1041 posts
  • Local time: 10:37 PM
  • LocationCalafell, Spain

Posted 10 August 2019 - 04:27 PM

Any movie beginning with special characters ? ! ... ?

 

https://emby.media/c...of-that-letter/


Edited by vdatanet, 10 August 2019 - 04:28 PM.


#3 DarkStaff OFFLINE  

DarkStaff

    Member

  • Members
  • 15 posts
  • Local time: 05:37 PM

Posted 18 August 2019 - 06:50 PM

There is a movie beginning with Æ and a TV Show beginning with £Both of these items have been in the Library for several years, and long before the sort stopped working on FireTV as expected.  While I do see the issue where they incorrectly show up with other filters/jump-to, on FireTV, the jump-to fails to function at all.



#4 sylvio2000 OFFLINE  

sylvio2000

    Advanced Member

  • Members
  • 93 posts
  • Local time: 10:37 PM

Posted 22 August 2019 - 01:58 AM

I can confirm this.

On my FireTV I go in the movie list and try to jump to a specific letter. But I always get back to a movie named "Æon"



#5 vdatanet ONLINE  

vdatanet

    Advanced Member

  • Members
  • 1041 posts
  • Local time: 10:37 PM
  • LocationCalafell, Spain

Posted 22 August 2019 - 02:04 AM

I can confirm this.

On my FireTV I go in the movie list and try to jump to a specific letter. But I always get back to a movie named "Æon"

 

 

Edit Movie Metadata and set Sort File Name to Aeon, and see what it happens. It's a server issue:

 

https://emby.media/c...iltered-letters

 

https://emby.media/c...ient-be-working


Edited by vdatanet, 22 August 2019 - 02:07 AM.


#6 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 47589 posts
  • Local time: 04:37 PM

Posted 22 August 2019 - 12:08 PM

The real issue here is the fact that that item is being returned in the list in a place other than where it should really sort according to the character it starts with.



#7 speechles OFFLINE  

speechles

    Advanced Member

  • App Developer
  • 5653 posts
  • Local time: 01:37 PM

Posted 22 August 2019 - 12:22 PM

It isn't sorting by Ascii when inserting those characters in like that. The three amigos issue is they didnt really use the "upside down" question mark to signify that at the start of three amigos. They use the accented i character(141) versus the correct(173). Which looks real close. So close like is near identical. Twins! yay!.. but the difference is pull the ascii value of that first character then you see its not the upside down exclamation point its the i. So three amigos should fall around the i's which it does. Then Aeon flux has that combined AE character which is after z in ascii.. It should be at the end but it sorts it also into the Ae's. There are other items doing this with jump letters too those are just examples.

 

image.png

 

But the easiest way to do it is look at the ascii for the character when jumping beyond what we know is "Z" which is 90. So anytime the jump character is 91 or higher in ASCII in the Roku app we just jump to that exact character or higher. It isn't possible then to stumble on these types of problems. If we search for AE is 145 and 146 ascii for upper/lower case. So you are correct in the sense these shouldn't be in the alphabet A-Z presented these jumps, but they are. The only work-around is when asked to jump to one of those characters jump specifically to that character or greater. Nothing else and it does solve it.

 

@ebr look at the findChildIndex procedure in the Roku app at how we dealt with it there. You might be able to do the same thing here.


Edited by speechles, 22 August 2019 - 12:31 PM.


#8 gene0915 OFFLINE  

gene0915

    Advanced Member

  • Members
  • 203 posts
  • Local time: 04:37 PM

Posted 10 September 2019 - 10:50 PM

Came here to report the same. I've had a Firestick 4K for a while and just now tried Emby on it. When I go into 'Movies' and hit the 'S' on the jump bar, it defaults back to my Æon Flux movie. Is this a universal problem with all Android devices or just the Firestick?



#9 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 47589 posts
  • Local time: 04:37 PM

Posted 11 September 2019 - 09:36 AM

Came here to report the same. I've had a Firestick 4K for a while and just now tried Emby on it. When I go into 'Movies' and hit the 'S' on the jump bar, it defaults back to my Æon Flux movie. Is this a universal problem with all Android devices or just the Firestick?

 

Hi.  As reported in here you simply need to use the metadata editor to give that item a sort name of "Aeon Flux" and it should work fine.

 

Please let us know if that fixes it for you.

 

Thanks.



#10 gene0915 OFFLINE  

gene0915

    Advanced Member

  • Members
  • 203 posts
  • Local time: 04:37 PM

Posted 11 September 2019 - 10:01 AM

Hi.  As reported in here you simply need to use the metadata editor to give that item a sort name of "Aeon Flux" and it should work fine.

 

Please let us know if that fixes it for you.

 

Thanks.

 

I guess when I saw vdatanet state it's a server issue, my brain turned off. But I see what you're saying.... I edited the metadata for Aeon Flux and when I get home tonight, I'll see if that fixes it on the FireTV. (Weird, using the jump bar when accessing my Emby server via a browser, I don't have the problem but no biggie..... if that simple fix takes care of it on the FireTV, I'm happy.)



#11 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 47589 posts
  • Local time: 04:37 PM

Posted 11 September 2019 - 10:14 AM

I guess when I saw vdatanet state it's a server issue, my brain turned off. But I see what you're saying.... I edited the metadata for Aeon Flux and when I get home tonight, I'll see if that fixes it on the FireTV. (Weird, using the jump bar when accessing my Emby server via a browser, I don't have the problem but no biggie..... if that simple fix takes care of it on the FireTV, I'm happy.)

 

The Android/Fire app is using a different method of "jumping".  Note that, when you do that in that app you can also back up to anywhere in your library but you cannot do that with the web app.







Also tagged with one or more of these keywords: Bug

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users