Jump to content

Request - I would pay for a fully functional ServerWMC plugin


ppickle

Recommended Posts

Workaround that works for me....

 

Stop Emby server from Automatically Restarting in Settings Tab & Hit Save at the Bottom of the page. (if you skip this it becomes a circle of insanity)

 

Navigate to Plug-Ins tab UNINSTALL ServerWMC plug-in V 1.2.1.0 Restart Emby Server...

 

Navigate to Plug-Ins tab install ServerWMC plug-in V 1.2.0.0 Restart Emby Server... (ServerWMC will install the Version 1.2.1.0 Automatically) So..

 

Ignore the NEXT MESSAGE to restart Emby Server and let it Nag and Hang like the Pic Below....         

*(If you have Emby for WMC installed IGNORE Restart Message its the same notification)

 

Works for me. Thanks for finding this!!! I've set permissions for 'wmc2mb.dll' to 'Read only' in hopes of preventing an unwanted auto-update... will re-address when an alternative is presented.

 

Update: ...except for a little 'clutter' in the 'Media Info' section (which I can live with).

 

post-10374-0-44071800-1568750386_thumb.jpg

 

Update 2: Test recordings made after this change worked fine. Last night's recordings are back to the recent "No compatible streams" behavior. So close...

Edited by d00zah
Link to post
Share on other sites

Where r u streaming to? Chrome? Apple TV?  Mobile? What version of Emby Server installed? What Version of the ServerWMC plugin is installed? it may have somehow updated to v1.2.1.0,

If not Check that Chrome is Updated to v77 click 3 Dots upper right hand corner, Help , About Google Chrome, it will auto update click Relaunch.

 

Apple TV same update it to the latest Firmware. Try reverting those permissions maybe?

 

More info you can provide better chance we can find a working state. I've been solid in this position for over a month now. 

 

I also UNCHECKED enable automatic server updates, this will certainly get the circle going again if an Update to Server restarts the Server Automatically.

Edited by muranoone
Link to post
Share on other sites

Server v4.2.1.0... runs as service.

SWMC v1.0.0.63 bld 1255

 

Playback in WMC (native), or latest Firefox (what I tested)..NO Chrome... ever. No Apple TV.

 

I was messing with the frequency of the 'Refresh Internet Channels' task as active recordings

do not show up 'in progress' as they did before plugin reversion. Best I can figure, any active

recordings added to the db by that task are entered as 'Live Stream' (won't play) forever & always.

No subsequent scans detect the .wtv files. I have reverted the task schedule to default.

 

The 2 test recordings I made after reading your post got scanned AFTER they completed &

played (in FF) just fine.

 

Update: the buggered recordings are also not removed from 'Latest ServerWMC Recordings'

on the home screen after being deleted in WMC (& subsequent full library scans).

 

Conclusion: Thia hack kinda works, but has side effects.

Edited by d00zah
Link to post
Share on other sites

So I tried my recordings in FF and everything is playing smooth.. Chrome too Apple TV ok also.... for my system as long as the Recorded TV streams... WE Happy 

 

I have noticed weird things happening with metadata being incorrect , images way off , sometimes when i stop a recording it goes back to the folder and has 2 or 3 of the same recordings in there that just magically appear , they clear out when i reenter the folder from the home screen. Like i said the important thing is that they Play! 

 

So i have SWMC v1257 Preview installed i would try that see if helps 1255 is not as stable for me w Apple TV  which i use the most.  Just reapply my HACK ;) if u restart the machine!

 

If you click on Dashboard in Emby Server do u still see the messages about restarting? Message about 1.2.1 Pending? if not you have restart the HACK! and Try A Lower Plug-IN Version ... LMK

 

5d82dddb29e2f_Nag2.png

Link to post
Share on other sites

I've seen 2 tiles per recording, in some cases. Finally dawned on me that it was always shows where the title & episode name were the same in the guide, so it was interpreted as 2 recordings.

 

Yep. Recordings play fine... as long as the aforementioned task doesn't run while the recording is active. I concur, that's what matters.

 

I've set permissions for 'wmc2mb.dll' to 'Read only', so all I see is this each time the service restarts::

 

post-10374-0-20376400-1568857914_thumb.jpg

 

Update: Now that 'Refresh Internet Channels' task is back to running 'in the wee hours', all of last night's recordings are 'good'... correctly detected, good metadata (mostly), play fine in FF. Thanks, again!

Edited by d00zah
Link to post
Share on other sites

Hey i noticed after an OS reboot yesterday that after adding my Hack the Recordings that were Recently Recorded within 4 days all have a Tag 'livestream" in the lower left hand corner of the recordings page will not play like you mentioned. How do we get rid of that tag? and Why is it there?

 

5d84cfe219c51_TagLiveStream.png

Link to post
Share on other sites

After the recordings are in this state in the database, I never found a way to fix them... "forever & always", I believe, was my description.

 

- I run Emby as a service. (probably irrelevant)

- I have set permissions on the ServerWWC plugin .dll such that it cannot be 'accidentally' updated. No need to "re-apply the hack". This MAY be the 'gotcha'?

 

%AppData%\Roaming\Emby-Server\plugins\wmc2mb.dll

 

- I have adjusted the schedule for the 'Refresh Internet Channels' task, now responsible for scanning recordings into the database, to not run while any recordings are active.

- In the morning, 'last night's' recordings are correctly identified, have ~proper metadata & play in FF as they did before said recent changes.

- A system reboot (I've done several)/re-running the 'Refresh Internet Channels' task hasn't changed this state once they are 'correct'.

 

Can you point to something you've done differently?

 

Other observations:

 

- Active/new recordings are not immediately detected as they were before the server change. The overnight task has to run before they appear in 'Latest ServerWMC Recordings', or 'LiveTV' > 'Recordings', but running the task while recordings are active results in the state you currently find yourself in.

- Deletion of recordings (after watching) from WMC is not detected by Emby unless I manually run the 'Refresh Internet Channels' task.

 

In conclusion, while this solution is less than perfect, I regain MOST of what is important to me. I could write a volume on other things that 'need work' on the SWMC/Emby integration, but it has no priority.

Edited by d00zah
Link to post
Share on other sites

@@Luke, FWIW, some additional detail IF you decide to revisit this.

 

Recording detail prior to deletion:

 

post-10374-0-55485800-1569070015_thumb.jpg

 

Recording detail shortly after deletion...some changes ARE automatically detected.

 

post-10374-0-44041300-1569070115_thumb.jpg

 

embyserver.txt

 

The remainder is only deleted after 'Refresh Internet Channels' task is run.

 

edit: log added

Edited by d00zah
Link to post
Share on other sites

Since this seems to be the current, de facto place to get issues on the record, I wanted to demonstrate this one, as well.

 

It seems to be news programs (most networks), where ( show title == episode name ). For example::

 

post-10374-0-87138700-1569162935_thumb.jpg     post-10374-0-55508500-1569163066_thumb.jpg

 

ends up displaying 2 tiles for a single recording:

 

post-10374-0-04208500-1569163003_thumb.jpg     post-10374-0-73959900-1569163036_thumb.jpg

 

This applies to either plugin version with the latest stable server.

Link to post
Share on other sites
  • 1 month later...

I was hopeful, but as of this morning, problems persist.

 

Good:

 

- Deletion of watched programs recognized within minutes (tile removed)

- In progress show tiles displayed, detail reports 'livestream'.

 

Bad:

 

- Last night's recordings still display as 'livestream' this morning after scheduled/manual 'refresh internet channels' tasks have run. NO media info, cast details. Task DID NOT run during active recordings.

- Show detail screen bugs remain.

 

post-10374-0-08165200-1574337295_thumb.jpg

 

I intend to revert to the old plugin, but will provide additional info upon request.

 

Update:

 

Show detail stuck reporting as 'livestream' after manual 'refresh internet channels' task following plugin reversion. Overall, behavior largely unchanged from what was reported in the prior release.

 

Function using old plugin still works as described in this post.

Edited by d00zah
Link to post
Share on other sites

My plugin is 1.2.1.0 and my ServerWMC service is 1257.  Do I need to downgrade these?

 

The stream starts up and continues right along in the ServerWMC service panel (on the server), but nothing ever reaches the client window ... just the spinning wheel of death.

Link to post
Share on other sites
  • 4 weeks later...

I got 4.3.1 today and I'm about to try this again.  Not sure if any of this is fixed ... just a shot in the dark.  I guess I should visit the GIT repo and see what's in the notes.

Link to post
Share on other sites
  • 4 months later...
MadibaJ

Ok unfortunately I'm not sure as we're using a hauppauge provided SDK and it's a bit of a black box for us. We are in the midst of rewriting our hauppauge support so that it won't have to depend on Hauppauge's SDK or WinTV. It probably won't be until the upcoming holiday season until we're ready to release though.

 

For now I would suggest adding your recordings library to Emby as a regular library, rather than trying to play the recordings using the ServerWMC plugin.

@@Luke how is this coming along?

Link to post
Share on other sites
Luke

It's progressing very well. It's taken a little longer than we anticipated, but hopefully we'll have something soon.

Link to post
Share on other sites
  • 1 month later...
  • 1 month later...
  • 5 months later...
customized

Hi everyone!

My thanks to Luke and everyone who works so hard on Emby.  You rule!  Emby literally brings joy to everyone in my house.

I'm jumping in to see if anyone has come up with a good way to have ServerWMC and Emby play nice.  Also, is ServerWMC still maintained/not hijacked?  I know this is getting to be a geriatric/niche program so I don't have high expectations.

I just rebuilt my Windows 7 WMC box and went to reinstall ServerWMC and I noticed a couple red flag items:

  • Though the main ServerWMC page is on github, the actual file download is hosted elsewhere, and my browser could not download it securely.
  • The license terms in version 1255 (listed as last updated on 9/25/2018) are nonsense words.  So I cancelled the install.  I looked through some of my old downloads and found a copy of ServerWMC 1225 from 2016 and installed that, license terms are proper language.
  • The update links are broken in version 1225.  404 Error to a Google Drive address.  Sure it's old but all of these together raise my eyebrows

There is a ServerWMC preview listed on the site (1260) with a 2020 date, but I didn't try that after my above red flags.

 

Like a lot of people, I can't playback recorded TV in Emby.  Live works, and scheduling recording works (I'm happy about that, it's the #1 thing it needs to do).  I've tried adding the recorded TV folder as an Emby library, but without renaming/converting all of the files it doesn't look like user-friendly playback there is an option.  If there is a fully automated way of having it work I'll happily set it up, but renaming/organizing for Emby playback just isn't worth the effort when I can watch with WMC.

We're still sticking with WMC because you can watch recorded TV on fast-forward with audio.  If there was a way to do that in Emby, we'd go 100% Emby.  I've tried using VLC as an external player, but there are waaaay too many remote control button clicks necessary to fast forward with audio, and likewise to go back to normal speed.

I feel archaic holding onto WMC, but for watching live and recorded TV, there's nothing better.  I've tried Emby, Plex, Kodi, MediaPortal, Amazon Recast, cable boxes, and probably more things that I've forgotten about.  WMC is peak TV in my book.

Link to post
Share on other sites
Luke

I can't answer about the ServerWMC software but we'll do our best to keep the plugin compatible.

  • Thanks 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...