Jump to content

Upgrade to 4.2.0 - doesn't start anymore


Pafzedog
 Share

Recommended Posts

Hello,

 

I just upgraded to 4.2 on my server (Debian Jessie 8.11 x64)

Emby service doesn't start with this error message in Systemd status report :

systemctl status emby-server.service
● emby-server.service - Emby Server is a personal media server with apps on just about every device.
   Loaded: loaded (/usr/lib/systemd/system/emby-server.service; enabled)
   Active: failed (Result: signal) since mar. 2019-07-30 17:51:37 CEST; 1min 54s ago
  Process: 696 ExecStart=/opt/emby-server/bin/emby-server (code=killed, signal=ABRT)
 Main PID: 696 (code=killed, signal=ABRT)

juil. 30 17:51:37 Fozzy emby-server[696]: --- End of inner exception stack trace ---
juil. 30 17:51:37 Fozzy emby-server[696]: --- End of inner exception stack trace ---
juil. 30 17:51:37 Fozzy emby-server[696]: at System.Net.NetworkInformation.LinuxNetworkInterface.GetLinuxNetworkInterfaces()
juil. 30 17:51:37 Fozzy emby-server[696]: at System.Net.NetworkInformation.NetworkInterfacePal.GetIsNetworkAvailable()
juil. 30 17:51:37 Fozzy emby-server[696]: at System.Net.NetworkInformation.NetworkChange.OnAvailabilityTimerFired(Object state)
juil. 30 17:51:37 Fozzy emby-server[696]: at System.Threading.TimerQueueTimer.CallCallback()
juil. 30 17:51:37 Fozzy emby-server[696]: at System.Threading.TimerQueueTimer.Fire()
juil. 30 17:51:37 Fozzy emby-server[696]: at System.Threading.TimerQueue.FireNextTimers()
juil. 30 17:51:37 Fozzy systemd[1]: emby-server.service: main process exited, code=killed, status=6/ABRT
juil. 30 17:51:37 Fozzy systemd[1]: Unit emby-server.service entered failed state.

In the last logs of emby server, I found this :

Error App: LoaderException: Could not load type 'SQLitePCL.pretty.IResultSetValue' from assembly 'SQLitePCL.pretty, Version=1.2.2.0, Culture=neutral, PublicKeyToken=null'.
Link to comment
Share on other sites

I don't see anything obvious here, but can you shutdown the server, then go to this folder:
 

/var/lib/emby/plugins

And just delete all of the .dll files in this folder. Then try starting the server back up. Thanks.

Link to comment
Share on other sites

done and same error :

● emby-server.service - Emby Server is a personal media server with apps on just about every device.
   Loaded: loaded (/usr/lib/systemd/system/emby-server.service; enabled)
   Active: failed (Result: signal) since mer. 2019-07-31 00:01:13 CEST; 11s ago
  Process: 24835 ExecStart=/opt/emby-server/bin/emby-server (code=killed, signal=ABRT)
 Main PID: 24835 (code=killed, signal=ABRT)

juil. 31 00:01:13 Fozzy emby-server[24835]: --- End of inner exception stack trace ---
juil. 31 00:01:13 Fozzy emby-server[24835]: --- End of inner exception stack trace ---
juil. 31 00:01:13 Fozzy emby-server[24835]: at System.Net.NetworkInformation.LinuxNetworkInterface.GetLinuxNetworkInterfaces()
juil. 31 00:01:13 Fozzy emby-server[24835]: at System.Net.NetworkInformation.NetworkInterfacePal.GetIsNetworkAvailable()
juil. 31 00:01:13 Fozzy emby-server[24835]: at System.Net.NetworkInformation.NetworkChange.OnAvailabilityTimerFired(Object state)
juil. 31 00:01:13 Fozzy emby-server[24835]: at System.Threading.TimerQueueTimer.CallCallback()
juil. 31 00:01:13 Fozzy emby-server[24835]: at System.Threading.TimerQueueTimer.Fire()
juil. 31 00:01:13 Fozzy emby-server[24835]: at System.Threading.TimerQueue.FireNextTimers()
juil. 31 00:01:13 Fozzy systemd[1]: emby-server.service: main process exited, code=killed, status=6/ABRT
juil. 31 00:01:13 Fozzy systemd[1]: Unit emby-server.service entered failed state.

new log is attached

embyserver.txt

  • Like 1
Link to comment
Share on other sites

I just updated to the newest version and I can't start either. The release I was upgrading from as the previous latest release. I am running on Unraid using Docker. This is a copy of the logs from Docker and Emby. I have tried removing all plugins and it still fails. It did clean up a few errors, but still fails. I do not know where the appHost.Init file is, I tried searching for it.

 

 

dockerlogs.txt

embylogs.txt

Edited by marauder
Link to comment
Share on other sites

I just updated to the newest version and I can't start either. The release I was upgrading from as the previous latest release. I am running on Unraid using Docker. This is a copy of the logs from Docker and Emby. I have tried removing all plugins and it still fails. It did clean up a few errors, but still fails. I do not know where the appHost.Init file is, I tried searching for it.

 

I ended up rebuilding my Library.db and got it working again. I am not sure why it got corrupted. I did the upgrade by logging into emby and shutting down the system, and waiting until docker read it as stopped, then ran the upgrade.

This is how I rebuilt my db.

 

 

I downloaded SQLite shell. This tool allows to export data in many forms including INSERTs. I run sqlite3.exe library.db.
 
The following script exports all content (as INSERTs) with schema into “dump_all.sql” file:
 
sqlite> .mode insert
sqlite> .output dump_all.sql
sqlite> .dump
sqlite> .exit”
 
run again: sqlite3.exe storage.fixed.data, where “storage.fixed.data” is name of non-existing file for my resurrected database.
 
The following script reads commands from “dump_all.sql” script file and recreates all database.
 
sqlite> .read dump_all.sql
Link to comment
Share on other sites

 

I ended up rebuilding my Library.db and got it working again. I am not sure why it got corrupted. I did the upgrade by logging into emby and shutting down the system, and waiting until docker read it as stopped, then ran the upgrade.

This is how I rebuilt my db.

 

 

I downloaded SQLite shell. This tool allows to export data in many forms including INSERTs. I run sqlite3.exe library.db.
 
The following script exports all content (as INSERTs) with schema into “dump_all.sql” file:
 
sqlite> .mode insert
sqlite> .output dump_all.sql
sqlite> .dump
sqlite> .exit”
 
run again: sqlite3.exe storage.fixed.data, where “storage.fixed.data” is name of non-existing file for my resurrected database.
 
The following script reads commands from “dump_all.sql” script file and recreates all database.
 
sqlite> .read dump_all.sql

 

 

Yea in your case somehow the database file got corrupted. Typical causes of this are sudden and abrupt terminations of the emby server process, such as a power loss, killing the process, machine crash, etc.

Link to comment
Share on other sites

Hello,

 

Yea in your case somehow the database file got corrupted. Typical causes of this are sudden and abrupt terminations of the emby server process, such as a power loss, killing the process, machine crash, etc.

 

Do you have an idea for my case ? Do you want more infos or logs of mine ?

 

Thanks in advance

Link to comment
Share on other sites

ok

 

Hello,

 

 

Do you have an idea for my case ? Do you want more infos or logs of mine ?

 

 

 

I just reinstall 4.2 over itself and retry to start without success but emby server log show now an error report (log attached), It seems like it's same problem that I encountered with upgrade to 3.5

embyserver.txt

Link to comment
Share on other sites

Yea this is supposed to be resolved in the .net core runtime and it's a tricky issue because i'd like to enable the feature that's causing it.

Link to comment
Share on other sites

so what ? is it a regression ?

I'm staying on 4.1 for now but can I hope for a fix in future beta or something like that ?

no offence, just to know :)

 

thanks

Link to comment
Share on other sites

Twistedcloud

I don't see anything obvious here, but can you shutdown the server, then go to this folder:

 

/var/lib/emby/plugins

And just delete all of the .dll files in this folder. Then try starting the server back up. Thanks.

 

I just did the latest update and am getting the same Error, I deleted all these files and it is still not working.

embyserver-63700277240.txt

embyserver-63700276713.txt

embyserver-63700277284.txt

Edited by Twistedcloud
  • Like 1
Link to comment
Share on other sites

Twistedcloud

I deleted the Library file out of the data folder and Emby loaded and is now rebuilding my library. The last update that happened caused a similar issue but my library would not scan in any new files this time Emby would refuse to load.

 

Not sure why updates are corrupting my library files.

Link to comment
Share on other sites

I deleted the Library file out of the data folder and Emby loaded and is now rebuilding my library. The last update that happened caused a similar issue but my library would not scan in any new files this time Emby would refuse to load.

 

Not sure why updates are corrupting my library files.

 

Are you force killing the server process because you think it's taking too long to load after installing the update? By far the most common cause of a corrupted database is abruptly stopping the server without a graceful shutdown. So that means loss of power, machine crash, killing the process, etc.

  • Like 1
Link to comment
Share on other sites

Twistedcloud

Are you force killing the server process because you think it's taking too long to load after installing the update? By far the most common cause of a corrupted database is abruptly stopping the server without a graceful shutdown. So that means loss of power, machine crash, killing the process, etc.

 

I told Emby to power down via the web app. Let it power down and show as the socket was offline I applied the update let it finish them powered on the docket and allowed it to boot fully (I actually walked away for 20 mins) came back realized it hadn't actually loaded checked the log and saw I had the same error as posted at the start of this thread (googled searched my error and the only hit was this thread). I tried your advice of removing the add-on DL files it didn't work but did change my error code. I deleted the Library DL file as you suggested to the other user and that had seemed to work.

 

I have been running Emby for last 3 years never had an issue like this until 4.0 since then I have had weird database issues that I have had to do full rebuilds. The rebuild take about 8 hours so I just run then at night.

 

I lose my watch statuses and any custom actor info though I use trakt for my watch status so it doesn't take much to get that back.

Edited by Twistedcloud
Link to comment
Share on other sites

Hello,

I just upgraded my Emby server to version 4.2.0.40 and it does not start anymore.

The error is :
 

emby-server.service - Emby Server is a personal media server with apps on just about every device.
   Loaded: loaded (/usr/lib/systemd/system/emby-server.service; enabled; vendor preset: enabled)
   Active: failed (Result: signal) since Sat 2019-08-03 19:48:17 CEST; 754ms ago
  Process: 3000 ExecStart=/opt/emby-server/bin/emby-server (code=killed, signal=ABRT)
 Main PID: 3000 (code=killed, signal=ABRT)

août 03 19:48:17 trantor emby-server[3000]:    at System.Net.NetworkInformation.LinuxNetworkInterface.<>c__DisplayClass5_0.<GetLinuxNetworkInterfaces>b__2(String name, LinkLayerAddressInfo* llAddr)
août 03 19:48:17 trantor emby-server[3000]:    --- End of inner exception stack trace ---
août 03 19:48:17 trantor emby-server[3000]:    at System.Net.NetworkInformation.LinuxNetworkInterface.GetLinuxNetworkInterfaces()
août 03 19:48:17 trantor emby-server[3000]:    at System.Net.NetworkInformation.NetworkInterfacePal.GetIsNetworkAvailable()
août 03 19:48:17 trantor emby-server[3000]:    at System.Net.NetworkInformation.NetworkChange.OnAvailabilityTimerFired(Object state)
août 03 19:48:17 trantor emby-server[3000]:    at System.Threading.TimerQueueTimer.CallCallback()
août 03 19:48:17 trantor emby-server[3000]:    at System.Threading.TimerQueueTimer.Fire()
août 03 19:48:17 trantor emby-server[3000]:    at System.Threading.TimerQueue.FireNextTimers()
août 03 19:48:17 trantor systemd[1]: emby-server.service: Main process exited, code=killed, status=6/ABRT
août 03 19:48:17 trantor systemd[1]: emby-server.service: Failed with result 'signal'.

My server is running Ubuntu 18.04.2.
 

Thank you.

embyserver-logs.txt

Link to comment
Share on other sites

Hello,

 

I just upgraded my Emby server to version 4.2.0.40 and it does not start anymore.

 

The error is :

 

emby-server.service - Emby Server is a personal media server with apps on just about every device.
   Loaded: loaded (/usr/lib/systemd/system/emby-server.service; enabled; vendor preset: enabled)
   Active: failed (Result: signal) since Sat 2019-08-03 19:48:17 CEST; 754ms ago
  Process: 3000 ExecStart=/opt/emby-server/bin/emby-server (code=killed, signal=ABRT)
 Main PID: 3000 (code=killed, signal=ABRT)

août 03 19:48:17 trantor emby-server[3000]:    at System.Net.NetworkInformation.LinuxNetworkInterface.<>c__DisplayClass5_0.<GetLinuxNetworkInterfaces>b__2(String name, LinkLayerAddressInfo* llAddr)
août 03 19:48:17 trantor emby-server[3000]:    --- End of inner exception stack trace ---
août 03 19:48:17 trantor emby-server[3000]:    at System.Net.NetworkInformation.LinuxNetworkInterface.GetLinuxNetworkInterfaces()
août 03 19:48:17 trantor emby-server[3000]:    at System.Net.NetworkInformation.NetworkInterfacePal.GetIsNetworkAvailable()
août 03 19:48:17 trantor emby-server[3000]:    at System.Net.NetworkInformation.NetworkChange.OnAvailabilityTimerFired(Object state)
août 03 19:48:17 trantor emby-server[3000]:    at System.Threading.TimerQueueTimer.CallCallback()
août 03 19:48:17 trantor emby-server[3000]:    at System.Threading.TimerQueueTimer.Fire()
août 03 19:48:17 trantor emby-server[3000]:    at System.Threading.TimerQueue.FireNextTimers()
août 03 19:48:17 trantor systemd[1]: emby-server.service: Main process exited, code=killed, status=6/ABRT
août 03 19:48:17 trantor systemd[1]: emby-server.service: Failed with result 'signal'.

My server is running Ubuntu 18.04.2.

 

Thank you.

 

@@Vjhbkfad this log is from an older version, 4.0.1.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...