Jump to content


Photo

TV episodes not showing

TV episodes season

Best Answer Luke , 03 August 2019 - 02:43 PM

It's more likely that by renaming it was no longer associated with anything in the database related to the old paths. Thanks for the feedback. Let us know how you get on.

 

You said you came from a really old version and going from version 3 to version 4 there were some upgrade related issues with dvd folder structures. I'm afraid that given the very small audience for folder rips nowadays, ultimately these were left as-is and required manual fixing by removing and then re-adding to the library.

Go to the full post


  • Please log in to reply
27 replies to this topic

#1 Taffer OFFLINE  

Taffer

    Advanced Member

  • Members
  • 43 posts
  • Local time: 04:17 AM
  • LocationPerth , Western Australia

Posted 30 July 2019 - 09:24 AM

I recently updated Emby to 4.2.0.40 from a much older version and after tweaking a couple of settings everything was running sweet ... almost. I am currently having an issue with some TV shows not showing any episodes. When I go into my TV folder I can see all the shows I have available and on some there is a number on the top right corner telling me how many episodes are in that shows folder.

5d4041cd6c23e_scrn1.jpg

If I go into a show that has the number in the top corner I can either play an episode or scroll through available episodes and select one to play etc.. however if I go into a show that does not have the number in the top corner I have no option to play any episodes and none are listed just the actors and artwork etc

 

I decided to check the folder structure and names etc to see if there was any difference between the shows

I found that in the shows that I could watch there was a system file called "season" in each of the Season folders but in the shows that I could not watch this file was missing !

What is this file ?

Can I manually add it to the season folder or is it generated by Emby or MCM or something like that



#2 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 46383 posts
  • Local time: 04:17 PM

Posted 30 July 2019 - 09:31 AM

Hi.  That number is the number of unwatched episodes in that series.  If you cannot see any content in the other ones, this is probably a file structure problem.

 

Is this setup as a mixed content library?  Do the problem shows have proper season folders?



#3 Taffer OFFLINE  

Taffer

    Advanced Member

  • Members
  • 43 posts
  • Local time: 04:17 AM
  • LocationPerth , Western Australia

Posted 30 July 2019 - 09:46 AM

The folder is setup as TV Shows and there is no mixed content in the folder or even on the drive

I went through the file structure with a fine tooth comb to find any differences but they are both the same

N:\TV SHOWS\The big bang theory\Season 1\s01e01

N:\TV SHOWS\Babylon 5\Season 1\s01e01

 

The only thing that I could find different between the two shows is the System file called "season" in the Babylon 5 folder



#4 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 46383 posts
  • Local time: 04:17 PM

Posted 30 July 2019 - 09:57 AM

What is directly in the Babylon 5 folder?



#5 Taffer OFFLINE  

Taffer

    Advanced Member

  • Members
  • 43 posts
  • Local time: 04:17 AM
  • LocationPerth , Western Australia

Posted 30 July 2019 - 10:07 AM

5d404f0f22ce1_scrn3.jpg



#6 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 46383 posts
  • Local time: 04:17 PM

Posted 30 July 2019 - 10:22 AM

or is it generated by Emby or MCM or something like that

 

Are you using both an external metadata manager (MCM) and Emby metadata management?  Choosing one or the other (I suggest just using ours) could help clear a lot of this up.



#7 Taffer OFFLINE  

Taffer

    Advanced Member

  • Members
  • 43 posts
  • Local time: 04:17 AM
  • LocationPerth , Western Australia

Posted 30 July 2019 - 10:34 AM

I initially used MCM years ago but possibly when I update Emby something caused a glitch there

Is the season file inside the Season folderpart of Emby ?

 

I think i will remove the whole folder out and refresh / restart Emby then make a new folder and move just the media back in

That way any metadata should be just Emby generated

Ill let you know what happens



#8 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 135852 posts
  • Local time: 04:17 PM

Posted 30 July 2019 - 11:12 AM

Let us know how you get on. Thanks.

#9 Taffer OFFLINE  

Taffer

    Advanced Member

  • Members
  • 43 posts
  • Local time: 04:17 AM
  • LocationPerth , Western Australia

Posted 31 July 2019 - 10:05 AM

Still no luck with this

I took the entire folder off the drive then refreshed the library then shut down and restarted emby, looked inside to make sure nothing was still showing

Shut down emby again and just incase I manually entered the N:\TV SHOWS\Babylon 5\Season 1\s01e01 etc then copied just the video_ts folder across for each episode, restarted emby and left it alone for an hour then refreshed the whole library, emby downloaded all the metadata and banners and posters etc

When I go into the folder to play I can see the posters and such as well as all the actors and movies like this but I still can not play anything

I have one option to PLAY ALL but that just says no compatible playback streams

 

If I go into the big bang theory I can play next or play all and I can scroll down to the Next Up or Seasons however these options do not appear in the Babylon 5 folder. Another thing I have noticed is that the shows that I can not watch have the played tick showing in red when I hover the mouse over them, if i change the tick to white then go into the folder the tick goes back to red again. When I go into the folder to try to play the tick is white even if the first layer tick is red

I tried select the folder and ticked the mark as unplayed option but none of these actions seem to stick

Getting more confused as time goes by



#10 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 46383 posts
  • Local time: 04:17 PM

Posted 31 July 2019 - 11:20 AM

 then copied just the video_ts folder across for each episode, 

 

Wait, that's new information... These are DVD folder rips?  Are the ones not working all folder rips and the ones that are working not?

 

That is an additional wrinkle that doesn't get much testing anymore.



#11 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 135852 posts
  • Local time: 04:17 PM

Posted 31 July 2019 - 01:12 PM

These aren't video files?

#12 Taffer OFFLINE  

Taffer

    Advanced Member

  • Members
  • 43 posts
  • Local time: 04:17 AM
  • LocationPerth , Western Australia

Posted 31 July 2019 - 06:53 PM

Both folders are exactly the same format, dvd rips using the same settings

They used to work in the earlier version without any problems but when I updated to the latest emby the problem started



#13 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 135852 posts
  • Local time: 04:17 PM

Posted 01 August 2019 - 12:51 AM

Can you show us what the contents of a season folder looks like?



#14 Taffer OFFLINE  

Taffer

    Advanced Member

  • Members
  • 43 posts
  • Local time: 04:17 AM
  • LocationPerth , Western Australia

Posted 02 August 2019 - 09:41 AM

Yep

5d443d9f8a6bd_scrn4.jpg



#15 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 46383 posts
  • Local time: 04:17 PM

Posted 02 August 2019 - 11:11 AM

Hi.  Can you please put it in "Details" view and be sure and show extensions and hidden files?

 

Thanks.



#16 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 135852 posts
  • Local time: 04:17 PM

Posted 02 August 2019 - 01:50 PM

Can you show the contents of an episode folder?



#17 Taffer OFFLINE  

Taffer

    Advanced Member

  • Members
  • 43 posts
  • Local time: 04:17 AM
  • LocationPerth , Western Australia

Posted 02 August 2019 - 06:59 PM

I did large tile view that shows all the details as well as show hidden folders

5d44c03412b72_scrn5.jpg



#18 Taffer OFFLINE  

Taffer

    Advanced Member

  • Members
  • 43 posts
  • Local time: 04:17 AM
  • LocationPerth , Western Australia

Posted 02 August 2019 - 06:59 PM

5d44c052e3270_scrn6.jpg



#19 Taffer OFFLINE  

Taffer

    Advanced Member

  • Members
  • 43 posts
  • Local time: 04:17 AM
  • LocationPerth , Western Australia

Posted 02 August 2019 - 07:00 PM

5d44c06e41406_scrn7.jpg



#20 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 15318 posts
  • Local time: 01:17 PM
  • LocationWashington State

Posted 02 August 2019 - 07:16 PM

The images to me would suggest a metadata issue as on has metadata and the other does not.







Also tagged with one or more of these keywords: TV episodes, season

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users