Jump to content


Photo

Connection fails on AndroidOne

android androidone

Best Answer stsier , 19 July 2019 - 05:29 AM

I found a WA 

I have a registered domain mydomain.com, I created a subdomain emby.mydomain.com and forwarded my emby server to it in the emby advanced server settings. Now I can connect from everywhere to emby.mydomain.com:8096 including my Android phone.

Emby API works as well with this WA. 

 

Go to the full post


  • Please log in to reply
7 replies to this topic

#1 stsier OFFLINE  

stsier

    Newbie

  • Members
  • 4 posts
  • Local time: 07:51 PM

Posted 12 July 2019 - 05:17 AM

Hi, 

I am a mobile app developper enthusiast, I really enjoyed emby API and created my sort of spotify with my own music. 

But my gorgeous Samsung Note9 has been stolen recently, and I moved to a much cheaper Xiaomi Mi2 with Google's native AndroidOne. 

Since then, impossible to connect to my emby server from a mobile connection. Everything works fine on WiFi. 

While on mobile network, neither API, nor emby app, nor browser.. An apache run server doesn't reply either. So that's not an Emby problem. Maybe the incompatibility of a IPv6 phone to connect to my IPv4 server.

If anyone would have a suggestion, would be much appreciated

 



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 135841 posts
  • Local time: 01:51 PM

Posted 13 July 2019 - 01:08 PM

Hi there, are you trying to connect over https, or http?



#3 stsier OFFLINE  

stsier

    Newbie

  • Members
  • 4 posts
  • Local time: 07:51 PM

Posted 13 July 2019 - 01:14 PM

Hi
yes I tried both. I have a connection error instantly. So it's definitely Android's limitation or bug.

#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 135841 posts
  • Local time: 01:51 PM

Posted 16 July 2019 - 12:34 AM

Have you tried by entering the server ip address manually into the app?



#5 stsier OFFLINE  

stsier

    Newbie

  • Members
  • 4 posts
  • Local time: 07:51 PM

Posted 16 July 2019 - 04:28 AM

yes, i tried with both 8096 and 8920 ports. 

i can't even ping "google.com" from my phone, there's something blocking on the Android's side. And only on mobile connection, works fine on wifi. 

Maybe the ipv6 of the LTE chip of the phone, incompatible with ipv4 of my static ip address server. 



#6 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 135841 posts
  • Local time: 01:51 PM

Posted 16 July 2019 - 11:19 AM

That's interesting. Thanks for the info.

#7 stsier OFFLINE  

stsier

    Newbie

  • Members
  • 4 posts
  • Local time: 07:51 PM

Posted 19 July 2019 - 05:29 AM   Best Answer

I found a WA 

I have a registered domain mydomain.com, I created a subdomain emby.mydomain.com and forwarded my emby server to it in the emby advanced server settings. Now I can connect from everywhere to emby.mydomain.com:8096 including my Android phone.

Emby API works as well with this WA. 

 


  • Luke likes this

#8 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 135841 posts
  • Local time: 01:51 PM

Posted 19 July 2019 - 02:04 PM

thanks for the feedback !







Also tagged with one or more of these keywords: android, androidone

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users