Jump to content

Trakt PlugIn Sync not working since more than a week


Go to solution Solved by hi2hello,

Recommended Posts


Hi there,


since mid June (logs just date back till June 18th), my emby server (Version running under Linux > unRaid in docker) can no longer connect to trakt for syncing the library. 

"Import Playstates from Trakt.tv" works fine.

"Sync library to trakt.tv" constantly faiils.


I already got a new PIN, no success.


Here is what the error message says:

at Emby.Server.Implementations.HttpClientManager.CoreHttpClientManager.SendAsyncInternal(HttpRequestOptions options, String httpMethod)
at Emby.Server.Implementations.HttpClientManager.CoreHttpClientManager.SendAsync(HttpRequestOptions options, String httpMethod)
at Trakt.Api.TraktApi.<>c__DisplayClass32_0.<<PostToTrakt>b__0>d.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
at Trakt.Api.TraktApi.Retry[T](Func`1 function)
at Trakt.Api.TraktApi.PostToTrakt(String url, Object data, CancellationToken cancellationToken, TraktUser traktUser)
at Trakt.Api.TraktApi.RefreshUserAuth(TraktUser traktUser)
at Trakt.Api.TraktApi.SetRequestHeaders(HttpRequestOptions options, TraktUser traktUser)
at Trakt.Api.TraktApi.GetFromTrakt(String url, CancellationToken cancellationToken, TraktUser traktUser)
at Trakt.Api.TraktApi.SendGetAllWatchedMoviesRequest(TraktUser traktUser)
at Trakt.ScheduledTasks.SyncLibraryTask.SyncMovies(User user, TraktUser traktUser, ISplittableProgress`1 progress, CancellationToken cancellationToken)
at Trakt.ScheduledTasks.SyncLibraryTask.SyncUserLibrary(User user, TraktUser traktUser, ISplittableProgress`1 progress, CancellationToken cancellationToken)
at Trakt.ScheduledTasks.SyncLibraryTask.Execute(CancellationToken cancellationToken, IProgress`1 progress)
at Emby.Server.Implementations.ScheduledTasks.ScheduledTaskWorker.ExecuteInternal(TaskOptions options)

Any idea on that matter?
Thank you! 

Edited by hi2hello
Link to comment
Share on other sites


Can I send this via PM?

Would prefer not to post this in public 


Alternatively I could replace all IPs, network names and things I dont want to get exposed that are shown in the log

Edited by hi2hello
Link to comment
Share on other sites

  • 2 weeks later...

Did not find the time to post this earlier.

Here are the logs, including errrors at the end of the logfile trying to sync library to trakt.tv.

In the meantime, I deinstalled the trakt plugin, rebootet the server, reinstalled the plugin, rebootet once more: still the same error messages.

Also tried a new trakt PIN with no luck.


As stated before:

Import playstates from Trakt.tv > works

Sync library to trakt.tv > constantly throws errors / exceptions


Please find emby server warning and log (anonymized) attached.

Emby Server running in Docker under unRaid 6.7.2

emby warn message.txt


Edited by hi2hello
Link to comment
Share on other sites

Are you sure you setup trakt correctly? It's acting as if you haven't completed setup.

Link to comment
Share on other sites


Thanks for your reply.


I Don’t know. As I said, it suddenly stopped working (after the update to


Here is what I did:

I installed the trakt PlugIn, went to "settings", selected my my main user in "configure trakt for", got an authentication pin from the website that I entered under "Authentication PIN", did not exclude any folders and selected the first two checkboxes "skip unwatched import from trakt" and "update trakt watched history during scheduled task".


Than I saved.

Just to be sure I did this with and without server reboot. Made no difference.


As this was not working, I did an uninstall of the trakt plug in. Rebooted server, than re-installed trakt. Server reboot. And than settings of trakt with another newly generated PIN to authenticate. Emby is listed under "connected apps" in trakt. 


What else to do? Anything I missed? 


The function "import playstates from trakt.tv" (takes 6 seconds) is working. Just "sync library to trakt.tv" throws exceptions. The progression bar runs till 100% but says "error" afterwards (takes 10 seconds).


Is there maybe any webservice used except for trakt.tv that might be blocked by pi-hole? That is the only thing I could think of, although it would not work in either directions, right?!

Edited by hi2hello
Link to comment
Share on other sites

I would suggest trying again following the release of emby server 4.2 as there will be some updates to the plugin. I'm not sure it will make a difference, but it's worth trying and re-evaluating at that time.


In the meantime you could try deleting the trakt xml config file, restarting the server, and then setting trakt back up.

Link to comment
Share on other sites

Well I'm currently mobile so from memory it should be




Look for an Xml file under there for trakt.


Make sure to restart the server after deleting it. Please let us know if this helps. Thanks.

Link to comment
Share on other sites

  • Solution

For Emby running in a Docker (on unRaid), follow this solution:


trakt.dll is under appdata/EmbyServer/plugins/

the trakt.xml can be found here: appdata/EmbyServer/plugins/configurations/


Deinstalled the PlugIn, restarted the server, restarted the docker and than deleted the trakt.xml, followed by the same reboot procedure of server and docker.

Than reinstalled the plugin, rebooted server and docker once more.


Got a new PIN and finally, it is working again. 


Thanks for your help!

Edited by hi2hello
  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...