Jump to content


Photo

Subtitles would not auto download

subtitle

  • Please log in to reply
7 replies to this topic

#1 cyl OFFLINE  

cyl

    Newbie

  • Members
  • 4 posts
  • Local time: 09:59 PM

Posted 19 June 2019 - 11:50 PM

I am trying to have Emby always automatically download subtitles even if video already contains embedded subtitles, but it is not happening automatically.

 

Would anyone know what I am doing wrong?

 

Here are what I know

  • Automatic subtitle download is working. I observe another video in the same folder having subtitles downloaded automatically
  • Settings
    5d0b00dbf3b11_subtitlessettings.png
  • File is mkv format
  • Playing the file does show English (Default SUBRIP) in CC
  • No subtitle file is saved in folder for that video, even though the option to skip if embedded is unchecked
  • Manually going to the video Edit Subtitles options with require a hash match does come up with Hash match results
  • I can manually download the subtitle, and observe the subtitle file in the folder
  • I tried turning debugging log on, and running the scheduled download missing subtitle job, but I did not see any useful log


#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142356 posts
  • Local time: 12:59 AM

Posted 20 June 2019 - 12:35 AM

Hi, we're preparing a wiki article that will step you through this because it comes up frequently.

 

But if the manual search produces nothing then i would check your server log because possible you may just have connection problems to the subtitle websites.

 

You did fill in your open subtitles credentials, right?



#3 cyl OFFLINE  

cyl

    Newbie

  • Members
  • 4 posts
  • Local time: 09:59 PM

Posted 20 June 2019 - 03:00 AM

Yep. Filled it with credential.

Also, manual search produces exact hash match.

Manual search also allows me to pick one and it'll download it to the folder.



#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142356 posts
  • Local time: 12:59 AM

Posted 20 June 2019 - 12:40 PM

Then you probably just need to wait and allow the subtitle scheduled task to run.

#5 cyl OFFLINE  

cyl

    Newbie

  • Members
  • 4 posts
  • Local time: 09:59 PM

Posted 20 June 2019 - 07:28 PM

I did wait. 

 

I also did Settings > Schedule Task > Download Missing subtitles

 

Neither did it. 



#6 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142356 posts
  • Local time: 12:59 AM

Posted 21 June 2019 - 12:47 AM

Your movies will need to be tagged with an Imdb id in Emby, unless they are a perfect hash match for open subtitles. Have you checked on this?



#7 cyl OFFLINE  

cyl

    Newbie

  • Members
  • 4 posts
  • Local time: 09:59 PM

Posted 21 June 2019 - 12:54 AM

Yes, when I do manual search, the search result shows perfect hash match



#8 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142356 posts
  • Local time: 12:59 AM

Posted 21 June 2019 - 12:56 AM

Can you please go over an example and attach the emby server log? thanks.







Also tagged with one or more of these keywords: subtitle

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users