Jump to content


Photo

Cannot Install Emby Server on Pi Zero W


  • Please log in to reply
1 reply to this topic

#1 seebeeess OFFLINE  

seebeeess

    Newbie

  • Members
  • 1 posts
  • Local time: 02:25 AM

Posted 08 June 2019 - 07:21 AM

I've been trying for nearly 5 hours trying to get Emby Server installed on my Pi Zero W (Raspbian) with no luck.

 

I'm no Linux expert so apologies if the terminology gets mixed up here (or if I ask stupid questions!), but I have tried the following methods to no avail:

 

Direct Download and Install From https://emby.media/linux-server.html: This gives the following error when I try to start the service:

 

root@raspberrypi:/etc/apt/sources.list.d# systemctl start emby-server

root@raspberrypi:/etc/apt/sources.list.d# systemctl status emby-server

emby-server.service - Emby Server is a personal media server with apps on just about every device.

   Loaded: loaded (/usr/lib/systemd/system/emby-server.service; enabled; vendor preset: enabled)

   Active: failed (Result: signal) since Sat 2019-06-08 12:02:01 BST; 30s ago

  Process: 25671 ExecStart=/opt/emby-server/bin/emby-server (code=killed, signal=SEGV)

 Main PID: 25671 (code=killed, signal=SEGV)

      CPU: 9ms

 

Jun 08 12:02:01 raspberrypi systemd[1]: Started Emby Server is a personal media server with apps on just about every device..

Jun 08 12:02:01 raspberrypi systemd[1]: emby-server.service: Main process exited, code=killed, status=11/SEGV

Jun 08 12:02:01 raspberrypi systemd[1]: emby-server.service: Unit entered failed state.

Jun 08 12:02:01 raspberrypi systemd[1]: emby-server.service: Failed with result 'signal'.

 

 

Install using apt-get via guide here https://akosresch.wo...raspberry-pi-3/ : This involves installing mono first. It gives an error which means nothing to me:

 

root@raspberrypi:/etc/apt/sources.list.d# sudo service emby-server start

root@raspberrypi:/etc/apt/sources.list.d# sudo service emby-server status

emby-server.service - Emby Media Server

   Loaded: loaded (/lib/systemd/system/emby-server.service; disabled; vendor preset: enabled)

   Active: failed (Result: exit-code) since Sat 2019-06-08 12:16:38 BST; 3s ago

  Process: 26682 ExecStopPost=/usr/bin/emby-server clear (code=exited, status=1/FAILURE)

  Process: 26655 ExecStart=/usr/bin/emby-server start (code=exited, status=1/FAILURE)

 Main PID: 26655 (code=exited, status=1/FAILURE)

      CPU: 611ms

 

Jun 08 12:16:38 raspberrypi emby-server[26682]:   -Z, --selinux-user SEUSER     new SELinux user mapping for the user account

Jun 08 12:16:38 raspberrypi emby-server[26682]: dirname: missing operand

Jun 08 12:16:38 raspberrypi emby-server[26682]: Try 'dirname --help' for more information.

Jun 08 12:16:38 raspberrypi emby-server[26682]: mkdir: missing operand

Jun 08 12:16:38 raspberrypi emby-server[26682]: Try 'mkdir --help' for more information.

Jun 08 12:16:38 raspberrypi emby-server[26682]: chown: missing operand after ‘.’

Jun 08 12:16:38 raspberrypi emby-server[26682]: Try 'chown --help' for more information.

Jun 08 12:16:38 raspberrypi systemd[1]: emby-server.service: Control process exited, code=exited status=1

Jun 08 12:16:38 raspberrypi systemd[1]: emby-server.service: Unit entered failed state.

Jun 08 12:16:38 raspberrypi systemd[1]: emby-server.service: Failed with result 'exit-code'.

 

 

Can anybody help? I definitely don't think it should be this difficult. All I want to do is have an Emby Server set up on my Pi so that I can connect to it via the Samsung TV Emby app. Emby is essential as it is the only media manager I have found that reliably downloads and manages subtitles properly and I am hard of hearing.


Edited by seebeeess, 08 June 2019 - 07:21 AM.


#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 129303 posts
  • Local time: 09:25 PM

Posted 09 June 2019 - 12:00 AM

Hi, the CPU for this is armv6, right?






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users