Jump to content


Photo

Issues in Linux setup

metadata slow

  • Please log in to reply
29 replies to this topic

#21 mastrmind11 OFFLINE  

mastrmind11

    Advanced Member

  • Members
  • 2770 posts
  • Local time: 01:23 PM
  • LocationLong Island, NY

Posted 06 June 2019 - 03:23 PM

For NFS fstab, if you ever get it working:

10.0.1.151:/storage/tv /storage/tv nfs rsize=8192,wsize=8192,timeo=14,intr

Keep in mind the uid/gid access has to match whoever you are on the client (ie, emby's uid needs to exist on your NAS in a group that has r/w access to the share)



#22 eversmannx OFFLINE  

eversmannx

    Member

  • Members
  • 14 posts
  • Local time: 06:23 PM

Posted 12 June 2019 - 07:19 AM

Sorry, I've been away and didn't get a chance to try your instructions till now.

 

I am unable to get passed the first step...

 

eversmannx@ThinkPad-T410:~$ showmount -e 192.168.0.22
Export list for 192.168.0.22:
/nfs *
eversmannx@ThinkPad-T410:~$

 

 

I tried a few variations, but not sure how to use this (nfs *) in the next step.

sudo mount -t nfs -o rw,soft,intr //192.168.0.22:/export_path /nas/movies

 

Just FYI:

When I try to access the same NAS through Kodi and nfs for installing add-ons, the path shown in the bottom is nfs://192.168.0.22/nfs/Movies etc - i tried similar path in the above syntax for "export_path" but no luck

 

My working /etc/fstab currently again is:

//192.168.0.22/Movies /nas/movies  cifs  guest,iocharset=utf8,sec=ntlm,vers=1.0  0  0
//192.168.0.22/TV_SHOWS /nas/tv  cifs  guest,iocharset=utf8,sec=ntlm,vers=1.0  0  0

 

although it shows root access, i am not able to delete things from Emby interface.

eversmannx@ThinkPad-T410:/nas/tv/_TV/TV_SHOWS/South Park/Season 09$ ls -l
total 1999552
-rwxr-xr-x 1 root root       771 Jun  3 15:39  season.nfo
-rwxr-xr-x 1 root root 154148864 Aug 30  2011 'South Park [9.01] Mr. Garrison'\''s Fancy New Vagina.avi'
-rwxr-xr-x 1 root root     26055 May 26 01:15 'South Park [9.01] Mr. Garrison'\''s Fancy New Vagina.en.srt'
-rwxr-xr-x 1 root root      1762 May 28 12:17 'South Park [9.01] Mr. Garrison'\''s Fancy New Vagina.nfo'
-rwxr-xr-x 1 root root         0 May 26 15:30 'South Park [9.01] Mr. Garrison'\''s Fancy New Vagina-thumb.jpg'
-rwxr-xr-x 1 root root 183549952 Aug 30  2011 'South Park [9.02] Die Hippie, Die.avi'

 

 

 

 

 

 

 

 

With your CIFS mount command I am kinda surprised it works since you have vers=1. SMB1 has security issues. Windows 10 is now SMB3.0.

** Commands for NFS mount **
You need the nfs client installed...
$ apt-get install nfs-utils

See what exports are shared...
$ showmount -e 192.168.0.22

This should work for mounting...
$ sudo mount -t nfs -o rw,soft,intr //192.168.0.22:/export_path /nas/movies


** Autofs Setup **
Edit /etc/auto.master and add in the line...
/nas /etc/auto.nas

Create the file /etc/auto.nas and add in the line...
movies -fstype=nfs,rw,soft,intr 192.168.0.22:/export_path

Start and enable the autofs service.
$ sudo systemctl enable autofs
$ sudo systemctl start autofs

See if you can get to the mount under /nas/movies


Sent from my PH-1 using Tapatalk



#23 sargenthp OFFLINE  

sargenthp

    Advanced Member

  • Members
  • 50 posts
  • Local time: 12:23 PM
  • LocationEau Claire, WI

Posted 12 June 2019 - 07:29 AM

Ok. So your exporting "/nas" to all systems (*).

See if this works...
sudo mount -t nfs -o rw,soft,intr //192.168.0.22:/nas/movies /nas/movies

Sent from my PH-1 using Tapatalk

#24 eversmannx OFFLINE  

eversmannx

    Member

  • Members
  • 14 posts
  • Local time: 06:23 PM

Posted 12 June 2019 - 07:32 AM

no luck :-(

 

eversmannx@ThinkPad-T410:~$ sudo mount -t nfs -o rw,soft,intr //192.168.0.22:/nas/movies /nas/movies
mount.nfs: Failed to resolve server //192.168.0.22: Name or service not known
eversmannx@ThinkPad-T410:~$

 



#25 sargenthp OFFLINE  

sargenthp

    Advanced Member

  • Members
  • 50 posts
  • Local time: 12:23 PM
  • LocationEau Claire, WI

Posted 12 June 2019 - 07:33 AM

Also remember Linux is case sensitive. So if your folder is named Movies instead of movies it will fail.

So the command might be...

sudo mount -t nfs -o rw,soft,intr //192.168.0.22:/nas/Movies /nas/movies

Or

sudo mount -t nfs -o rw,soft,intr //192.168.0.22:/nas/Movies /nas/Movies

Sent from my PH-1 using Tapatalk

#26 eversmannx OFFLINE  

eversmannx

    Member

  • Members
  • 14 posts
  • Local time: 06:23 PM

Posted 12 June 2019 - 07:38 AM

Okay, it is actually "Movies" with a capital M.

 

not sure if you mistyped /nas instead of /nfs, i tried both anyways..

 

eversmannx@ThinkPad-T410:~$ sudo mount -t nfs -o rw,soft,intr //192.168.0.22:/nas/Movies /nas/movies
mount.nfs: Failed to resolve server //192.168.0.22: Name or service not known

eversmannx@ThinkPad-T410:~$ sudo mount -t nfs -o rw,soft,intr //192.168.0.22:/nfs/Movies /nas/movies
mount.nfs: Failed to resolve server //192.168.0.22: Name or service not known
eversmannx@ThinkPad-T410:~$

 



#27 sargenthp OFFLINE  

sargenthp

    Advanced Member

  • Members
  • 50 posts
  • Local time: 12:23 PM
  • LocationEau Claire, WI

Posted 12 June 2019 - 07:52 AM

Sorry my bad... It is nfs that it is exporting.

And NFS doesn't use // in front of the server name.

sudo mount -t nfs -o rw,soft,intr 192.168.0.22:/nfs/Movies /nas/movies

Sent from my PH-1 using Tapatalk

#28 eversmannx OFFLINE  

eversmannx

    Member

  • Members
  • 14 posts
  • Local time: 06:23 PM

Posted 12 June 2019 - 08:00 AM

That works! Many Thanks!

 

eversmannx@ThinkPad-T410:~$ sudo mount -t nfs -o rw,soft,intr 192.168.0.22:/nfs/Movies /nas/movies
[sudo] password for eversmannx:
eversmannx@ThinkPad-T410:~$ cd /nas/movies/
eversmannx@ThinkPad-T410:/nas/movies$ ls
 _MOVIES  'Network Trash Folder'  'Temporary Items'

 

 

I will go back and follow your instructions for autofs later.

the nfs mount above did ask for the password - as i have same userid/password for linux account and nas - i wasn't sure which it picked up. But i did create a user called "emby" (with a password) for the nas, and hoping to use that for the autofs process.

 



#29 eversmannx OFFLINE  

eversmannx

    Member

  • Members
  • 14 posts
  • Local time: 06:23 PM

Posted 12 June 2019 - 10:04 AM

Eveyrthings works perfectly now! @sargenthp - you're a legend! Thank you so much for all your help.

 

autofs loads the shares as below when i rebooted the computer, and can delete files from Kodi interface now.

 

eversmannx@ThinkPad-T410:~$ df

...
192.168.0.22:/nfs/Movies   1941348672 1718503168 222845504  89% /nas/movies
192.168.0.22:/nfs/TV_SHOWS 1941348672 1718503168 222845504  89% /nas/tv

 


  • sargenthp likes this

#30 sargenthp OFFLINE  

sargenthp

    Advanced Member

  • Members
  • 50 posts
  • Local time: 12:23 PM
  • LocationEau Claire, WI

Posted 12 June 2019 - 11:52 AM

Sweet!!! Enjoy!

Sent from my PH-1 using Tapatalk





Also tagged with one or more of these keywords: metadata, slow

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users