Jump to content


Photo

Downloads failing to start


  • Please log in to reply
31 replies to this topic

#1 darkassassin07 ONLINE  

darkassassin07

    Advanced Member

  • Members
  • 703 posts
  • Local time: 04:33 AM

Posted 23 May 2019 - 04:38 PM

Myself and a few of my users have been having trouble using download&sync.
Items simply fail to start transferring either staying at "Ready to transfer" or "Transferring 0%"

Server version 4.1.1.0 on Win 10 pro
Client: Emby for android version 3.0.48 on Android v8.0.0 (moto z2 play)


Error from log:
2019-05-23 13:29:53.085 Error HttpServer: Error processing request
*** Error Report ***
Version: 4.1.1.0
Command line: C:\Users\Darkassassin07\AppData\Roaming\Emby-Server\system\EmbyServer.dll -noautorunwebapp
Operating system: Microsoft Windows NT 6.2.9200.0
64-Bit OS: True
64-Bit Process: True
User Interactive: True
Runtime: file:///C:/Users/Darkassassin07/AppData/Roaming/Emby-Server/system/System.Private.CoreLib.dll
Processor count: 12
Program data path: C:\Users\Darkassassin07\AppData\Roaming\Emby-Server\programdata
Application directory: C:\Users\Darkassassin07\AppData\Roaming\Emby-Server\system
MediaBrowser.Common.Extensions.ResourceNotFoundException: MediaBrowser.Common.Extensions.ResourceNotFoundException: Exception of type 'MediaBrowser.Common.Extensions.ResourceNotFoundException' was thrown.
   at Emby.Server.Sync.Api.SyncService.Get(GetSyncJobItemFile request)
   at Emby.Server.Implementations.Services.ServiceExecGeneral.GetTaskResult(Task task)
   at Emby.Server.Implementations.Services.ServiceHandler.ProcessRequestAsync(HttpListenerHost appHost, IRequest httpReq, IResponse httpRes, ILogger logger, String operationName, CancellationToken cancellationToken)
   at Emby.Server.Implementations.HttpServer.HttpListenerHost.RequestHandler(IRequest httpReq, String urlString, String host, String localPath, CancellationToken cancellationToken)
Source: Emby.Server.Sync
TargetSite: Void MoveNext()




/edit:


A couple hours later I'm also noticing 'download unsuccessful' notifications from the android download manager that only pop up for a second or two then disappear from the notification tray. No sounds at all.

Attached Files


Edited by darkassassin07, 23 May 2019 - 07:07 PM.


#2 darkassassin07 ONLINE  

darkassassin07

    Advanced Member

  • Members
  • 703 posts
  • Local time: 04:33 AM

Posted 25 May 2019 - 05:46 PM

Is anyone else having issues with download/sync?

Neither option seems to work for me. Everything I'm trying to download plays just fine both in and out of emby, but emby itself refuses to transfer it from the server to clients for offline use. It just sits at 0% with the clients download manager occasionally saying 'download failed' for a fraction of a second.

This behavior is the same when connected directly to the servers lan address, as well as remote access.

#3 darkassassin07 ONLINE  

darkassassin07

    Advanced Member

  • Members
  • 703 posts
  • Local time: 04:33 AM

Posted 26 May 2019 - 10:05 PM

3 days later and no one has even bothered to look at the log.... "0 downloads"

I'm starting to think I'm going to have to create new accounts to get support. It seems like any time I try to get help with this software lately the threads get completely ignored. It's not like this forum is inactive.... I spend a fair amount of time here trying to help others the best I can while providing my own opinion/point of view.


I just don't understand why my requests for help go unanswered while 30+ other threads get created, answered, and closed in the same time.

What have I done to deserve the cold shoulder?

@Luke

Edited by darkassassin07, 27 May 2019 - 04:59 AM.

  • daedalus likes this

#4 revengineer OFFLINE  

revengineer

    Advanced Member

  • Members
  • 744 posts
  • Local time: 07:33 AM

Posted 27 May 2019 - 04:26 PM

Syncing/downloading not working has been a long standing issue on several devices. I reported and provided many debugging logs about 6 months ago. Reports by many followed. The devs have decided to ignore further reports and nagging by us a while ago.


  • daedalus and darkassassin07 like this

#5 daedalus OFFLINE  

daedalus

    Advanced Member

  • Members
  • 1041 posts
  • Local time: 01:33 PM

Posted 27 May 2019 - 06:26 PM

welcome to the world of emby



#6 daedalus OFFLINE  

daedalus

    Advanced Member

  • Members
  • 1041 posts
  • Local time: 01:33 PM

Posted 27 May 2019 - 06:32 PM

3 days later and no one has even bothered to look at the log.... "0 downloads"

I'm starting to think I'm going to have to create new accounts to get support. It seems like any time I try to get help with this software lately the threads get completely ignored. It's not like this forum is inactive.... I spend a fair amount of time here trying to help others the best I can while providing my own opinion/point of view.


I just don't understand why my requests for help go unanswered while 30+ other threads get created, answered, and closed in the same time.

What have I done to deserve the cold shoulder?

@Luke

 

simply deal with it, that's how they decided to handle it

i'm in the same situation and only a small step away from gaining so much free time back and simply don't care anymore



#7 dotcom OFFLINE  

dotcom

    Member

  • Members
  • 23 posts
  • Local time: 04:33 AM

Posted 27 May 2019 - 08:48 PM

Two requirements:

1. set storage to internal (emby doesn’t work with Ed cards currently)
2. Go into sync on the server and delete any downloads in progress or existing.

Then close the app and retry a download.

#8 darkassassin07 ONLINE  

darkassassin07

    Advanced Member

  • Members
  • 703 posts
  • Local time: 04:33 AM

Posted 28 May 2019 - 01:23 AM

Thanks @dotcom,

Download&sync is a feature I very rarely use. Last time I used it, I didn't have any issues. At the time it was set to external storage and thats just where I left it.

Switching to internal storage seems to have allowed it to function for now.

I appreciate the help.

#9 revengineer OFFLINE  

revengineer

    Advanced Member

  • Members
  • 744 posts
  • Local time: 07:33 AM

Posted 28 May 2019 - 07:10 AM

Two requirements:

1. set storage to internal (emby doesn’t work with Ed cards currently)
2. Go into sync on the server and delete any downloads in progress or existing.

Then close the app and retry a download.

The workaround is unacceptable. The internal storage of my device can barely hold one movie and only if I compress (transcode) them. A solution is needed, and I point out that all of this used to work until some genius screwed up the code.



#10 gu5gus OFFLINE  

gu5gus

    Newbie

  • Members
  • 1 posts
  • Local time: 04:33 AM

Posted 28 May 2019 - 02:18 PM

Honestly? The best workaround is to install Plex and use it for sync only. Emby has better streaming performance, and Plex has better....everything else. I've been using them both for years.

 

p.s. hey devs, do you want to kill your project? because this is how you kill your project.

 

The good news is that you can submit pull requests on their github account. No idea whether they consider them though. I assume so since their account has 118 contributors.

 

Oh..The code on github is v 3.5, like a year and a half old. Sad.


Edited by gu5gus, 28 May 2019 - 02:24 PM.


#11 dotcom OFFLINE  

dotcom

    Member

  • Members
  • 23 posts
  • Local time: 04:33 AM

Posted 30 May 2019 - 07:33 PM

It will get fixed, I'm sure they're working on it. It's not easy to support all the different devices and OSes/versions. There's a thread on this to watch: https://emby.media/c...ternal-storage/



#12 revengineer OFFLINE  

revengineer

    Advanced Member

  • Members
  • 744 posts
  • Local time: 07:33 AM

Posted 30 May 2019 - 08:10 PM

The biggest issue I have with this bug that the downloads used to work well through app version 2.9. It all got hosed with app version 3. For the longest time, the work around was to simply use the old app version and prevent it from updating by self signing the apk. However, app version 2 is not compatible with server version 4, so for the last 6+ months I had to travel without movies and that sucked.

 

Moral of the story is to pay attention during the betas so that no nutjob comes along and asks for changes the screw emby up for everyone else. 


Edited by revengineer, 30 May 2019 - 08:11 PM.

  • daedalus likes this

#13 darkassassin07 ONLINE  

darkassassin07

    Advanced Member

  • Members
  • 703 posts
  • Local time: 04:33 AM

Posted 30 May 2019 - 09:07 PM

As long as you dont need the content transcoded before transfer, I have just been using a filezilla ftp server to get media for offline use. Just another option if you really need it in the meantime.

#14 daedalus OFFLINE  

daedalus

    Advanced Member

  • Members
  • 1041 posts
  • Local time: 01:33 PM

Posted 31 May 2019 - 10:25 AM

It will get fixed, I'm sure they're working on it. It's not easy to support all the different devices and OSes/versions. There's a thread on this to watch: https://emby.media/c...ternal-storage/

 

just stay a bit longer and you'll see how things get handled here


Edited by daedalus, 31 May 2019 - 10:25 AM.


#15 notla49285 OFFLINE  

notla49285

    Advanced Member

  • Members
  • 365 posts
  • Local time: 12:33 PM

Posted 11 June 2019 - 08:22 AM

Is anyone else having issues with download/sync?

Neither option seems to work for me. Everything I'm trying to download plays just fine both in and out of emby, but emby itself refuses to transfer it from the server to clients for offline use. It just sits at 0% with the clients download manager occasionally saying 'download failed' for a fraction of a second.

This behavior is the same when connected directly to the servers lan address, as well as remote access.

 

I don't have an answer to your problems but just to add - yes, I have also had the same problems as you. The downloads facility on the Android app (can't check iOS) are awful, mainly due to the information that the app gives. If it's waiting for a response from my server, or it's a slow download, or there's some kind of error - fine, but tell me about it. Sitting there saying "Ready to Transfer" is not at all helpful, like me sat at my work desk saying "Ready to start working" and then just not doing anything...

 

I can't criticise Emby devs too much because sometimes they are shit hot on support, but with this particular issue it's been going on for too long now. It's unusable for me and I have to tell any users that want it to just grin and bear it, and a couple of times I've actually taken their device home to my network and downloaded it there (after a while) then given it back, which is really dumb.



#16 computerprep OFFLINE  

computerprep

    Advanced Member

  • Members
  • 315 posts
  • Local time: 07:33 AM
  • LocationCentral Florida

Posted 11 June 2019 - 09:57 AM

I've had download issues for a while, and suspected it was mostly because of my reverse proxy. So I finally got those errors ironed out and attempted some download troubleshooting.

Previously, downloading only worked within LAN for me. Now in testing in WAN and it's working. Yay.

The downside (maybe related to OP, same app/server versions) is that the downloads page shows "Transferring 0%" until the download finished, which can be a while on my 10Mbps upstream if lots of other things are happening simultaneously.

When I use a file browser to navigate to the default location for internal storage, the files are present, showing their full reserved side while they finish downloading. I can play then with VLC or whatever while they download. Playback just stops wherever the download progress is currently.

Android never shows me a Download Manager notification or progress bar. I think it does on LAN, but can't test that right now. I believe I get a notification on WAN download when it completed, but again, no progress bar. Will update later when it completes.

Screenshot showing 0% transferring
Attached File  Screenshot_20190611-095242.png   594.62KB   0 downloads

Screenshot showing detail screen of download.
Attached File  Screenshot_20190611-095304.png   851.52KB   0 downloads

Screenshot showing my file browser pointed to the download folder.
Attached File  Screenshot_20190611-095251.png   388.15KB   0 downloads

Screenshot showing playback working in external player, initiated by file browser.
Attached File  Screenshot_20190611-100610.png   95.21KB   0 downloads

Edited by computerprep, 11 June 2019 - 10:07 AM.


#17 computerprep OFFLINE  

computerprep

    Advanced Member

  • Members
  • 315 posts
  • Local time: 07:33 AM
  • LocationCentral Florida

Posted 11 June 2019 - 10:20 AM

Its definitely downloading, and it looks like it's in spurts.

Screenshot of data activity.
Attached File  Screenshot_20190611-101832.png   639.82KB   0 downloads

#18 daedalus OFFLINE  

daedalus

    Advanced Member

  • Members
  • 1041 posts
  • Local time: 01:33 PM

Posted 11 June 2019 - 01:46 PM

most people have problems downloading with android 9 pie and/or external memory

 

here on android 9 simply nothing loads and after a couple of hours i got the error message, that nothing was downloaded

internal memory, no reverse proxy, same over lan and internet


Edited by daedalus, 11 June 2019 - 03:10 PM.


#19 nathanghetto OFFLINE  

nathanghetto

    Newbie

  • Members
  • 2 posts
  • Local time: 07:33 AM

Posted 26 July 2019 - 06:39 PM

Same issue for me on Android 9!



#20 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 134339 posts
  • Local time: 07:33 AM

Posted 03 August 2019 - 01:55 PM

We are working on this. Apologies for the delay.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users