Jump to content

Emby not always updating in Kodi


Go to solution Solved by Angelblue05,

Recommended Posts

@@heula

 

Restart Emby for Kodi, you should see a new pafch applied. Bring your libraries up to date once more. This time, if should keep up. The issue was related to newly added shows (or maybe the show was empty previously?). Anyway, I ensure to add the episodes if the show is added via live updates/fast sync. That should correct what you are seeing.

Thanks, I will post an update when I know if this works or not.

Link to post
Share on other sites

It does update now but some of the new added episodes are double. In the widget but also in the serie itself. Only one file on my NAS.

This on my PC and Shield TV.

 

post-310-0-26137900-1559593474_thumb.jpg

 

post-310-0-90293600-1559593481_thumb.jpg

 

PC log kodi PC.log

 

Shield TV log kodi Shield TV.log

 

 

  • Like 1
Link to post
Share on other sites
Angelblue05

@@heula

 

To understand what happened, I'll need the ids associated with the episodes that are duplicated. Could you please try to play each episode and provide a new kodi log? Thank you. 

Edited by Angelblue05
Link to post
Share on other sites

@@heula

 

To understand what happened, I'll need the ids associated with the episodes that are duplicated. Could you please try to play each episode and provide a new kodi log? Thank you. 

Played both Fear the walking dead 5x1 episodes, this is the log.

 

kodi PC 4-6-2019.log

Edited by heula
  • Like 1
Link to post
Share on other sites
Angelblue05

@@heula

 

Thanks for the log, I am working on a fix. Please do still update to the latest beta.

The issue is that the episode adds the show which then adds the episode (which initiated this). Have to prevent that.

Edited by Angelblue05
  • Like 1
Link to post
Share on other sites
  • Solution
Angelblue05

@@heula

 

Restart Kodi, you'll see a new patch applied. Repair the libraries to remove the duplicates. Let me know if the issue is resolved. I believe the issue was that the episode adds the show which then tries to add the episode (which initiated this). That caused the duplicate (the integrity errors)

  • Like 1
Link to post
Share on other sites

@@heula

 

Restart Kodi, you'll see a new patch applied. Repair the libraries to remove the duplicates. Let me know if the issue is resolved. I believe the issue was that the episode adds the show which then tries to add the episode (which initiated this). That caused the duplicate (the integrity errors)

After aplying the patch and updating the libraries the issue still remains. Not with all episodes but with some,

 

For example, today the episode Beste Kijkers NL 6x4 is double.

All older double episodes also still exist.

 

post-310-0-36997100-1559900867_thumb.png

 

kodi PC.log

kodi PC.old.log

Edited by heula
Link to post
Share on other sites
horstepipe

After aplying the patch and updating the libraries the issue still remains. Not with all episodes but with some,

 

Hey

just to be sure:

Did you really repair the library or did you press refresh?

 

Best regards

  • Like 1
Link to post
Share on other sites
horstepipe
All older double episodes also still exist.

 

I'm asking because you're really not supposed to see that after a library repair from my experience.

  • Like 1
Link to post
Share on other sites

I'm asking because you're really not supposed to see that after a library repair from my experience.

No you are right. I updated instead or repairing. Doning that right now.

  • Like 1
Link to post
Share on other sites

@@heula

 

Still having this issue with newly added content?

Sorry for the late reaction. After the last updates and repair of the libraries it seems to go well now.

Thanks.

  • Like 1
Link to post
Share on other sites
Angelblue05

Sorry for the late reaction. After the last updates and repair of the libraries it seems to go well now.

Thanks.

That is great to hear! Thank you for reporting back.

Link to post
Share on other sites
  • 3 weeks later...

Again I'm having issues but this time only on my Shield TV.

 

New episodes are going well but deleted items are not removed from the library. They are deleted because on the PC the deleted episodes are all gone.

On Shield TV the episodes are still visible but when I select one a message appears that the episode is no longer available in the library and asks me if I want to remove it from the library.

 

Emby for Kodi is up to date on Shield TV and PC.

Running Emby server version 4.2.0.12

 

kodi Shield TV.log

 

kodi Shield TV.old.log

 

kodi PC.log

  • Like 1
Link to post
Share on other sites
Angelblue05

Thanks for reporting @@heula

 

If I don't manage to find the fix right away, I will still release a new stable version because some api changes can't wait any longer, but I will keep you posted. It does seem like there was an issue on your shield regarding connection and then that resulted in an unusual error in the add-on. I will take a deeper look.

  • Like 1
Link to post
Share on other sites

Again I'm having issues but this time only on my Shield TV.

 

New episodes are going well but deleted items are not removed from the library. They are deleted because on the PC the deleted episodes are all gone.

On Shield TV the episodes are still visible but when I select one a message appears that the episode is no longer available in the library and asks me if I want to remove it from the library.

 

Emby for Kodi is up to date on Shield TV and PC.

Running Emby server version 4.2.0.12

 

attachicon.gifkodi Shield TV.log

 

attachicon.gifkodi Shield TV.old.log

 

attachicon.gifkodi PC.log

Having same problem on my shield also

 

Sent from my LYA-L09 using Tapatalk

Link to post
Share on other sites
Angelblue05

Is this a recent issue? What server version are you on? I haven't been able to replicate this yet. Are we sure it's not bad entries from the past when I was trying to fix this issue?

Link to post
Share on other sites
mobamobamoba

Is this a recent issue? What server version are you on? I haven't been able to replicate this yet. Are we sure it's not bad entries from the past when I was trying to fix this issue?

I have this same issue and it showed up recently (using Kodi on Win10). I delete a show and it properly deletes in Emby and on the PC but still shows up in Kodi and won't disappear unless you go in and force a manual library repair.

Edited by mobamobamoba
  • Like 1
Link to post
Share on other sites

I have seen two Emby Server updates and I thought one addon update but still the deleted items remain in the library.

Yesterday deleted several episodes of L.A's Finest, they are deleted but still visible on my Shield TV. When I take a look on my pc they are gone. When I delete an episode on my pc it disappears almost instantly.

 

I do see now a progress bar on top of the screen in Kodi. New items are still no issue. 

 

 

kodi.log

 

Thanks.

 

  • Like 1
Link to post
Share on other sites
Glyde62

Had shows that we watched and Emby deleted them, But this afternoon they were showing again

Doing a library repair fixed it though

 

Sent from my LYA-L09 using Tapatalk

  • Like 1
Link to post
Share on other sites
Glyde62

No fix for this problem

Watched shows still showing after Emby deleted them

Disappear but later show in library again

 

Sent from my LYA-L09 using Tapatalk

Link to post
Share on other sites
Angelblue05

I am working on fixing this situation, thanks again for your patience. I'll let you know if I need anything more.

  • Like 2
Link to post
Share on other sites
Glyde62

Are you guys using the beta server by any chance?

Let me check....... 4.1.1.0-1 doesn't say beta anywhere

 

That's on my Synology btw

 

Sent from my LYA-L09 using Tapatalk

  • Like 1
Link to post
Share on other sites
Angelblue05

Ok then you likely don’t have the same issue as heula. Did you provide your Kodi log? How can I replicate the behavior for myself? What’s your file structure? Thanks.

Edited by Angelblue05
Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...