Jump to content


Photo
In-Progress

Emby not always updating in Kodi



Best Answer Angelblue05 , 06 June 2019 - 04:47 AM

@heula

 

Restart Kodi, you'll see a new patch applied. Repair the libraries to remove the duplicates. Let me know if the issue is resolved. I believe the issue was that the episode adds the show which then tries to add the episode (which initiated this). That caused the duplicate (the integrity errors)

Go to the full post


  • Please log in to reply
150 replies to this topic

#1 heula OFFLINE  

heula

    Advanced Member

  • Members
  • 858 posts
  • Local time: 11:23 PM
  • LocationSpijkenisse, The Netherlands

Posted 07 May 2019 - 03:39 AM

Lately I noticed that Emby does not always update new added media in Kodi.

To get all new media I have to manually do an update of the libraries I miss things.

 

That process takes some time if it needs to update multiple libraries.

 

Running Kodi 18.2

Emby Addon 4.0.20a

 

Last two Kodi logs.

 

Attached File  kodi.log   1.72MB   3 downloads

Attached File  kodi.old.log   1.67MB   1 downloads

 

Thanks.

 

 



#2 alturismo OFFLINE  

alturismo

    Advanced Member

  • Members
  • 142 posts
  • Local time: 11:23 PM

Posted 07 May 2019 - 07:39 AM

same here ...

 

pretty often lately that syncs not working properly.

 

also a behavior wich is strange, when all episodes are watched from a series the main series folder stays active sometimes ...

or new episodes are not shown in the series folder ... or even better, like GOT, all epsisodes from S08 are gone in Kodi ...

emby app all is good, just the kodi connection is pretty worse lately. it was very stable, but here at least i have some issues ...

 

also i guess its something with the emby companion addon, sometimes i have double entries left in kodi (same episode twice) ...

wich also just get removed by redo database.

 

background why i guess this happens here, i record as .ts file, i then cut my episodes and remux them with avidemux as mkv ...

then i let a script run wich automoves to a proper season subfolder as emby still does it wrong for me (sampl, season 08 instead season 8, 2 digit numbering ...),

deletes the "old ts file, the old idx2 (avidemux) file, eletes the empty 1 digit season folder), then a api call to autorefresh emby ...

 

works flawlessly, emby updates straight ahead to new file and all is good, most cases ... also in kodi then ...

 

but sometimes i have either double entries in kodi for a episode, or the episode is not there at all (even all episodes from the current season ...) but the show folder is showing up as unseen ...

 

i get it sorted by database reset and redo ... but with 3 shield clients it aint the big fun ;)

 

question is now, as i see also many updates like "emby patch added ..." ... theres currently worked on.

 

and, what could be helpful as logs ?



#3 heula OFFLINE  

heula

    Advanced Member

  • Members
  • 858 posts
  • Local time: 11:23 PM
  • LocationSpijkenisse, The Netherlands

Posted 07 May 2019 - 10:13 AM

Also when using the same account on multiple computers or shield tv watched items are often not the same and bookmarks set on one pc are not there on the other.
Should be same when using the same Emby account or login in Kodi, right?

#4 Angelblue05 OFFLINE  

Angelblue05

    Advanced Member

  • Developers
  • 13513 posts
  • Local time: 04:23 PM

Posted 07 May 2019 - 01:44 PM

No one is asking you to reset. I appreciate you guys helping testing beta, but if you read the changelog, you’d see a reset is useless as it is unrelated to the latest changes I made. I am currently looking into this right now. Thanks for reporting this.

#5 Angelblue05 OFFLINE  

Angelblue05

    Advanced Member

  • Developers
  • 13513 posts
  • Local time: 04:23 PM

Posted 07 May 2019 - 03:48 PM

@heula

 

Thanks for providing your log. Please note, I really, really don't need Kodi debug on 99% of the time, it just makes your log harder to read.

 

If you don't receive updates then things won't match across devices. Was Kodi running at the time or is it not updating when you start up Kodi?



#6 heula OFFLINE  

heula

    Advanced Member

  • Members
  • 858 posts
  • Local time: 11:23 PM
  • LocationSpijkenisse, The Netherlands

Posted 07 May 2019 - 03:59 PM

@heula

 

Thanks for providing your log. Please note, I really, really don't need Kodi debug on 99% of the time, it just makes your log harder to read.

 

If you don't receive updates then things won't match across devices. Was Kodi running at the time or is it not updating when you start up Kodi?

I always start a fresh instance of Kodi at startup.

 

I have set my log level like this an the Kodi advancedsettings.xml.

<loglevel>1</loglevel>

 

Should that be different?


  • Angelblue05 likes this

#7 Angelblue05 OFFLINE  

Angelblue05

    Advanced Member

  • Developers
  • 13513 posts
  • Local time: 04:23 PM

Posted 07 May 2019 - 04:00 PM

Can you set it to 0?

#8 heula OFFLINE  

heula

    Advanced Member

  • Members
  • 858 posts
  • Local time: 11:23 PM
  • LocationSpijkenisse, The Netherlands

Posted 07 May 2019 - 04:02 PM

Can you set it to 0?

Done. Do you need a new log now?


  • Angelblue05 likes this

#9 Angelblue05 OFFLINE  

Angelblue05

    Advanced Member

  • Developers
  • 13513 posts
  • Local time: 04:23 PM

Posted 07 May 2019 - 04:13 PM

You'll have to repeat the test. But it depends on the following

 

What I wanted to know is do you receive live updates? As in, Kodi is running, then your content is added to your server. Nothing is added to Kodi?

 

If so, while Kodi is running, are you able to repeat adding content and providing a new log?

 

If it's when Kodi is not running, and you start it and the update is missing. Then can you shut down Kodi, add content. Wait until the content is added to your server and start Kodi. Provide that log.

 

Thank you



#10 Angelblue05 OFFLINE  

Angelblue05

    Advanced Member

  • Developers
  • 13513 posts
  • Local time: 04:23 PM

Posted 07 May 2019 - 05:33 PM

same here ...

 

pretty often lately that syncs not working properly.

 

also a behavior wich is strange, when all episodes are watched from a series the main series folder stays active sometimes ...

or new episodes are not shown in the series folder ... or even better, like GOT, all epsisodes from S08 are gone in Kodi ...

emby app all is good, just the kodi connection is pretty worse lately. it was very stable, but here at least i have some issues ...

 

also i guess its something with the emby companion addon, sometimes i have double entries left in kodi (same episode twice) ...

wich also just get removed by redo database.

 

background why i guess this happens here, i record as .ts file, i then cut my episodes and remux them with avidemux as mkv ...

then i let a script run wich automoves to a proper season subfolder as emby still does it wrong for me (sampl, season 08 instead season 8, 2 digit numbering ...),

deletes the "old ts file, the old idx2 (avidemux) file, eletes the empty 1 digit season folder), then a api call to autorefresh emby ...

 

works flawlessly, emby updates straight ahead to new file and all is good, most cases ... also in kodi then ...

 

but sometimes i have either double entries in kodi for a episode, or the episode is not there at all (even all episodes from the current season ...) but the show folder is showing up as unseen ...

 

i get it sorted by database reset and redo ... but with 3 shield clients it aint the big fun ;)

 

question is now, as i see also many updates like "emby patch added ..." ... theres currently worked on.

 

and, what could be helpful as logs ?

I don't know what version of Emby for Kodi you are running.

 

Patch is normal if you are on beta, since I'm constantly updating code to get everything working atm.

 

You should not need to do any database reset. You can simply update select libraries, you know that right? Or even repair them if it's really messed up.

 

Provide your Kodi log, see my previous post. because I have no issues on my side. I have both Krypton and Leia running and both receive their updates no problem.



#11 alturismo OFFLINE  

alturismo

    Advanced Member

  • Members
  • 142 posts
  • Local time: 11:23 PM

Posted 08 May 2019 - 01:29 AM

emby server currently 4.2.0.4 beta

Kodi Companion 2.0.9.0

 

Clients on different OS´s, all Kodi Versions are running Leia 18.2

i use 3 shield tv´s (2017), all same OS firmware, all using the 4.0.20a Emby addon.

 

i ll try to narrow it down ... and provide then some logs ...

 

as sample what happens and why a database refresh aint helping (here actually) and why i think "doubles" it has todo with "old" entries ... and then why kodi companion ...

 

pictures attached

 

real_current = after database reset, all is good, only series with unwatched content shown, only unwatched episodes are shown, all are there when i check "all"

 

before_update = series are shown where no unwatched content is inside ... and when checking "all" there are episodes "missing", this case GOT S08 Ep 1 - 4 ... wich are all watched

 

after_update... = manual database refresh from addon settings, now i get the missing episodes added, BUT, with all kinda double entries ... sample here s.w.a.t, 3 x the episode 2x20 (while theres only 1 file), and also GOT S08E04 as wrong entry,

its the .ts file now wich doesnt exist anymore, the .mkv is also there but watched, the .ts is unwatched ... and never can be watched cause it doesnt exist anymore (see detail2)

 

so, im back with my general oppinion from emby that "dead" entries are left somewhere ... i know this behavior from movie collections with different versions and replaced versions .... 

 

to bring it in words with my workflow

 

i create a .ts file (record) in a subfolder season 2 for sample. (1 entry in emby database)

i remux after cutting this file to .mkv (2 entries in emby database)

i move the .mkv to a (personal) proper subfolder season 08 (2 digit) ( now even 3 entries in emby)

i remove the .ts and the empty season 8 (1 digit) folder

i refresh the emby library so the file gets updated ...

this i do with ALL my records, the above described "error" happens from time to time ... thats probably something i have to watch ...

before this happened like once in 6 weeks, actually every few days ...

 

in emby web view, in emby app(s), all is immediately updated and correct and working like before, no change

 

my personal oppinion, somewhere in this chain the old entries gets stuck and this is the reason why my database gets messed ...

Attached Files



#12 heula OFFLINE  

heula

    Advanced Member

  • Members
  • 858 posts
  • Local time: 11:23 PM
  • LocationSpijkenisse, The Netherlands

Posted 08 May 2019 - 04:06 AM

You'll have to repeat the test. But it depends on the following

 

What I wanted to know is do you receive live updates? As in, Kodi is running, then your content is added to your server. Nothing is added to Kodi?

 

If so, while Kodi is running, are you able to repeat adding content and providing a new log?

 

If it's when Kodi is not running, and you start it and the update is missing. Then can you shut down Kodi, add content. Wait until the content is added to your server and start Kodi. Provide that log.

 

Thank you

Sometimes I see live updates yes.

The biggest issues I'm seeing is when I open Kodi. I get the welcome message but than there is mostly no message bar where it says updating new items or something like that. Before I was seeing that always and were new items there after a while. Longer before that process was faster though.

 

Today I saw items were added live after I restarted the Emby server. (took me almost 45 minutes on my DS418 NAS)

When it was finally up and running again I saw new items coming but one was missing in the Kodi - Emby recent added episodes widget. It was there in the serie itself in Kodi but not in the widget. In Emby it was there in the recent added episodes list.

 

Attached File  Capture_648.jpg   115.18KB   6 downloads

Attached File  Capture_649.jpg   40.83KB   6 downloads

 

Kodi Log before restarting the Emby Server

 

Attached File  kodi.log   62.38KB   3 downloads

 

Kodi Log after restarting the Emby Server

 

Attached File  kodi2.log   318.09KB   2 downloads

 

I have started a topic some time ago about the restarting time of the Emby Server here.


Edited by heula, 08 May 2019 - 04:08 AM.


#13 alturismo OFFLINE  

alturismo

    Advanced Member

  • Members
  • 142 posts
  • Local time: 11:23 PM

Posted 08 May 2019 - 05:08 AM

may a side question from me, kodi companion, does it create a own database with its entries ?

 

if so, may a hint where to find it ?

 

as i checked the emby library database and for example all entries there looking good (no doubles), i d like to check if there is another database (companion ...) and if there are double entries nested ... just trying to narrow it down.



#14 heula OFFLINE  

heula

    Advanced Member

  • Members
  • 858 posts
  • Local time: 11:23 PM
  • LocationSpijkenisse, The Netherlands

Posted 09 May 2019 - 08:46 AM

Two new logs. Lucifer was added to Emb yesterday but no matter how often I restart Kodi, it wil not add new episodes.

Attached File  kodi.log   612.21KB   4 downloads
Attached File  kodi.old.log   5.56MB   4 downloads

Edited by heula, 09 May 2019 - 03:28 PM.


#15 popy OFFLINE  

popy

    Advanced Member

  • Members
  • 196 posts
  • Local time: 11:23 PM

Posted 09 May 2019 - 03:10 PM

I have Emby Server Version 4.0.0.2 with an android tv running kodi 18.2 and Companion 4.0.5 addon.
Also in my case changes would not be picked up correctly after some time in standby.
A manual "look for changes" in the addon settings does not help.
Emby states -> no changes to syn.
I have to restart kodi (exit and reopen) so that the changes will be picked up.

The TV is cutting the network connection after 10 mins after power off and goes in some sort of standby.
When i'll power it on again kodi app is opened and the my PVR addon reconnects immidiattly (progress is shown at the top).
I dont see a "Connected" message from emby addon after standby, like it will be shown after kodi restart.

@Angelblue05:
Does the addon have some sort of keep alive to check if tcp connection is dead?
Should there be a popup from emby addon after standby?

thx
pOpY

#16 Angelblue05 OFFLINE  

Angelblue05

    Advanced Member

  • Developers
  • 13513 posts
  • Local time: 04:23 PM

Posted 09 May 2019 - 03:24 PM

Yes there is. However I’d have to see your log to make sure that it triggers correctly.

But that is not what Heula experiences...
  • popy likes this

#17 popy OFFLINE  

popy

    Advanced Member

  • Members
  • 196 posts
  • Local time: 11:23 PM

Posted 10 May 2019 - 03:37 AM

Yes there is. However I’d have to see your log to make sure that it triggers correctly.

But that is not what Heula experiences...

 

Ok, thanks.

Will try to provide a log.

 

What must i enable in kodi to get an "good" not spammed log on android TV?

 

Enable debug logging in Kodi?

Enable debug logging in Emby addon?

 

Thank you

pOpY



#18 Angelblue05 OFFLINE  

Angelblue05

    Advanced Member

  • Developers
  • 13513 posts
  • Local time: 04:23 PM

Posted 10 May 2019 - 03:38 AM

Only addon logging set to info, no Kodi debug should be good. Thanks.
  • popy likes this

#19 popy OFFLINE  

popy

    Advanced Member

  • Members
  • 196 posts
  • Local time: 11:23 PM

Posted 10 May 2019 - 03:41 AM

Only addon logging set to info, no Kodi debug should be good. Thanks.

 

ok thx, will try to get an log in the evening.

 

pOpY



#20 Seger OFFLINE  

Seger

    Advanced Member

  • Members
  • 96 posts
  • Local time: 10:23 PM

Posted 10 May 2019 - 05:19 AM

Hello @Angelblue05 ,
 
Also wanted to let me know that I currently perceive the automatic update in Kodi as slightly "flawed". So if I restart Kodi or Emby for Kodi, Kodi will be properly updated, if Kodi is already running and I do not restart the addon manually, the server will not accept the change. Please take a look at my log to:
 
2019-05-10 11: 03: 59.569 T: 1608
 
 
From that point on, I removed an Emby favorite on the server and waited two minutes for Emby for Kodi to implement it in Kodi. This has not worked despite refreshing the skins and jumping in menus and pause, no change. Then I restarted the addon Kodi for Emby via Kodi and it will be taken over immediately afterwards.
 
THANK YOU FOR ALL YOUR GREAT WORK !!!!!!!!!
 
Thanks and best regards,
Seger

Edited by Seger, 10 May 2019 - 05:21 AM.






Also tagged with one or more of these keywords: In-Progress

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users