Jump to content

Emby not always updating in Kodi


heula
 Share

Go to solution Solved by Angelblue05,

Recommended Posts

heula

Lately I noticed that Emby does not always update new added media in Kodi.

To get all new media I have to manually do an update of the libraries I miss things.

 

That process takes some time if it needs to update multiple libraries.

 

Running Kodi 18.2

Emby Addon 4.0.20a

 

Last two Kodi logs.

 

kodi.log

kodi.old.log

 

Thanks.

 

 

Link to comment
Share on other sites

alturismo

same here ...

 

pretty often lately that syncs not working properly.

 

also a behavior wich is strange, when all episodes are watched from a series the main series folder stays active sometimes ...

or new episodes are not shown in the series folder ... or even better, like GOT, all epsisodes from S08 are gone in Kodi ...

emby app all is good, just the kodi connection is pretty worse lately. it was very stable, but here at least i have some issues ...

 

also i guess its something with the emby companion addon, sometimes i have double entries left in kodi (same episode twice) ...

wich also just get removed by redo database.

 

background why i guess this happens here, i record as .ts file, i then cut my episodes and remux them with avidemux as mkv ...

then i let a script run wich automoves to a proper season subfolder as emby still does it wrong for me (sampl, season 08 instead season 8, 2 digit numbering ...),

deletes the "old ts file, the old idx2 (avidemux) file, eletes the empty 1 digit season folder), then a api call to autorefresh emby ...

 

works flawlessly, emby updates straight ahead to new file and all is good, most cases ... also in kodi then ...

 

but sometimes i have either double entries in kodi for a episode, or the episode is not there at all (even all episodes from the current season ...) but the show folder is showing up as unseen ...

 

i get it sorted by database reset and redo ... but with 3 shield clients it aint the big fun ;)

 

question is now, as i see also many updates like "emby patch added ..." ... theres currently worked on.

 

and, what could be helpful as logs ?

Link to comment
Share on other sites

heula

Also when using the same account on multiple computers or shield tv watched items are often not the same and bookmarks set on one pc are not there on the other.

Should be same when using the same Emby account or login in Kodi, right?

Link to comment
Share on other sites

Angelblue05

No one is asking you to reset. I appreciate you guys helping testing beta, but if you read the changelog, you’d see a reset is useless as it is unrelated to the latest changes I made. I am currently looking into this right now. Thanks for reporting this.

Link to comment
Share on other sites

Angelblue05

@@heula

 

Thanks for providing your log. Please note, I really, really don't need Kodi debug on 99% of the time, it just makes your log harder to read.

 

If you don't receive updates then things won't match across devices. Was Kodi running at the time or is it not updating when you start up Kodi?

Link to comment
Share on other sites

heula

@@heula

 

Thanks for providing your log. Please note, I really, really don't need Kodi debug on 99% of the time, it just makes your log harder to read.

 

If you don't receive updates then things won't match across devices. Was Kodi running at the time or is it not updating when you start up Kodi?

I always start a fresh instance of Kodi at startup.

 

I have set my log level like this an the Kodi advancedsettings.xml.

<loglevel>1</loglevel>

 

Should that be different?

  • Like 1
Link to comment
Share on other sites

heula

Can you set it to 0?

Done. Do you need a new log now?

  • Like 1
Link to comment
Share on other sites

Angelblue05

You'll have to repeat the test. But it depends on the following

 

What I wanted to know is do you receive live updates? As in, Kodi is running, then your content is added to your server. Nothing is added to Kodi?

 

If so, while Kodi is running, are you able to repeat adding content and providing a new log?

 

If it's when Kodi is not running, and you start it and the update is missing. Then can you shut down Kodi, add content. Wait until the content is added to your server and start Kodi. Provide that log.

 

Thank you

Link to comment
Share on other sites

Angelblue05

same here ...

 

pretty often lately that syncs not working properly.

 

also a behavior wich is strange, when all episodes are watched from a series the main series folder stays active sometimes ...

or new episodes are not shown in the series folder ... or even better, like GOT, all epsisodes from S08 are gone in Kodi ...

emby app all is good, just the kodi connection is pretty worse lately. it was very stable, but here at least i have some issues ...

 

also i guess its something with the emby companion addon, sometimes i have double entries left in kodi (same episode twice) ...

wich also just get removed by redo database.

 

background why i guess this happens here, i record as .ts file, i then cut my episodes and remux them with avidemux as mkv ...

then i let a script run wich automoves to a proper season subfolder as emby still does it wrong for me (sampl, season 08 instead season 8, 2 digit numbering ...),

deletes the "old ts file, the old idx2 (avidemux) file, eletes the empty 1 digit season folder), then a api call to autorefresh emby ...

 

works flawlessly, emby updates straight ahead to new file and all is good, most cases ... also in kodi then ...

 

but sometimes i have either double entries in kodi for a episode, or the episode is not there at all (even all episodes from the current season ...) but the show folder is showing up as unseen ...

 

i get it sorted by database reset and redo ... but with 3 shield clients it aint the big fun ;)

 

question is now, as i see also many updates like "emby patch added ..." ... theres currently worked on.

 

and, what could be helpful as logs ?

I don't know what version of Emby for Kodi you are running.

 

Patch is normal if you are on beta, since I'm constantly updating code to get everything working atm.

 

You should not need to do any database reset. You can simply update select libraries, you know that right? Or even repair them if it's really messed up.

 

Provide your Kodi log, see my previous post. because I have no issues on my side. I have both Krypton and Leia running and both receive their updates no problem.

Link to comment
Share on other sites

alturismo

emby server currently 4.2.0.4 beta

Kodi Companion 2.0.9.0

 

Clients on different OS´s, all Kodi Versions are running Leia 18.2

i use 3 shield tv´s (2017), all same OS firmware, all using the 4.0.20a Emby addon.

 

i ll try to narrow it down ... and provide then some logs ...

 

as sample what happens and why a database refresh aint helping (here actually) and why i think "doubles" it has todo with "old" entries ... and then why kodi companion ...

 

pictures attached

 

real_current = after database reset, all is good, only series with unwatched content shown, only unwatched episodes are shown, all are there when i check "all"

 

before_update = series are shown where no unwatched content is inside ... and when checking "all" there are episodes "missing", this case GOT S08 Ep 1 - 4 ... wich are all watched

 

after_update... = manual database refresh from addon settings, now i get the missing episodes added, BUT, with all kinda double entries ... sample here s.w.a.t, 3 x the episode 2x20 (while theres only 1 file), and also GOT S08E04 as wrong entry,

its the .ts file now wich doesnt exist anymore, the .mkv is also there but watched, the .ts is unwatched ... and never can be watched cause it doesnt exist anymore (see detail2)

 

so, im back with my general oppinion from emby that "dead" entries are left somewhere ... i know this behavior from movie collections with different versions and replaced versions .... 

 

to bring it in words with my workflow

 

i create a .ts file (record) in a subfolder season 2 for sample. (1 entry in emby database)

i remux after cutting this file to .mkv (2 entries in emby database)

i move the .mkv to a (personal) proper subfolder season 08 (2 digit) ( now even 3 entries in emby)

i remove the .ts and the empty season 8 (1 digit) folder

i refresh the emby library so the file gets updated ...

this i do with ALL my records, the above described "error" happens from time to time ... thats probably something i have to watch ...

before this happened like once in 6 weeks, actually every few days ...

 

in emby web view, in emby app(s), all is immediately updated and correct and working like before, no change

 

my personal oppinion, somewhere in this chain the old entries gets stuck and this is the reason why my database gets messed ...

post-112497-0-10318900-1557293057_thumb.png

post-112497-0-71222800-1557293138_thumb.png

post-112497-0-97486300-1557293214_thumb.png

post-112497-0-67958000-1557293237_thumb.png

post-112497-0-13754000-1557293250_thumb.png

post-112497-0-49786800-1557293281_thumb.png

post-112497-0-73696600-1557293301_thumb.png

post-112497-0-71998600-1557293349_thumb.png

Link to comment
Share on other sites

heula

You'll have to repeat the test. But it depends on the following

 

What I wanted to know is do you receive live updates? As in, Kodi is running, then your content is added to your server. Nothing is added to Kodi?

 

If so, while Kodi is running, are you able to repeat adding content and providing a new log?

 

If it's when Kodi is not running, and you start it and the update is missing. Then can you shut down Kodi, add content. Wait until the content is added to your server and start Kodi. Provide that log.

 

Thank you

Sometimes I see live updates yes.

The biggest issues I'm seeing is when I open Kodi. I get the welcome message but than there is mostly no message bar where it says updating new items or something like that. Before I was seeing that always and were new items there after a while. Longer before that process was faster though.

 

Today I saw items were added live after I restarted the Emby server. (took me almost 45 minutes on my DS418 NAS)

When it was finally up and running again I saw new items coming but one was missing in the Kodi - Emby recent added episodes widget. It was there in the serie itself in Kodi but not in the widget. In Emby it was there in the recent added episodes list.

 

post-310-0-10607800-1557302500_thumb.jpg

post-310-0-94514100-1557302506_thumb.jpg

 

Kodi Log before restarting the Emby Server

 

kodi.log

 

Kodi Log after restarting the Emby Server

 

kodi2.log

 

I have started a topic some time ago about the restarting time of the Emby Server here.

Edited by heula
Link to comment
Share on other sites

alturismo

may a side question from me, kodi companion, does it create a own database with its entries ?

 

if so, may a hint where to find it ?

 

as i checked the emby library database and for example all entries there looking good (no doubles), i d like to check if there is another database (companion ...) and if there are double entries nested ... just trying to narrow it down.

Link to comment
Share on other sites

heula

Two new logs. Lucifer was added to Emb yesterday but no matter how often I restart Kodi, it wil not add new episodes.

 

kodi.log

kodi.old.log

Edited by heula
Link to comment
Share on other sites

popy

I have Emby Server Version 4.0.0.2 with an android tv running kodi 18.2 and Companion 4.0.5 addon.

Also in my case changes would not be picked up correctly after some time in standby.

A manual "look for changes" in the addon settings does not help.

Emby states -> no changes to syn.

I have to restart kodi (exit and reopen) so that the changes will be picked up.

 

The TV is cutting the network connection after 10 mins after power off and goes in some sort of standby.

When i'll power it on again kodi app is opened and the my PVR addon reconnects immidiattly (progress is shown at the top).

I dont see a "Connected" message from emby addon after standby, like it will be shown after kodi restart.

 

@Angelblue05:

Does the addon have some sort of keep alive to check if tcp connection is dead?

Should there be a popup from emby addon after standby?

 

thx

pOpY

Link to comment
Share on other sites

Angelblue05

Yes there is. However I’d have to see your log to make sure that it triggers correctly.

 

But that is not what Heula experiences...

  • Like 1
Link to comment
Share on other sites

popy

Yes there is. However I’d have to see your log to make sure that it triggers correctly.

 

But that is not what Heula experiences...

 

Ok, thanks.

Will try to provide a log.

 

What must i enable in kodi to get an "good" not spammed log on android TV?

 

Enable debug logging in Kodi?

Enable debug logging in Emby addon?

 

Thank you

pOpY

Link to comment
Share on other sites

popy

Only addon logging set to info, no Kodi debug should be good. Thanks.

 

ok thx, will try to get an log in the evening.

 

pOpY

Link to comment
Share on other sites

Seger
Hello @@Angelblue05 ,

 

Also wanted to let me know that I currently perceive the automatic update in Kodi as slightly "flawed". So if I restart Kodi or Emby for Kodi, Kodi will be properly updated, if Kodi is already running and I do not restart the addon manually, the server will not accept the change. Please take a look at my log to:

 

2019-05-10 11: 03: 59.569 T: 1608

 


 

From that point on, I removed an Emby favorite on the server and waited two minutes for Emby for Kodi to implement it in Kodi. This has not worked despite refreshing the skins and jumping in menus and pause, no change. Then I restarted the addon Kodi for Emby via Kodi and it will be taken over immediately afterwards.

 

THANK YOU FOR ALL YOUR GREAT WORK !!!!!!!!!

 

Thanks and best regards,

Seger

Edited by Seger
Link to comment
Share on other sites

Sorry to say angelblue but for me today same problem with last version a record witch was recorded 2h ago didn't show up in database. I must trigger refresh of the database to make it appear.

 

Gesendet von meinem MHA-L29 mit Tapatalk

Link to comment
Share on other sites

Angelblue05

@@Seger

 

You have something playing content as Kodi starts? PVR. What if you don't have that happen, does it update without restarting?

Link to comment
Share on other sites

Angelblue05

may a side question from me, kodi companion, does it create a own database with its entries ?

 

if so, may a hint where to find it ?

 

as i checked the emby library database and for example all entries there looking good (no doubles), i d like to check if there is another database (companion ...) and if there are double entries nested ... just trying to narrow it down.

 

In the server folder > data > syncdata > The json files.

Edited by Angelblue05
Link to comment
Share on other sites

popy

@Angelblue05: Here are my logs and a quick description what i have done.
PS.: i can reproduce the issue on my android tv.


kodi_1_after_standby_nothing changed_on_emby_side.log

  • tv was in standby for about an day (not pingable)
  • Switch it on @19:47 -> Dashboard of emby showed it as last seen a few seconds ago
  • Nothing changed on emby server
  • Nothing was updated in kodi -> OK

 

kodi_2_after_standby_matrix_deleted_from_emby server_not picked up by kodi.log

  • Swiched tv off and waited until ping disappears
  • Deleted Matrix movie on emby server
  • checked in emby Dashboard -> Matrix is gone
  • Switch it on @20:09 -> Dashboard of emby showed it as last seen a few seconds ago
  • waited 5 minutes
  • Nothing was updated in kodi -> NOT OK
  •  

kodi_3_after_kodi_restart_matrix_change_picked_up_from_emby server.log

  • Restarted kodi -> changes was picked up and matrix was gone in kodi

Hope you can see the issue in the logs.

Anthe question: Should a popup been seen after resuming?

 

thx

pOpY

kodi_1_after_standby_nothing changed_on_emby_side.log

kodi_2_after_standby_matrix_deleted_from_emby server_not picked up by kodi.log

kodi_3_after_kodi_restart_matrix_change_picked_up_from_emby server.log

Edited by popy
Link to comment
Share on other sites

Seger

@@Seger

 

You have something playing content as Kodi starts? PVR. What if you don't have that happen, does it update without restarting?

I have exhibited PVR, started Kodi clean, waited a bit and then removed the movie "Oh Boy" from the favorites at 20:22. As before, he does not remove this movie in Kodi. I did not watch a movie during that time. Only at 22:24 the movie will be removed after which I let manually restart the addon:
2019-05-10 20: 24: 27.182 T: 13016 NOTICE: EMBY.objects.core.movies -> USERDATA movie [73222/11766] 168474: Oh boy
  • Like 1
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...