Jump to content

Auto Organise retains old folder path for a series as a duplicate series


hanzworld
 Share

Go to solution Solved by Luke,

Recommended Posts

hanzworld
Hi team - think I'm having an issue with old cached/stored settings for Auto Organize which I can't seem to "purge".

 

Emby Server: MacOS version 4.1.1.0

Auto Organize: Version 1.3.9

 

Background:

TV library path was changed.

  • Was: /Volumes/Recorded TV/ (a mounted folder via MacOS Network)
  • Now: /Users/[username]/Library/Containers/nz.co.pixeleyes.AutoMounter/Data/Mounts/Cube/SMB/Recorded TV (a mounted folder via a third-party tool)

All other aspects of Emby have been working without issue - playback, deletion, subtitle download, etc.

 

Problem:

When I go to Auto Organize, I have a bunch of episodes (in this case Bull) waiting to be organised.

  • It picks up episodes in the watch folder just fine

post-3289-0-42008100-1556777276_thumb.png

  • It identifies the episode information and provides the expected prompt to set the Series. However, note the two options for Bull (2016)

post-3289-0-54600400-1556782065_thumb.png

  • If I choose the first one, it errors out

post-3289-0-90785800-1556777271_thumb.png

 

The log shows that it is trying to use the old path to move the folder, which isn't valid (I have redacted username for privacy):

 

post-3289-0-55387700-1556777814_thumb.png

  • If I choose the second one, it is successful, and it shows the correct path.
 

post-3289-0-97943200-1556783227_thumb.png

 

So there are two Bull (2016) series according to Auto Organize, each with a different path to its location in the library. The unattended Auto Organize obviously tries to use the first one and so fails with wrong path and "Permission denied" error as above. This means the Auto part of Auto Organize doesn't work  :(

 

I cannot see how or why there are two series defined, Emby doesn't seem to think there are two:

 

post-3289-0-65056800-1556782277_thumb.png

 

and the old library location isn't part of the library definition any more:

 

post-3289-0-80427300-1556782407_thumb.png

 

It's not just Bull - there are other duplicated series, but not all of the TV series I have. I could loosely say it seems to be series I've run through Auto Organize before, but I couldn't swear to that or prove it definitely.

 

Things I've tried with no success

  • Based on a semi-related issue here (namely: changed the paths to media libraries, and Auto Organize kept trying to use the old paths) - which had a fix in the latest version of Emby Server - I updated to 4.1.1.0. 
  • Restart
  • Plugin update
  • Library scan
  • Manually organise an episode with the "right" choice, and choose Remember this correction (to try and fix the one that the Auto organisation uses - no joy)

Help me Obi-Wan Kenobi, you're my only hope.

Edited by hanzworld
Link to comment
Share on other sites

  • Solution

Hi, it's because you have old entries hanging around in the database. Unfortunately we don't have a fix right now to clear these out. What i can say is that it shouldn't happen anymore going forward with new series.

  • Like 1
Link to comment
Share on other sites

hanzworld

Well, phooey. But thanks, at least I know I'm not going mad or missing something!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...