Jump to content

formerly running Kodi 17.6 (all these years)


CharleyVarrick
 Share

Go to solution Solved by Angelblue05,

Recommended Posts

CharleyVarrick

Hi Emby for Kodi fellow users,

in my living room setup, I am still on 17.6, and wish to update to the latest 18.2 version.

The Kodi site says we can install 18.2 "over" 17.6 (over as in no need to uninstall previous version)

 

My question is does the Kodi claim holds true not only for Kodi users, but also for Emby for Kodi users? After installing 18.2 over 17.6, should I expect Emby for Kodi to resume working by itself as if nothing happenned, or is this Emby for Kodi reinstall time?

 

 

I'm asking because the last time I tried this, on my home office setup, I managed to succeed but at the expanse of bandwidth and time (took much longer than anticipated + multiples scans required).

Edited by jlr19
Link to comment
Share on other sites

Angelblue05

Are you using the add-on stable 4.0.5 on Krypton? Jarvis is 16.

 

If so, you can install Kodi Leia over, but note if you are using add-on mode for playback, that you'll need to reset your local database or repair your individual video libraries (tv shows, movies, music videos--music hasn't changed so you can skip that) and let your content resync. If you are using native mode, then it should work without doing anything.

 

This is a one time change moving to Leia from Krypton, because there was a transition from plugin path to strm path being in database instead. It gives better result overall.

Edited by Angelblue05
  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...
CharleyVarrick

I thought I was using a beta version, as  per https://emby.media/community/index.php?/topic/68137-emby-server-update-broke-kodi/page-2&do=findComment&comment=684760

When I check my emby for kodi version, it says 4.0.5 by AngelBlue055

Neverthless, I took the plunge, earlier this morning.

 

My latest content seems 1 week month behind. On top right, I see the spining circle update gadget update, but it does not seem to progress, sticking at 9% Processing Updates: 96 for over 2 hours already

Edited by jlr19
Link to comment
Share on other sites

CharleyVarrick

I am in process of reinstalling Emby which encountered a failure, most likely causing Kodi for Emby's issue.

Edited by jlr19
  • Like 1
Link to comment
Share on other sites

CharleyVarrick

Emby reinstalled, content accessible in Kodi but again, only from a month ago or more. Put another way, all content aquired within the last month is ignored.

kodi.log

Edited by jlr19
  • Like 1
Link to comment
Share on other sites

Angelblue05

Did you do a local database reset? Just to be safe. Or at the very least, do a repair?

 

Edit: Please do a reset and reset your settings too. I will review this unusual scenario.

 

Let me know if it still doesn't allow you to move further by providing an updated Kodi log.

Edited by Angelblue05
Link to comment
Share on other sites

CharleyVarrick

By the way, Hi Angel, :)

a database reset is underway, It might very well take all night and then some (I have a significant collection), but I'll be sure to report back as soon as it completes.

Thanks already.

Edited by jlr19
  • Like 1
Link to comment
Share on other sites

CharleyVarrick

The database reset seemed has fixed the missing newer content issue.

Do you still recommend additional step of reset settings?

  • Like 1
Link to comment
Share on other sites

Angelblue05

Not if it works now. Keep an eye on it, if it happens again, let me know.

  • Like 1
Link to comment
Share on other sites

CharleyVarrick

I am sorry to report its happening again.

 

When starting Emby, I'm getting the Emby greeting on top right, but its not followed by the usual emby update progress bar% listing media names in that spot (usually a short update of recently added stuff). This is happening on 2 different pc running Emby for Kodi, called HTPC and WORKHORSE.

 

HTPC is behind by a up to 3 days (judging by Recently added episodes).

Having already done 5 or 6 local database reset in the last week, I uninstalled Emby for Kodi and reinstalled it.

 

Its now up to date, but I'll know for sure if its a proper fix when I add some more new content (tomorrow).

 

Workhorse is one full day behind in Recently added episodes. I'm thinking uninstalling/reinstalling Emby for Kodi on this pc too, but I preferred to let you know first, in case you want a log or something.

I also just noticed movie sets shows only 3 entries, while Emby Collections shows a lot (it used to give a count before v4.0), but I'm guessing 300 at least

Edited by jlr19
Link to comment
Share on other sites

CharleyVarrick

Supply the Kodi log so that @@Angelblue05 can take a look when she's back online.

We'll do

in the meantime, I'm getting a couple of Emby for Kodi prompts when restarting Emby for Kodi.

The first says: "Install the server plugin Kodi companion to automatically apply emby library updates at startup. This setting can be found in the add-on settings-sync options-Enable Kodi Companion" (with a OK button). Hitting OK brings up 2nd prompt:  "You can update your library manually rather than rely on the server plugin Kodi companion. Launch the add-on and update libraries (or per library). To remove content, you'll need to repair the library."

 

Please note I've enabled it 2-3 times already, but after restarting Kodi, it reverts to disabled

EDIT: Nice work bonehead, enabling an uninstalled plugin.

I'd like to thank the academy and my significant others in accepting the Total Newb of the Year Award.

 

Wit that said, its now installed on a restarted Emby server, but I have not noticed any changes.

 

 

 

EDIT: Kodi logfile: https://paste.kodi.tv/ehasuzofaz

Edited by jlr19
  • Like 1
Link to comment
Share on other sites

Angelblue05

@@jlr19

Ok so you figured out the Kodi companion is a server plugin.

Next thing to do, is test that it works correctly. Turn off Kodi. Open your Emby webclient > find an episode or a movie to edit (or any synced content) and edit it’s metadata. Wait a few moments, then start Kodi. Does that item receive an update when starting Emby for Kodi?

 

Edit: Checking your log, was that taken after you've installed the server plugin?

Edited by Angelblue05
  • Like 1
Link to comment
Share on other sites

CharleyVarrick

Next thing to do, is test that it works correctly. Turn off Kodi. Open your Emby webclient > find an episode or a movie to edit (or any synced content) and edit it’s metadata. Wait a few moments, then start Kodi. Does that item receive an update when starting Emby for Kodi?

 

Edit: Checking your log, was that taken after you've installed the server plugin?

I added a mockup actor and Kodi did acknowledge it as per your instructions. But It made it did disappear from Recently added episodes, I had to browse in show/season/ to get back to it.

 

I cant remember if log was before/after companion, sorry.

HTPC and Workhorse are both over a day behind in Recently added episodes

Edited by jlr19
Link to comment
Share on other sites

Angelblue05

You didn't have the Kodi companion installed, so that is normal because the Kodi companion records live events for the add-on. You need to bring your libraries up to date once in Emby for Kodi > manage libraries > update libraries. Then the Kodi companion will provide the list of updated content on Kodi startup from then on.

 

Make sure the kodi companion option in the add-on settings is enabled.

Edited by Angelblue05
Link to comment
Share on other sites

CharleyVarrick

You didn't have the Kodi companion installed, so that is normal because the Kodi companion records live events for the add-on. You need to bring your libraries up to date once in Emby for Kodi > manage libraries > update libraries. Then the Kodi companion will provide the list of updated content on Kodi startup from then on.

 

Make sure the kodi companion option in the add-on settings is enabled.

Yes, Kodi companion was already enabled (once installed).

manage libraries > update libraries: this provoke the first update scan (top right) in a week, if not more, but I noticed it performed a full scan of the library I picked (from A to Z)

If I'm not mistaken, its the first time in 3 years I've been using Emby and Emby for Kodi, that I needed to use the manage/update libraries feature

 

In those 3 years, without Kodi Companion installed/enabled, Kodi was performing a quick update scan on startup, seconds after the Emby "Hi user" greeting

Edited by jlr19
Link to comment
Share on other sites

Angelblue05

Doubt the manual sync performed quick, unless you had a really small library. It literally pulled your entire emby library to compare by type with what's in Kodi. I removed the manual sync because it was impossible to implement series pooling with it in place, it would cause bad links because the manual sync would pull by type rather than by library. Anyway.

 

The Kodi companion is sort of required now. Otherwise, update libraries manually.

 

Once the update process is completed, then the kodi companion will take over and it should be quick updates at startup.

Edited by Angelblue05
  • Like 1
Link to comment
Share on other sites

CharleyVarrick

Doubt the manual sync performed quick, unless you had a really small library. It literally pulled your entire emby library to compare by type with what's in Kodi. I removed the manual sync because it was impossible to implement series pooling with it in place, it would cause bad links because the manual sync would pull by type rather than by library. Anyway.

 

The Kodi companion is sort of required now. Otherwise, update libraries manually.

 

Once the update process is completed, then the kodi companion will take over and it should be quick updates at startup.

My library is on the large side (14k movies/25k episodes, and I assure you the daily "differential" update scan was performed automatically, in 30-50 seconds, often less when there was less new content to find and update.

 

I was wondering why all of a sudden I needed this Companion, when I was doing just fine without it, up to a couple of weeks ago that is.

Your explanation now make sense of it all.

 

Thank you

Edited by jlr19
  • Like 1
Link to comment
Share on other sites

Angelblue05

Wow, well it's definitely gone. More improvements will be done in that area in the future. But with the companion plugin, it should be faster.

 

Not only that, but the manual sync would break music libraries as well. Adding themes as songs. Anyway. Keep me posted. I have a few people that have some difficulties with the server plugin, but it seems to function quite well for most.

Link to comment
Share on other sites

CharleyVarrick

One more unrelated thing, If I may.

As you know, I was using Kodi 17 along with default Confluence skin, and now, I'm on Kodi18, with Estuary. I must be a traditionalist because I thought Confluence was more user friendly.

 

I was looking at a thread about a made for Emby Kodi skin called Embuary, but when I try to enable it, I get a red warning that mouses are not supported.

Link to comment
Share on other sites

Angelblue05

Yes the skin does not support mouse control. You can disable that in the Kodi settings > system settings > input > Disable mouse and touch support. You should be able to move forward anyway? Is it asking you to update your Kodi settings?

Link to comment
Share on other sites

CharleyVarrick

Is it asking you to update your Kodi settings?

What would be asking this? Embuary skin install?

I chickened out of the install.

No mouse support is a deal breaker for me.

 

Oh, I am so pleased to tell you Kodi is 100% up to date in tv shows, a first in over 2 weeks.

I just fixed boxed set, the count went from 3 to 577.

Edited by jlr19
  • Like 1
Link to comment
Share on other sites

Angelblue05

Yeah, when it's the first time, it asks you to edit some kodi settings.

 

Ah well there are other skins :)

 

And good.

  • Like 1
Link to comment
Share on other sites

CharleyVarrick

Looks like I'm not out of the woods yet.

Remember I am running instances of Kodi for Emby on 2 different pc, Workhorse and HTPC.

While Workhorse seems all fine now, I figured I would need to perform libraries update on HTPC as well.

Companion was already enabled, but when I go manage libraries/update libraries, instead of listing all my libraries like on Workhorse, on HTPV, it only offers "All", which I selected.

There was no progress indication at all. But it seems to have updates some content, tv shows, for instance. it now looks up to date.

But it also looks like its missing whole libraries, music videos, music shows.

 

I chose Add libraries, and the following screen offered all libraries, I selected "All".

Progress indication popped in in familiar place, but it will take a while before it completes.

I'll keep you posted.

Edited by jlr19
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...