Jump to content
ArthurAttout

Two MKV files. One of them has distorted audio

Recommended Posts

ArthurAttout

I have two MKV files that I stream from a Windows emby server to a Raspberry Pi HTML5 client.

 

One of them has perfectly fine audio, while the other has highly distorted audio (like if it was amplified 10 times, then compressed).

The audio is distorted only on the Raspberry Pi client. If I read the same video on another client (Android app, or windows web client) the audio is perfect on both files.

The Raspberry Pi client uses Chromium 65.0.3325.181 Built on Raspbian , running on Raspbian 9.8.

 

Here are the specs of the file that does not distort the sound

5cb8c670412e7_nodist.png

 

5cb8c5f5ba579_nodist.png

 

Here are the specs of the file that does distort the sound

5cb8c66232c9a_dist.png

 

5cb8c6028f762_dist.png

 

Server configuration : Version 4.1.0.26 (Windows) Dlna (1.0.12)

 

Is there any well-known issues regarding MKV files with distorted audio on specific platforms ?

I've seen several threads about this, but it was on Roku (https://emby.media/community/index.php?/topic/28067-audio-distorted-when-playing-1080p-mkvs/) and I'm using the HTML5 client.

Share this post


Link to post
Share on other sites
Luke

Hi, so the server is remuxing this I assume? Because chrome does not support ac3 audio. Are you not able to update chrome?

Share this post


Link to post
Share on other sites
pwhodges

Has the "audio boost when downmixing" setting under transcoding been set too high?

Share this post


Link to post
Share on other sites
ArthurAttout

Hi, so the server is remuxing this I assume? Because chrome does not support ac3 audio. Are you not able to update chrome?

 

Chromium seems to be at its last version, I cannot upgrade it further. All browsers on Raspberry PI are bloated, chromium is the only one that managed to load properly the HTML5 emby theater.

Firefox ESR is slow as hell, midori can't even load it

 

 

Has the "audio boost when downmixing" setting under transcoding been set too high?

 

Where do I check this ?

Share this post


Link to post
Share on other sites
ArthurAttout

My previous message can be ignored. The problem has been partially fixed by combining both the answers

 

Updating chromium-browser to its last version

Setting audio boost from 2 to 0.5 (I don't think it's actually what fixed it, but the issue is solved anyways)

 

The audio is still distorted, but in a more acceptable way than before. I guess it's still distorted because the audio boost is at 0.5 (can't set it lower, why though ?)

Edited by ArthurAttout

Share this post


Link to post
Share on other sites
Luke

I'll look at that configuration.

 

Thanks for the feedback.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...