Jump to content

Subtitles do not work on Emby Android


zetatec
 Share

Go to solution Solved by Luke,

Recommended Posts

zetatec
Hi, first congratulations for all this work. Great!

 

I have a problem, subtitles work fine in the Web version as you can see below:

 

5ca116ea61c6e_WebVersion.png

 

 

However, in the Android version do not work:

 

 

5ca117ef863fe_mobile2.jpg

 

 

 

5ca117fb72a36_mobile1.jpg

 

 

 

Thank you very much in advance.

Link to comment
Share on other sites

  • 1 month later...

@@zetatec

 

The issue is that we extract the embedded subtitles on the fly and send them to the video player as plain text, however in your environment this process is taking a long time, and it's causing you to think the subtitles aren't working.

 

What you can do is go to server transcoding settings and uncheck the option to allow subtitle extraction on the fly. This will caused them to be burned in with server transcoding instead - of course, you might not like that either due to the amount of resources it will consume on your server in order to do that.

 

That's why for the best experience possible, external subtitles are always the most efficient choice. Please let us know if this helps. Thanks.

Link to comment
Share on other sites

  • 1 month later...
zetatec

 

Hi, thanks for replying.

I continued testing here. I will describe the scenario:

{

 

All movies are in the format ".strm"

Subtitles in ".srt" format

 

}

 

In the described scenario the subtitles work in the web version, but, they do not work on Windows and Android clients.

I tested the same movie, the same subtitle.

The difference is that in the first test (test1) the movie was locally (Figure 1), in the second test (test2) the movie was in the cloud (.strm file) (Figure 2).

 

 

Figure1:

5d0e89cdb351d_figure1.png

 

 

 

Figure2:

5d0e89e921c7e_figure2.png

 

 

Result test1 (Android Client):

 

 

5d0e8a012f9ed_test1.jpg

 

 

Result test2 (Android Client):

 

5d0e8a16df617_test2.jpg
Link to comment
Share on other sites

  • 1 year later...
silvending

Hi.. on the latest version of emby app for my android tablet, it doesn't display subtitles too... however, if i play that movie by web.. it displays subtitles. Strange.

Link to comment
Share on other sites

  • 1 month later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...