Jump to content


Photo

Horrible performance with NVENC + GTX 960

help nvenc performance

  • Please log in to reply
18 replies to this topic

#1 patrickemuller OFFLINE  

patrickemuller

    Newbie

  • Members
  • 7 posts
  • Local time: 04:13 AM

Posted 19 February 2019 - 11:28 AM

I'm been using Emby for a few months now, and recently I made a deal and got a GTX 960 Zotac 4GB version.
I put this in my media server and enabled hardware encoding on Emby Server.

The problem is that I can't stream 4k movies without buffering pauses during playback.

The server cannot transcoding more than 20 fps and I always need to pause the video and let the buffer load for a few minutes.

 

There is something hide that I need to enable to get more performance?
GPU usage for every 4k stream is around 25% (viewing through Windows Task Manager panel).

 

I know you guys will ask for the logs... which one of them is required?

Attached Files


Edited by patrickemuller, 19 February 2019 - 10:56 PM.


#2 rbjtech OFFLINE  

rbjtech

    Advanced Member

  • Members
  • 490 posts
  • Local time: 06:13 AM
  • LocationLondon, UK

Posted 19 February 2019 - 11:51 AM

so some obvious things to check even without logs ..

 

a) Do you have emby premier ? - as hardware transcoding only works with a premier subscription

B) if yes - then under 'Transcoding' - under 'Enable Hardware Acceleration when available' - select 'Advanced'

c) Does you system list 'NVDEC' for the decoders and 'NVENC' for the encoders ?


Edited by rbjtech, 19 February 2019 - 11:51 AM.


#3 patrickemuller OFFLINE  

patrickemuller

    Newbie

  • Members
  • 7 posts
  • Local time: 04:13 AM

Posted 19 February 2019 - 12:15 PM

Yes, Im premiere, this GPU is the only one I have on that system, all options in advanced tab are selected

#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142432 posts
  • Local time: 01:13 AM

Posted 19 February 2019 - 03:23 PM

Hi there, can we please look at an example? Please attach the information requested in how to report a media playback issue. thanks !

 

@softworkz



#5 patrickemuller OFFLINE  

patrickemuller

    Newbie

  • Members
  • 7 posts
  • Local time: 04:13 AM

Posted 19 February 2019 - 10:56 PM

I edited the original post and put more information



#6 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142432 posts
  • Local time: 01:13 AM

Posted 19 February 2019 - 11:18 PM

Thanks. We'll see what @softworkz thinks.

#7 pir8radio OFFLINE  

pir8radio

    NGINX

  • Members
  • 2936 posts
  • Local time: 12:13 AM
  • LocationChicago

Posted 20 February 2019 - 12:45 AM

I'm been using Emby for a few months now, and recently I made a deal and got a GTX 960 Zotac 4GB version.
I put this in my media server and enabled hardware encoding on Emby Server.

The problem is that I can't stream 4k movies without buffering pauses during playback.

The server cannot transcoding more than 20 fps and I always need to pause the video and let the buffer load for a few minutes.

 

There is something hide that I need to enable to get more performance?
GPU usage for every 4k stream is around 25% (viewing through Windows Task Manager panel).

 

I know you guys will ask for the logs... which one of them is required?

 

 

does it play when you force transcode to 1080p 4mbps? 

 

Does it get better if you shut off Closed Caption?    Burnt in subtitles kill the transcoding. 

 

That's an older card, I wouldn't expect too much more than 1 or 2 streams max at 4k hevc.


Edited by pir8radio, 20 February 2019 - 12:58 AM.


#8 patrickemuller OFFLINE  

patrickemuller

    Newbie

  • Members
  • 7 posts
  • Local time: 04:13 AM

Posted 20 February 2019 - 01:20 AM

does it play when you force transcode to 1080p 4mbps?

Does it get better if you shut off Closed Caption? Burnt in subtitles kill the transcoding.

That's an older card, I wouldn't expect too much more than 1 or 2 streams max at 4k hevc.


The images I sent as evidence are with just 1 stream opened.

Turning off subtitles didn't help.

I tested on my phone 1080@4mbps and it played nice with almost 60 fps of encoding speed as reported in Stats for Nerds.

4k, even with the slowest bitrate, still stutter and get below 20fps

Edited by patrickemuller, 20 February 2019 - 01:21 AM.


#9 chacawaca OFFLINE  

chacawaca

    Advanced Member

  • Members
  • 147 posts
  • Local time: 01:13 AM
  • LocationQuebec, Canada

Posted 20 February 2019 - 01:31 AM

https://developer.nv...-support-matrix

If its not a gtx 960 ti it doesnt support 4K

#10 patrickemuller OFFLINE  

patrickemuller

    Newbie

  • Members
  • 7 posts
  • Local time: 04:13 AM

Posted 20 February 2019 - 01:43 AM

https://developer.nv...-support-matrix

If its not a gtx 960 ti it doesnt support 4K


Interesting, didn't know about that. I'm using a AMD FX-8320e Overclock to 4.4ghz, there is any chance that the CPU itself support 4k encoding?

#11 pir8radio OFFLINE  

pir8radio

    NGINX

  • Members
  • 2936 posts
  • Local time: 12:13 AM
  • LocationChicago

Posted 20 February 2019 - 09:38 AM

Interesting, didn't know about that. I'm using a AMD FX-8320e Overclock to 4.4ghz, there is any chance that the CPU itself support 4k encoding?

 

what does the dashboard show when you transcode?  I suspect it's already using the CPU if the GPU doesn't support?



#12 patrickemuller OFFLINE  

patrickemuller

    Newbie

  • Members
  • 7 posts
  • Local time: 04:13 AM

Posted 20 February 2019 - 12:17 PM

what does the dashboard show when you transcode? I suspect it's already using the CPU if the GPU doesn't support?


No, Ita always using the GPU, but the speed is below 20fps, even on lowest 4k bitrate

#13 Doofus ONLINE  

Doofus

    Advanced Member

  • Members
  • 12887 posts
  • Local time: 10:13 PM

Posted 20 February 2019 - 12:53 PM

The 960 supports HEVC, but only decoding, not encoding. That's why you see GPU activity. It's decoding, then the CPU is encoding.

Edited by Doofus, 20 February 2019 - 02:07 PM.


#14 chacawaca OFFLINE  

chacawaca

    Advanced Member

  • Members
  • 147 posts
  • Local time: 01:13 AM
  • LocationQuebec, Canada

Posted 20 February 2019 - 01:36 PM

Yes my bad on nvidia matrix it support decode but not encode

#15 softworkz OFFLINE  

softworkz

    Advanced Member

  • Developers
  • 1892 posts
  • Local time: 07:13 AM

Posted 20 February 2019 - 03:48 PM

@patrickemuller

 

Disregard the above replies, a number of incorrect statements were made.

 

You GPU _does_ support H.264 encoding up to 4096x4096 as can be seen in the ffmpeg log:

>>>>>>  NVDEC GeForce GTX 960 - H.265 (HEVC)
        Adapter #0: 'GeForce GTX 960' ComputeCapability: 5.2
        Frame Sizes: 144x144...4096x4096 - Width Alignment: 2 - Height Alignment: 2
        Color Formats: CUDA, NV12, P010LE, P016LE
        Profiles: Main Profile (Level 6 (Main)), Main 10 Profile (Level 6 (Main))

>>>>>>  NVENC GeForce GTX 960 - H.264 (AVC)
        Adapter #0: 'GeForce GTX 960' ComputeCapability: 5.2
        Frame Sizes: max 4096x4096 - Width Alignment: 2 - Height Alignment: 2
        Color Formats: NV12, P010LE, CUDA, YUV420P
        Profiles: Baseline Profile (Level 5.1), Main Profile (Level 5.1), High Profile (Level 5.1), High 4:4:4 Profile (Level 5.1) 

Also, the Nvidia GPU is used for both decoding and encoding.

 

What slows down things here is the graphical subtitle overlay that was used in the ffmpeg log.

 

 

Please try to disable subtitles and create a new log.



#16 Doofus ONLINE  

Doofus

    Advanced Member

  • Members
  • 12887 posts
  • Local time: 10:13 PM

Posted 20 February 2019 - 03:53 PM

Oh ha! Of course, my head was stuck on hevc. My bad.

#17 pir8radio OFFLINE  

pir8radio

    NGINX

  • Members
  • 2936 posts
  • Local time: 12:13 AM
  • LocationChicago

Posted 20 February 2019 - 09:33 PM

I asked him to turn off subtitles, said didn't help at all..  But yea a second log would be good..   :)



#18 patrickemuller OFFLINE  

patrickemuller

    Newbie

  • Members
  • 7 posts
  • Local time: 04:13 AM

Posted 22 February 2019 - 01:10 PM

@patrickemuller

 

Disregard the above replies, a number of incorrect statements were made.

 

You GPU _does_ support H.264 encoding up to 4096x4096 as can be seen in the ffmpeg log:

>>>>>>  NVDEC GeForce GTX 960 - H.265 (HEVC)
        Adapter #0: 'GeForce GTX 960' ComputeCapability: 5.2
        Frame Sizes: 144x144...4096x4096 - Width Alignment: 2 - Height Alignment: 2
        Color Formats: CUDA, NV12, P010LE, P016LE
        Profiles: Main Profile (Level 6 (Main)), Main 10 Profile (Level 6 (Main))

>>>>>>  NVENC GeForce GTX 960 - H.264 (AVC)
        Adapter #0: 'GeForce GTX 960' ComputeCapability: 5.2
        Frame Sizes: max 4096x4096 - Width Alignment: 2 - Height Alignment: 2
        Color Formats: NV12, P010LE, CUDA, YUV420P
        Profiles: Baseline Profile (Level 5.1), Main Profile (Level 5.1), High Profile (Level 5.1), High 4:4:4 Profile (Level 5.1) 

Also, the Nvidia GPU is used for both decoding and encoding.

 

What slows down things here is the graphical subtitle overlay that was used in the ffmpeg log.

 

 

Please try to disable subtitles and create a new log.

 

Why it encode AND decode while streaming?



#19 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142432 posts
  • Local time: 01:13 AM

Posted 22 February 2019 - 01:18 PM

Because it decodes the source and encodes to the format that will be used for streaming.





Also tagged with one or more of these keywords: help, nvenc, performance

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users