Jump to content

Server - Unhandled Exception


AdrianW
 Share

Recommended Posts

AdrianW

I have the server and MBC running on the same PC - with Media Center full screen most of the time.

 

Today I updated MBC and hiding behind was this:

 

vMt5p4Y.png

 

 

Here's the "unhandled...txt" log:

Sequence contains no matching element
System.InvalidOperationException
   at System.Linq.Enumerable.First[TSource](IEnumerable`1 source, Func`2 predicate)
   at MediaBrowser.Server.Implementations.Session.SessionManager.GetSession(String sessionId)
   at MediaBrowser.Server.Implementations.Session.SessionManager.<ReportSessionEnded>d__11.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
   at MediaBrowser.Dlna.PlayTo.PlayToController.<_SsdpHandler_MessageReceived>d__0.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.CompilerServices.AsyncMethodBuilderCore.<ThrowAsync>b__5(Object state)
   at System.Threading.QueueUserWorkItemCallback.WaitCallback_Context(Object state)
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem()
   at System.Threading.ThreadPoolWorkQueue.Dispatch()
   at System.Threading._ThreadPoolWaitCallback.PerformWaitCallback()

And here's the server log including the time that this occurred. The time stamp on the "unhandled...txt" log was 30/04/2014 8:10PM

 

Link to comment
Share on other sites

SikSlayer

I too have been having the same problem, but with the server, I wasn't using any clients. I did also have this issue about a month ago, and it went away, but now its happening again. 

 

Here's my server logs. Hope these help.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...