Jump to content


Photo

Some movies won't add into a collection

Movies Collection Multiple file 4K HD

  • Please log in to reply
7 replies to this topic

#1 Twistedcloud OFFLINE  

Twistedcloud

    Member

  • Members
  • 19 posts
  • Local time: 02:13 AM

Posted 20 January 2019 - 05:28 PM

For some of my movies I have both an 1080p and a 4k Version saved into the same folder. Emby groups the files together properly and allows me to pick the version I want to watch.

 

It seems that there are a few movies that just refuse to be added into a Collection when I do this.

 

My John Wick movies show in a collection and have both 4K and HD in the same file. As will my Pacific Rim Movies.

My Matrix Movies, will not go into a collection (even if I try to add them manually), The Incredibles will also not allow me to add them to a collection. 

 

I use the same file name structure for all of my movies.



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 123950 posts
  • Local time: 09:13 PM

Posted 20 January 2019 - 05:42 PM

Hi there, what happens when you try to add your matrix movies to a collection?



#3 Twistedcloud OFFLINE  

Twistedcloud

    Member

  • Members
  • 19 posts
  • Local time: 02:13 AM

Posted 21 January 2019 - 02:02 AM

Hi there, what happens when you try to add your matrix movies to a collection?

 

Nothing at all, ti says Item Added but it doesn't actually get added. I checked the Metadata and it shows the correct collection ID. I tried to add and remove the ID. delete the collection and move the files around and nothing happens.

 

The Matrix will just show as a stand alone movie, The Matrix Reloaded goes into the collection as a single movie and the Matrix Revolutions stands out as a single movie.

Attached Files


Edited by Twistedcloud, 21 January 2019 - 02:05 AM.


#4 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 13761 posts
  • Local time: 06:13 PM
  • LocationWashington State

Posted 21 January 2019 - 03:37 AM

That image of The Matrix (itemdetails page) shows it does not have a tmdbcollectionid. 

 

But do you save metadata with your media?



#5 Twistedcloud OFFLINE  

Twistedcloud

    Member

  • Members
  • 19 posts
  • Local time: 02:13 AM

Posted 21 January 2019 - 11:29 AM

That image of The Matrix (itemdetails page) shows it does not have a tmdbcollectionid. 

 

But do you save metadata with your media?

 

Went and double check made sure it had the collection ID, still doesn't get added into the collection.

 

Yes I save Metadata with all of my media. If I remove either the 1080P version or the 4K Version it will move back into the collection. The moment I have both files it sits outside of the collection.

 

Though My John Wick movies are set up exactly the same and they will show as part of the collection

Attached Files



#6 Twistedcloud OFFLINE  

Twistedcloud

    Member

  • Members
  • 19 posts
  • Local time: 02:13 AM

Posted 21 January 2019 - 09:37 PM

I am adding the collection files as for John Wick and the Matrix, the seem to read the same to me.

Attached Files


Edited by Twistedcloud, 21 January 2019 - 10:59 PM.


#7 Twistedcloud OFFLINE  

Twistedcloud

    Member

  • Members
  • 19 posts
  • Local time: 02:13 AM

Posted 22 March 2019 - 07:37 PM

For anyone else running into this same issue I did find a work around

 

From what I can tell the issue comes if you add a secondary file that you want to show up as the primary file. (So have a 1080p movie I added a 4K and i wanted the NFO to be tied to the 4K version).

 

1) I manually moved the files out of my Emby folders and into another folder Emby could not see.

2) Then I went into Emby and deleted the movie and all associated data.

3) I created a new folder in my Emby files for the Movie

4) I moved my primary Movie file back in and change the name structure just a bit (so added a . where i had spaces or vice versa)

5) Let Emby scan the movie back in and make a new NFO file

6) added my additional version files back in.*

 

* With step 6 sometimes if my other files were older then then my primary Emby would still make .NFO file for it so sometimes I would have to copy it to a new drive then copy it back so it showed as a whole new file to my system)



#8 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 123950 posts
  • Local time: 09:13 PM

Posted 01 April 2019 - 12:44 AM

Thanks for the feedback. We are looking into this.







Also tagged with one or more of these keywords: Movies, Collection, Multiple file, 4K, HD

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users