Jump to content

How to Order the Library entries on the EHS for EMC with Throgs themes..


Recommended Posts

After the last update I changed one small library (JW Media) from Movie Content to Mixed Content to solve the issue of incorrect displaying of single movies in a single folder.

 

After rescanning the JW Media library it was now entered as the last item just before Live TV on the EHS. I made sure of the Library order and the correct display on the Home Screen in Fire Fox but it still puts the JW Media library at the end. Is there somewhere in the bowels of the AppData directory or somewhere else in a folder some config file that will ensure the correct order on the EHS screen?

 

Home Screen with correct order.

5c42b787db64a_0HomeScreen.jpg

 

 

Library Order from MyMedia setting and again it is correct.

5c42b7bc13a6b_1LibraryOrder.jpg

 

 

Meta Data Manager that shows where the JW Library is now appearing. All other libraries follow the proper order as from the home screen.

5c42b882e2117_2MetadataMgr.jpg

 

I am afraid that when I add new libraries they will always be tagged on to the end. So please tell me the secret on where to configure the order of libraries for the EHS of the EMC.

 

Thanks

O2G

 

Link to post
Share on other sites

What is incorrect about the 2nd screenshot?

 

The metadata manager is currently a user-less browser, meaning, it does not incorporate user settings at this time.

Link to post
Share on other sites

@@Luke The first two screen shots are correct look at the JW Media library it follows the Documentary library. Which it should. However on the EHS screen it follows Bits & Bobs - TV library before the Live TV part. It should be in the 7th position not next to last.

 

Thanks for the quick answer and I feel for you guys manning the fort after the major update.

Link to post
Share on other sites

I am have pretty much the same issue. The Library order is adhered to by the web interface...

5c43b5db88335_LibraryOrder.jpg

5c43b5f714525_MyMedia.jpg

...but Emby for Windows Media Center (using EHS and Chocolate) follows the order displayed in the Metadata Manager...

5c43b63d4d2ac_MetadataManager.jpg

 

In previous versions of Emby Server there was the ability to set media folder wide settings in Metadata manager and one of these was Sort Order Title (which I assigned titles of "001", "002", "003" etc). Now there are no options at folder level.

 

Further to this as you can see the order is not alphabetical, probably because it was mostly set up using an older server versions and likely adhering to the Sort Order Title for those that have that filed populated. I think this as I deleted and readded "Movies" and they moved from before Miscellaneous to after (which is now following alphabetical order). I have also does the same with Miscellaneous and Music Videos to fix other issues.

 

So the question is: How to we define the Sort Order Title in Emby Server 4? Or how to we define the displayed order in Emby for Windows Media Center as it seems to follow the order of the Metadata manager?

Link to post
Share on other sites

 

 

In previous versions of Emby Server there was the ability to set media folder wide settings in Metadata manager and one of these was Sort Order Title (which I assigned titles of "001", "002", "003" etc). Now there are no options at folder level.

 

The exact reason for getting rid of this is that we should not have multiple ways of doing the same thing. It just complicates everything.

 

It sounds like the app will need update to respect user library order.

Link to post
Share on other sites

Please include this update in the next release. I found in the corresponding directories to the libraries a folder.xml file which had an entry called "Sort" (something) listing the position in the EHS. Something like "<sort>6th</sort>" but it did not change the position of the library in question that needed to be moved forward. Any idea what that folder.xml is for?

Link to post
Share on other sites

The exact reason for getting rid of this is that we should not have multiple ways of doing the same thing. It just complicates everything.

 

I agree it was very confusing and this should be better.

 

 

It sounds like the app will need update to respect user library order.

 

Yes please!

Link to post
Share on other sites

I'm afraid this may end up a bit tricky but we'll try and work something out.

 

The basic issue is that EMC has always had its own sorting built in (because it evolved from the old MB 2 and was just supposed to be a stop-gap until Theater was finished :)).  So, my guess is that it is relying on the sort title which is now not there.

Link to post
Share on other sites

Since I do still have MB 2.6 installed on one of my PCs as a backup in the configurator there is a way to sort the libraries by moving their respective position, can't that be added to the EMC configurator?

Edited by One2Go
Link to post
Share on other sites
throgmorton

The basic issue is that EMC has always had its own sorting built in (because it evolved from the old MB 2 and was just supposed to be a stop-gap until Theater was finished :)).  So, my guess is that it is relying on the sort title which is now not there.

 

I'm pretty sure in the MB days it used sort title I seem to remember just doing a simple number scheme like 001 Movies, 002 TV Shows, etc... Although with Emby I was able to reorder properly using the method shown in the 2nd screenshot. I guess this has since changed in v4.0, as I guess v3 was still using that sort order tag to support WMC.

Link to post
Share on other sites

I'm pretty sure in the MB days it used sort title I seem to remember just doing a simple number scheme like 001 Movies, 002 TV Shows, etc... Although with Emby I was able to reorder properly using the method shown in the 2nd screenshot. I guess this has since changed in v4.0, as I guess v3 was still using that sort order tag to support WMC.

 

It seems that there may still be some of the old sorting code left in v4 as if you look at the order of folders in my Metadata screen shot it is not in any logical sort order other than me knowing I used the Sort Title field to put Television first. 

Link to post
Share on other sites
throgmorton

It seems that there may still be some of the old sorting code left in v4 as if you look at the order of folders in my Metadata screen shot it is not in any logical sort order other than me knowing I used the Sort Title field to put Television first. 

 

Well unless I completely misunderstood what has happened Emby still and always has had the ability to order the items.  The issue I thought was that in Emby pre v4 it was sending that information to the Sort tag in EMC, now in v4 they have removed the code which sends the information to the sort tag so it will no longer put it in order.  Maybe I'm wrong on this as I haven't upgraded to v4 to look at it.  Honestly if I could I would revert back to a way older version of Emby to get my Studio icons back, but I need to keep up-to-date to ensure my themes work for the user base that still uses them.

Link to post
Share on other sites

Honestly if I could I would revert back to a way older version of Emby to get my Studio icons back, but I need to keep up-to-date to ensure my themes work for the user base that still uses them.

Same here I spend hours to get studio icons, but since resolved to keep abreast with the Emby development. I really appreciate your constant effort to keep us users of your themes happy. Is there any thing you can do in your themes to sort the order of the library links the way they appear on the EHS or is this something @@ebr that he has to fix in EMC? EMC beta is from May 2018 if I am not mistaken, it does deserve a desperately needed look for changes and needed updates!

Link to post
Share on other sites
throgmorton

Unfortunately I can't think of any way right now as my themes basically request the "children" of the specific item in this case the children of the root folder (which would be your EHS folder items).  I simply present them in the order provided back to me,

 

In order to change this I believe the core EMC will have to be updated to order this request by what the Emby Server is saying, and not by perhaps some sort order tag which @@ebr thinks the core is used to sending.

Link to post
Share on other sites

Unfortunately I can't think of any way right now as my themes basically request the "children" of the specific item in this case the children of the root folder (which would be your EHS folder items).  I simply present them in the order provided back to me,

 

In order to change this I believe the core EMC will have to be updated to order this request by what the Emby Server is saying, and not by perhaps some sort order tag which @@ebr thinks the core is used to sending.

Don't know if this may help but the word root folder in your post triggered my memory. I searched in the \Users\Admin\AppData folder and found this at the following location \Users\Admin\AppData\Roaming\Emby-Server\root\default

 

5c4508703d904_1RootLocation.jpg

 

 

These are all my libraries that I have the one that I deleted and then replaced again is JW Media but here is an example of what the folder associated with the library Animation looks like:

5c4508d559713_2AnimationFolder.jpg

 

 

Animation.mblink file has a single line in it the location of the library

\\TOWER\Animation

 

However folder.xml looks like this:

5c45096cdaab9_3folderxml.jpg

 

True this is in the 2nd location of the EHS however the JW Media folder had NO folder.xml file in it. After copying the Animation folder.xml file and changing the relevant entries including setting SortTitle to 8th which it should be. Restarted the server and NO changes. Then from the Web Dashboard I added Logo & Backdrop PNG files to it and they appeared in the JW Media folder as Fanart.png and Logo.png and showed up in the EHS but the sort location for JW Media did not change and was still just before Live TV.

 

Don't know if this helps but I am trying to resolve this.

Thanks for your help.

Edited by One2Go
Link to post
Share on other sites

The problem here is with the Legacy browsing option.  It simply cannot be supported anymore.

 

317 should behave properly for the order now.

Link to post
Share on other sites

The problem here is with the Legacy browsing option.  It simply cannot be supported anymore.

 

317 should behave properly for the order now.

I don't quite understand this. There are two problems that crept in with the 4.002 update, this one about the order and the other about single movie files in a single folder having this extra erroneous folder before finally ending up in the correct detail page. Does that have to do with the legacy browsing as I don't get it as I mentioned in the other thread that CoverArt never applies any treatment on the single movie folders. That does not look to me like legacy browsing but something in EMC or the server.

 

I have one server that works for my home theater and I was very happy with the total functioning. I am almost certain that I disabled automatic updates, yet when I turned on the HTPC the server had updated to 4.002 and I wish now that I had stayed at 3.5.3 with no hassles.

 

I am hoping that if it is not in the future of EMBY then please either release a version that works for this problem with single movie folders and then I will stay at that version, OR please publish a guideline how to revert to version 3.5.3 and I will stay at that version then and install version 4.* on a different PC if I need the new features. I am a bit disappointed the way things turned out and since I am tied to Throg's themes I would like a stable HTPC with EMC.

Edited by One2Go
Link to post
Share on other sites

I don't quite understand this. There are two problems that crept in with the 4.002 update, this one about the order and the other about single movie files in a single folder having this extra erroneous folder before finally ending up in the correct detail page. Does that have to do with the legacy browsing as I don't get it as I mentioned in the other thread that CoverArt never applies any treatment on the single movie folders. That does not look to me like legacy browsing but something in EMC or the server.

 

I have one server that works for my home theater and I was very happy with the total functioning. I am almost certain that I disabled automatic updates, yet when I turned on the HTPC the server had updated to 4.002 and I wish now that I had stayed at 3.5.3 with no hassles.

 

I am hoping that if it is not in the future of EMBY then please either release a version that works for this problem with single movie folders and then I will stay at that version, OR please publish a guideline how to revert to version 3.5.3 and I will stay at that version then and install version 4.* on a different PC if I need the new features. I am a bit disappointed the way things turned out and since I am tied to Throg's themes I would like a stable HTPC with EMC.

 

The problem in this thread is about library order.  That is related to the legacy browsing option.

 

The other issue you are talking about, I believe, is related to movies in a Mixed Content library.  You should test this with both the latest beta of EMC and the new stable 4.0.1 that should be out very soon.

Link to post
Share on other sites

The problem in this thread is about library order.  That is related to the legacy browsing option.

 

The other issue you are talking about, I believe, is related to movies in a Mixed Content library.  You should test this with both the latest beta of EMC and the new stable 4.0.1 that should be out very soon.

Libraries of mixed content do not have the problem with the single movie folder it is just in libraries that have Movies as content. I changed a 10 movie library from Content = Movies to Content = Mixed and all the problems with the single movie folder went away.

 

I am running the EMC beta as the .307 version together with server 4.002 does not handle Movie folders that contain Blu-ray or DVD folders correctly. The external player will never get launched as the Blu-ray and DVD folders are not identified as such but rather are identified as H.264 and H.262 respectively which launches MPC-HC as external player rather then PDVD that handles Blu-rays and DVDs.

 

Thanks for all the help and I feel for you guys as you have been in a fire drill since the release. Thanks again and I am waiting for the next stable server version.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...