Jump to content


Photo

Video crashing to Roku home screen

crashing roku

  • Please log in to reply
3 replies to this topic

#1 S3v3nD34dly51ns OFFLINE  

S3v3nD34dly51ns

    Member

  • Members
  • 11 posts
  • Local time: 02:44 PM

Posted 09 January 2019 - 07:34 PM

Noticed something as of late, when trying to play videos through Roku they will 'cycle' through as though they're going to play then it will immediately crash the Emby app and then go right back to the Roku homescreen.  It's random, because sometimes it will play the movie that I was just watching and other times it will do this. Roku software version is 9.0.0 build 4084-24, and Emby has been uninstalled and reinstalled. Sometimes restarting of the Roku fixes the issue.  Anyone else experience this? I can do a debug log and send it if need be just need to enable Emby debug on the Roku and pull from there.



#2 speechles OFFLINE  

speechles

    Advanced Member

  • App Developer
  • 5459 posts
  • Local time: 11:44 AM

Posted 09 January 2019 - 08:24 PM

1) What Roku model # is this?

2) Do you have "enable debug" turned on when you have these issues or does it occur with it off as well? With debug on the app will use memory to store data to send as logs.

3) The video player must have 25MB of free space in texture ram to spawn. Does this occur after using the app for an extended period or does it happen when the app is started recent too?

 

Knowing the answers to the above will help determine what we need to do. It will be hard to send debug logs if the app is actually crashing back to the Roku homescreen. The way Roku works you can log to TMP as long as your app is running. Once your app stops the TMP is wiped. So when you come back into the app what you previously logged is now lost from TMP. This makes logs from the Roku not very useful in this case which is why I pose the 3 questions above. 



#3 S3v3nD34dly51ns OFFLINE  

S3v3nD34dly51ns

    Member

  • Members
  • 11 posts
  • Local time: 02:44 PM

Posted 10 January 2019 - 04:44 AM

1>It's the Roku streaming stick model #3600x

2>enable debug is off when this happens, I have not turned it on yet.

3>it will happen randomly, I could have been at work all day come home and throw on something random say like "Shrek" and it'll get to the movie menu, act like it's loading then crash. Or I could be watching a series for a couple of hours, decide to watch a Disney movie and it will do it.



#4 speechles OFFLINE  

speechles

    Advanced Member

  • App Developer
  • 5459 posts
  • Local time: 11:44 AM

Posted 10 January 2019 - 12:29 PM

It might be the server is slow to respond to your request. This will cause issues with async timeouts. When this happens some of the functions of the app depend on the data those async connections would return with. Some of these timeouts are 5s or 10s. Once that time elapses the app may get stuck or crash to the homescreen if the async task doesnt return with valid data.

 

What Emby server version are you using? If you use the beta Emby server it should solve your problem as it is much faster at everything. The added speed of the server benefits the app and you should see much faster responses to all your button presses.

 

If you are already on the beta server we may need server logs during one of these crashes to compare against. To see which API call is timing out and then can see in the app which call to correct to add fallback when no data is returned and gracefully give an error rather than entirely crash the app. Thanks. :)


Edited by speechles, 10 January 2019 - 12:30 PM.






Also tagged with one or more of these keywords: crashing, roku

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users