Jump to content

无法下载opensubtitles的字幕, can not download any subtitle in emby server


gubin521
 Share

Recommended Posts

Hello @@gubin521

 

Thanks for getting in touch, I've taken a look at the above log and it appears to be a connectivity issue.

 

The attempts to connect fail with the following:-

System.Net.WebException: Unable to read data from the transport connection: Connection reset by peer.
---> System.IO.IOException: Unable to read data from the transport connection: Connection reset by peer.
---> System.Net.Sockets.SocketException: Connection reset by peer

Are you behind a proxy and/or firewall that could be restricting access? Has anything changed recently on your local network?

 
Best
- James
Link to comment
Share on other sites

Hi James,

This is my first time to build a emby server in synology 218+, I doubt it's a connectivity issue because I could get the movies' picture and art information. Just can not download any subtitles.

I am not behind a proxy and I close any firewall in router and NAS, and I could access my emby server by my DDNS and public network IP.

Link to comment
Share on other sites

Hello @@gubin521

 

Are you still experiencing the problem now? The error "Connection reset by peer" essentially means "...the site you are connected to has reset the connection."

 

    i.e. something between your system and OpenSubtitles' servers caused the reset.

 

I agree that in general your system appears ok, as I can see other connections completing without issue.

 

Best

- James

Link to comment
Share on other sites

yes, the problem is still there. :(

Any suggestion that I can take?

@@solabc16, is it possible that the problem is causeb by opensubtitles api? is there any other users experiencing this problem meanwhile?

Edited by gubin521
Link to comment
Share on other sites

Hello @@gubin521

 

There have been a couple of reported issues with OpenSubtitles over the past couple of days, but I'm cautious about jumping to any conclusions.

 

The current stable release of Emby Server has been out for some time now, so nothing has changed on that side.

 

Do you have another machine on the same LAN using the same Internet connection you can try and open the below URL on in browser?

https://api.opensubtitles.org/xml-rpc

You should get something back similiar to the below:-

 

5c1fccb02aae7_open_subtitles_request.jpg

Best

- James

Link to comment
Share on other sites

Hi @solabc16 

I tried it by using my windows-PC with chrome browser, get the same response as you. this PC is configured in the same router with my synology NAS.

NAS ip:192.168.2.128

PC ip: 192.168.2.158

 

 

5c20ca72a95f8_.png

Link to comment
Share on other sites

Hello @@gubin521

 

Thanks for the above. If you have IPv6 enabled on your NAS, can you disable it, so we can eliminate that as a possibility.

 

The setting is here:-

DSM -> Control Panel -> Network -> Network Interface -> <your connection> -> IPv6 -> IPv6 setup -> Off

Best

- James

Link to comment
Share on other sites

And I tried the subDB as subtitles resource, the same problem as below:

2018-12-25 11:45:54.392 Error HttpClient: Error ProtocolError getting response from http://api.thesubdb.com/?action=search&hash=30E318E40C2654692DA735464AC6609D
    *** Error Report ***
    Version: 3.5.3.0
    Command line: /var/packages/EmbyServer/target/server/EmbyServer.exe -package synology -programdata /var/packages/EmbyServer/target/var -ffmpeg /var/packages/EmbyServer/target/ffmpeg/bin/ffmpeg -ffprobe /var/packages/EmbyServer/target/ffmpeg/bin/ffprobe -restartexitcode 121
    Operating system: Unix 4.4.59.0
    64-Bit OS: True
    64-Bit Process: True
    User Interactive: False
    Mono: 5.14.0.177 (tarball Sun Nov 4 20:48:29 UTC 2018)
    Processor count: 2
    Program data path: /var/packages/EmbyServer/target/var
    Application directory: /volume1/@appstore/EmbyServer/releases/3.5.3.0
    System.Net.WebException: The remote server returned an error: (404) Not Found.
     at System.Net.HttpWebRequest+<GetResponseFromData>d__247.MoveNext () [0x00152] in <2e58ecde50444b6baf2e884bbf90860c>:0
    --- End of stack trace from previous location where exception was thrown ---
     at System.Net.HttpWebRequest+<RunWithTimeoutWorker>d__244`1[T].MoveNext () [0x000c5] in <2e58ecde50444b6baf2e884bbf90860c>:0
    --- End of stack trace from previous location where exception was thrown ---
     at System.Net.HttpWebRequest.EndGetResponse (System.IAsyncResult asyncResult) [0x00020] in <2e58ecde50444b6baf2e884bbf90860c>:0
     at System.Threading.Tasks.TaskFactory`1[TResult].FromAsyncCoreLogic (System.IAsyncResult iar, System.Func`2[T,TResult] endFunction, System.Action`1[T] endAction, System.Threading.Tasks.Task`1[TResult] promise, System.Boolean requiresSynchronization) [0x0000f] in <eb1cd6c456494990813d92477245f615>:0
    System.Net.WebException
     at System.Net.HttpWebRequest+<GetResponseFromData>d__247.MoveNext () [0x00152] in <2e58ecde50444b6baf2e884bbf90860c>:0
    --- End of stack trace from previous location where exception was thrown ---
     at System.Net.HttpWebRequest+<RunWithTimeoutWorker>d__244`1[T].MoveNext () [0x000c5] in <2e58ecde50444b6baf2e884bbf90860c>:0
    --- End of stack trace from previous location where exception was thrown ---
     at System.Net.HttpWebRequest.EndGetResponse (System.IAsyncResult asyncResult) [0x00020] in <2e58ecde50444b6baf2e884bbf90860c>:0
     at System.Threading.Tasks.TaskFactory`1[TResult].FromAsyncCoreLogic (System.IAsyncResult iar, System.Func`2[T,TResult] endFunction, System.Action`1[T] endAction, System.Threading.Tasks.Task`1[TResult] promise, System.Boolean requiresSynchronization) [0x0000f] in <eb1cd6c456494990813d92477245f615>:0
    
2018-12-25 11:45:54.403 Info HttpServer: HTTP Response 200 to 192.168.2.158. Time: 739ms. http://192.168.2.128:8096/emby/Items/ee7cf4c712e9df1b80098ac738158620/RemoteSearch/Subtitles/chi
2018-12-25 11:45:55.734 Info HttpServer: HTTP GET http://192.168.2.128:8096/emby/Items/ee7cf4c712e9df1b80098ac738158620/RemoteSearch/Subtitles/chi. UserAgent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/67.0.3396.79 Safari/537.36
2018-12-25 11:45:55.737 Info HttpClient: HttpClientManager GET: http://api.thesubdb.com/?action=search&hash=30E318E40C2654692DA735464AC6609D
2018-12-25 11:45:55.786 Info HttpServer: HTTP POST http://192.168.2.128:8096/emby/DisplayPreferences/usersettings?userId=9af3d105acac40db9f185b599ca7efc9&client=emby. UserAgent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/67.0.3396.79 Safari/537.36
2018-12-25 11:45:55.788 Info HttpServer: HTTP Response 204 to 192.168.2.158. Time: 3ms. http://192.168.2.128:8096/emby/DisplayPreferences/usersettings?userId=9af3d105acac40db9f185b599ca7efc9&client=emby
2018-12-25 11:45:55.954 Error HttpClient: Error ProtocolError getting response from http://api.thesubdb.com/?action=search&hash=30E318E40C2654692DA735464AC6609D
    *** Error Report ***
    Version: 3.5.3.0
    Command line: /var/packages/EmbyServer/target/server/EmbyServer.exe -package synology -programdata /var/packages/EmbyServer/target/var -ffmpeg /var/packages/EmbyServer/target/ffmpeg/bin/ffmpeg -ffprobe /var/packages/EmbyServer/target/ffmpeg/bin/ffprobe -restartexitcode 121
    Operating system: Unix 4.4.59.0
    64-Bit OS: True
    64-Bit Process: True
    User Interactive: False
    Mono: 5.14.0.177 (tarball Sun Nov 4 20:48:29 UTC 2018)
    Processor count: 2
    Program data path: /var/packages/EmbyServer/target/var
    Application directory: /volume1/@appstore/EmbyServer/releases/3.5.3.0
    System.Net.WebException: The remote server returned an error: (404) Not Found.
     at System.Net.HttpWebRequest+<GetResponseFromData>d__247.MoveNext () [0x00152] in <2e58ecde50444b6baf2e884bbf90860c>:0
    --- End of stack trace from previous location where exception was thrown ---
     at System.Net.HttpWebRequest+<RunWithTimeoutWorker>d__244`1[T].MoveNext () [0x000c5] in <2e58ecde50444b6baf2e884bbf90860c>:0
    --- End of stack trace from previous location where exception was thrown ---
     at System.Net.HttpWebRequest.EndGetResponse (System.IAsyncResult asyncResult) [0x00020] in <2e58ecde50444b6baf2e884bbf90860c>:0
     at System.Threading.Tasks.TaskFactory`1[TResult].FromAsyncCoreLogic (System.IAsyncResult iar, System.Func`2[T,TResult] endFunction, System.Action`1[T] endAction, System.Threading.Tasks.Task`1[TResult] promise, System.Boolean requiresSynchronization) [0x0000f] in <eb1cd6c456494990813d92477245f615>:0
    System.Net.WebException
     at System.Net.HttpWebRequest+<GetResponseFromData>d__247.MoveNext () [0x00152] in <2e58ecde50444b6baf2e884bbf90860c>:0
    --- End of stack trace from previous location where exception was thrown ---
     at System.Net.HttpWebRequest+<RunWithTimeoutWorker>d__244`1[T].MoveNext () [0x000c5] in <2e58ecde50444b6baf2e884bbf90860c>:0
    --- End of stack trace from previous location where exception was thrown ---
     at System.Net.HttpWebRequest.EndGetResponse (System.IAsyncResult asyncResult) [0x00020] in <2e58ecde50444b6baf2e884bbf90860c>:0
     at System.Threading.Tasks.TaskFactory`1[TResult].FromAsyncCoreLogic (System.IAsyncResult iar, System.Func`2[T,TResult] endFunction, System.Action`1[T] endAction, System.Threading.Tasks.Task`1[TResult] promise, System.Boolean requiresSynchronization) [0x0000f] in <eb1cd6c456494990813d92477245f615>:0
    

Link to comment
Share on other sites

@@Luke OK, do you mean subdb or opensubtitle? Emby server works fine in my windows pc and it can download subtitles from opensubtitles, but in my synology 218+ the problem is still there.

Link to comment
Share on other sites

That’s just a trial to see if it works with other subtitle add on except opensubtitles. The current situation is, in the same subnet, emby server in my pc works well but not emby server in my synology NAS. It’s so strange.

Link to comment
Share on other sites

I am very sure that this is not a connectivity issue or NAS network configuration issue, because I just install a plex to download some subtitles from opensubtitles.org and it is successful.

Anything found from your side?

Link to comment
Share on other sites

Hello @@gubin521

 

We are still looking at this, but haven't been able to recreate it so far. It's certainly curious that the problem only appears to be affecting Open Subtitles and only on this particular piece of h/w.

 

This isn't an issue we're seeing reported widely.

 

The error "Connection reset by peer" could be the result of an SSL negotiation failure, with that most likely being a failure to validate the certificate chain.

 

Would you be willing to update to the latest beta?

 

Best

- James

Link to comment
Share on other sites

Just created this account, to say that there is a chance his ISP is blocking opensubtitles.org, as several ISP's here in DK does that now, in the same manner as they block access to various infamous torrentsites.

 

It depends on the country you are in, and their laws/rules, whether your ISP will be DNS blocking opensubtitles.org.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...