Jump to content


Photo

New feature request: Management of server wake / sleep state

Emby Server Sleep wake WOL magic packet Windows Android TV

  • Please log in to reply
30 replies to this topic

#21 Kodi_Newcomer OFFLINE  

Kodi_Newcomer

    Advanced Member

  • Members
  • 228 posts
  • Local time: 12:45 AM

Posted 23 September 2019 - 02:50 PM

It will be on the dialog that comes up after the server connection times out so please be sure you are waiting at least 45 seconds.


There is No Message or Dialog for wol Option. Maybe you can bring Automatic wol Back as an Option. I dont think im the only one with this Problem .

#22 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156920 posts
  • Local time: 07:45 PM

Posted 23 September 2019 - 03:35 PM

do you have a mobile device to compare with the WOL function in the mobile android app?



#23 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 52001 posts
  • Local time: 07:45 PM

Posted 23 September 2019 - 06:00 PM

Hi.  I found one logic path where the dialog didn't show.  This should be fixed in the next release.

 

Thanks.



#24 Kodi_Newcomer OFFLINE  

Kodi_Newcomer

    Advanced Member

  • Members
  • 228 posts
  • Local time: 12:45 AM

Posted 24 September 2019 - 04:14 PM

With the Mobile App on mY Phone it works. After a View Seconds He Shows me the Server to choose there i can click wakeup Server and IT has worked.

But the time ist very long, normaly my server is in standby, so i have to wait many seconds every day.

Edited by Kodi_Newcomer, 24 September 2019 - 04:15 PM.


#25 DaSilva OFFLINE  

DaSilva

    Advanced Member

  • Members
  • 92 posts
  • Local time: 01:45 AM

Posted 16 April 2020 - 02:23 PM

Was this problem fixed?
I also have a Shield 2019 and when I’m trying to connect to my sleeping Emby Server (Windows) I get the spinning circle for about 40 seconds and then I get the screen with the following:
-Select a server with my server listed.
-Other options / Enter Manually / Login with connect.
Is there an option to configure the Emby client app to automatic send a magic packet to the server?
Thanks.

#26 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 52001 posts
  • Local time: 07:45 PM

Posted 16 April 2020 - 02:51 PM

Was this problem fixed?
I also have a Shield 2019 and when I’m trying to connect to my sleeping Emby Server (Windows) I get the spinning circle for about 40 seconds and then I get the screen with the following:
-Select a server with my server listed.
-Other options / Enter Manually / Login with connect.
Is there an option to configure the Emby client app to automatic send a magic packet to the server?
Thanks.

 

On that screen, is there also a "Send Logs" button?  If so, after you get that time-out, can you please send the log and then come back here and tell me exactly what time you did that?

 

Thanks.



#27 DaSilva OFFLINE  

DaSilva

    Advanced Member

  • Members
  • 92 posts
  • Local time: 01:45 AM

Posted 17 April 2020 - 02:44 AM

Hi ebr,
I’m sorry but no “send logs” button.
Is there anything else I can do to help you figure this out?
TY

#28 DaSilva OFFLINE  

DaSilva

    Advanced Member

  • Members
  • 92 posts
  • Local time: 01:45 AM

Posted 17 April 2020 - 04:13 AM

Ok small update.
I’ve been messing around and I’ve been able to send logs at 10:05 in Belgium.
When I start Emby on the Shield while the server is asleep I get the spinning circle before getting the screen as mentioned in post #25.
Then when I select my server and press OK nothing happens for about 20sec and then I get the screen wich says Server Unavailable and there is a wake button.
Unfortunately when i press “Wake” nothing happens ...

This is the last piece I’m missing for a pefect (if that exists) setup.
I’m using Emby Theater on my HTPC, wich automaticlly wakes the server, because of madvr for UHD.
And the wife and the kids use the Shield because that just works without messing around with external players.
If now the Shield would just auto wake my server it would be golden!
Thanks in advance!

Edit - maybe it’s relevant to know that I have configured in the Power Management settings of the NIC in my server to only wake when a magic packet is sent because otherwise my server would wake randomly.

Edited by DaSilva, 17 April 2020 - 04:25 AM.


#29 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 52001 posts
  • Local time: 07:45 PM

Posted 17 April 2020 - 09:54 AM

Are you sure your server isn't woken up and it is just a different problem?  We appear to be getting an auth failure:

04-17 10:05:33.242  7424  7643 E Volley  : [370] BasicNetwork.performRequest: Unexpected response code 401 for http://192.168.1.2:8096/emby/system/info?format=json


#30 DaSilva OFFLINE  

DaSilva

    Advanced Member

  • Members
  • 92 posts
  • Local time: 01:45 AM

Posted 17 April 2020 - 11:35 AM

Nope server still asleep.
I can wake the server with the Lights Out app on my phone but Emby unfortunately not.
Thanks for taking your time to look into it 👍

Edited by DaSilva, 17 April 2020 - 11:36 AM.


#31 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156920 posts
  • Local time: 07:45 PM

Posted 17 April 2020 - 02:24 PM

How about the Emby mobile app on your phone?







Also tagged with one or more of these keywords: Emby Server, Sleep, wake, WOL, magic packet, Windows, Android TV

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users