Jump to content
akoenig

Images/thumbnails generation

Recommended Posts

akoenig

Hello,

 

I seem to have a lot of tv shows in the "next up" or "continue watching" section that show the "thumb" image for the entire series rather than the image listed as the "primary" for the exact episode in question.

 

I have recently moved from plex over to emby and have been loving it so far, I am probably just not quite understanding exactly how it works with all these different image types I'm not used to dealing with. I'm finding myself a bit confused by when emby decides to use a thumbnail to display, and if a thumbnail is not available what picture does it fall back on to use?

 

On that note I'm wondering if there is a plugin I'm missing or anything to help find thumbnails. I have a mix of a lot of shows and movies that seem to be unable to find any thumbnail images. I have the library settings set up under movie image fetchers to include TheMovieDb, FanArt, The Open Movie Database, and Screen Grabber as well as making sure the image type is included under Fetcher Settings, and I have them set to save artwork into media folders.

 

thanks in advance.

Edited by akoenig

Share this post


Link to post
Share on other sites
ebr

I seem to have a lot of tv shows in the "next up" or "continue watching" section that show the "thumb" image for the entire series rather than the image listed as the "primary" for the exact episode in question.

 

Hi.  That is by design.

 

On the home screen "Next Up" row you will have one episode from many different series displayed.  It is much easier to identify what series it is when we use the Series thumb instead of a random screen capture of a particular episode.

Share this post


Link to post
Share on other sites
akoenig

I see, thank you, I had been playing around with the premium cover art plugin and things were looking pretty off because I didn't understand what it was choosing to display and where, along with some missing the thumbnail completely. Any thoughts on the thumbnails missing? Do most people just copy the primary artwork or something and upload it as the thumbnail as well? Or is there a specific name I can give the image file so the artwork would automatically get loaded up as the thumbnail after a library scan?

Share this post


Link to post
Share on other sites
ebr

Hi.  The CoverArt plug-in just enhances images you have in the system.  It doesn't provide images or choose the ones displayed anywhere.  CoverArt 4.0

 

Depending on what image providers you enabled or disabled, the system will usually find thumbs for your series automatically.  But, if you want to provide them yourself, please see the image sections here:

 

Movie naming

TV naming

Share this post


Link to post
Share on other sites
akoenig

Yeah I enabled every image provider that I have in hopes of finding anything but they come up with 0 results. Not all of them but just some random ones, mix of TV shows and movies.

 

Thanks for the link for art filenames, I should have been able to find that.

Share this post


Link to post
Share on other sites
Luke

Can you give an example? Thanks.

Share this post


Link to post
Share on other sites
akoenig

Wasn't sure how many you wanted, or if some of them being anime helps or hurts. Figured more is better.

 

Realized it might also be more helpful to have the IDs it linked to for identifying. The Alex Cross one managed to find a thumb but only if I selected all languages, ended up not being the case for all the others.

Alex Cross- https://www.imdb.com/title/tt1712170/  https://www.themoviedb.org/movie/94348-alex-cross 

Arizona- https://www.imdb.com/title/tt2140629/  https://www.themoviedb.org/movie/490004-arizona

Bojack- https://www.imdb.com/title/tt0142238/   https://www.themoviedb.org/movie/39105-dragonball-z-ginga-giri-giri-bucchigiri-no-sugoi-yatsu

Charlotte- https://www.imdb.com/title/tt4574736/  https://www.thetvdb.com/?tab=series&id=289679

Homecoming- https://www.imdb.com/title/tt7008682/  https://thetvdb.com/?tab=series&id=350553

post-378168-0-05334400-1543257355_thumb.jpg

post-378168-0-84640300-1543257366_thumb.jpg

post-378168-0-58462800-1543257372_thumb.jpg

post-378168-0-93700600-1543257377_thumb.jpg

post-378168-0-11369000-1543257451_thumb.jpg

post-378168-0-50024800-1543257456_thumb.jpg

post-378168-0-40780000-1543257517_thumb.jpg

post-378168-0-50736300-1543257522_thumb.jpg

post-378168-0-62652700-1543258065_thumb.jpg

post-378168-0-26314800-1543258074_thumb.jpg

Edited by akoenig

Share this post


Link to post
Share on other sites
Luke

Thumbs come from fanart.tv. Have you checked it to see that it has thumbs for your titles?

Share this post


Link to post
Share on other sites
akoenig

I'll scope it out and see, I didn't know fanart.tv was the only source that does thumbnails, I could've sworn I saw some thumbnails from other sources on some different movies/series. I wonder if just deleting all thumbnails would be easier and more uniform in the long run for automation. The coverart plugin is cool but things don't look quite right when some have a thumbnail and others don't. The roku thumbnail generator can't be used for these thumbnails can it?

Share this post


Link to post
Share on other sites
Luke

No, the roku plugin is for seek preview thumbnails.

Share this post


Link to post
Share on other sites
akoenig

Thanks for the info, looks like all of the ones I am missing do not have thumbnails in fanart.tv I think I'll end up just deleting all thumbnails and telling emby not to pull thumbnails. It should show the backdrop instead of thumbnail when thumbnail isn't available, correct?

Share this post


Link to post
Share on other sites
Luke

Yes that's correct.

Share this post


Link to post
Share on other sites
akoenig

I went through my library and deleted any thumbnail files and any extra artwork (through windows not through emby web interfaces) to help uniform the library and told it to refresh the library for missing/updated files but instead of realizing the files are gone it seems I get either broken picture icons or if I go to edit the images of a video it still shows the category of thumbnail but the actual picture is just blank.

 

Is there a better way to delete all picture files of a certain category like thumbnails over an entire library?

 

 

5c05eab3ef8d2_images.png

Thanks,

Share this post


Link to post
Share on other sites
Happy2Play

I went through my library and deleted any thumbnail files and any extra artwork (through windows not through emby web interfaces) to help uniform the library and told it to refresh the library for missing/updated files but instead of realizing the files are gone it seems I get either broken picture icons or if I go to edit the images of a video it still shows the category of thumbnail but the actual picture is just blank.

 

Is there a better way to delete all picture files of a certain category like thumbnails over an entire library?

 

 

5c05eab3ef8d2_images.png

Thanks,

 

That broken image is for Logo not thumbnails though.  No positive but a library scan should update the database for the removed images.

Share this post


Link to post
Share on other sites
akoenig

Ah I see, logo was also one of the image formats I went through and deleted. I checked that exact stream some time later in the night and found the image had been restored and was no longer showing a broken image. It's almost like emby thought the logo image should be there so it went out and grabbed it again.

Share this post


Link to post
Share on other sites
Luke

Try running a library scan

Share this post


Link to post
Share on other sites
akoenig

Which scan option should I pick? I tried the updated files option but that didn't work. I'd hate to do the replace all metadata and check to replace all images because I had to hand pick quite a few for primary image.

Share this post


Link to post
Share on other sites
Luke

I would just run a regular scan.

Share this post


Link to post
Share on other sites
akoenig

I thought that's what I did, just did a library scan and picked the scan for new and updated files under refresh mode. Is there a different way I should be doing that?

Share this post


Link to post
Share on other sites
Luke

Just running a scan should be fine.

Share this post


Link to post
Share on other sites
akoenig

So I went through and deleted image files and ran another scan and even told it to get new images. But it still thinks an image should be there even though I deleted it. I made sure fetcher settings are not pulling the image type I want removed.

post-378168-0-02981700-1544154255_thumb.jpg

post-378168-0-18006500-1544154264_thumb.jpg

post-378168-0-35524500-1544154273_thumb.jpg

Edited by akoenig

Share this post


Link to post
Share on other sites
Luke

I'm afraid I can't reproduce this. I just tested by deleting some image files and then running a scan. After the scan was done, the server was aware the images were gone and didn't try to display anything.

Share this post


Link to post
Share on other sites
akoenig

Weird, which of the 3 scan options did you choose when you did the scan and did you have to tell it to replace images?

Share this post


Link to post
Share on other sites
Luke

i just clicked the big button that says scan all libraries.

Share this post


Link to post
Share on other sites
akoenig

hmm, I made sure the files were deleted then ran a scan all libraries like you suggested but I still get stuck with a black placeholder for the logo which seems to cause that broken image icon. Curiously enough I had another tv series that had a thumbnail and a logo which I wanted to remove both, went into the folder for the show and found the thumbnail picture and deleted it, when I scanned the library it removed the thumbnail I deleted. But the logo which I could never find the picture file for sticks as a blank entry in emby.

 

post-378168-0-83580800-1544190337_thumb.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...