Jump to content

New Items not Showing


Glyde62
 Share

Recommended Posts

There was a bug in the update library function. 

 

Here is a temp build that fixes it. I am still fixing some other stuff right now.

Just install this, update the library should do the trick.

Update libraries is working like it use to again it seems... I'll report findings after how ever long this takes to update..5b9c4e492f43b_embybeta1.jpg

  • Like 1
Link to comment
Share on other sites

Think I installed it OK, said it was updated anyway.

 

If you mean this Update Library...

 

5b9c4d597569c_EmbyKodiAddingEpisodes.jpg

 

It doesn't add the episodes to the series, it just makes the (empty) series disappear, thought the series comes back again if I back out of the list of series and go back in again - its still got no episodes though.

 

Course considering what I know about Kodi I might be doing something really basic wrong...

No... in the addon here...5b9c4f1ab0c02_emby2.jpg

  • Like 1
Link to comment
Share on other sites

Yes that's the one. Or if you open the context menu on the library itself in the emby for kodi listing, you'll find options per individual library.

 

 5b9c4f6157c24_context2.jpg

  • Like 1
Link to comment
Share on other sites

Thanks for the help everyone. Didn't work though. Tried updating TV, then tried updating All twice. Still the same. Should I try Repairing the library or Resetting the database or sending a log (have restarted Kodi a few times though).

Link to comment
Share on other sites

Thanks for the help everyone. Didn't work though. Tried updating TV, then tried updating All twice. Still the same. Should I try Repairing the library or Resetting the database or sending a log (have restarted Kodi a few times though).

I just repaired my libraries and that might be the best option. Or reset local database and then add libraries.

Link to comment
Share on other sites

For simple missing episodes then an update should do the trick (it pulls all content from the library, same as add library, but since the entries still exists, it updates existing information). A repair should be last resort.  A repair removes all entries from that library first, then re-adds (same as add library).

 

However there is a bug with series pooling which is what I'm fixing right now, if that is the case then nothing you do will fix this atm.

  • Like 1
Link to comment
Share on other sites

Just to make sure, is this a tv show that should have series pooling applied? (where the series is separated on multiple hdds?)

 

Well I have films and TV shows scattered about various disks, and a few shows have series that are on different discs, but these particular series (and their episodes) are all on the same disc.

  • Like 1
Link to comment
Share on other sites

Thanks for that. Please tell me if I'm wasting your time though, like I say I'm not very familiar with Kodi and don't want to waste your time fixing something that might turn out to be a 'just click here / duh, is that all' moment.

Link to comment
Share on other sites

Ok I repaired movies and my tv library. Fixed all the stuff that didn't show up but it's not auto syncing right. I added 4 movies and only two added correctly the other 2 have no artwork  plot but if i hit info the artwork is there but no plot or anything else.

Link to comment
Share on other sites

Log? I know I'm annoying with that but I'm trying to see if it's just because it processes updates before additions or what. If there's no info usually means it's the added event. But that it never processed the update event which indicates all information was scraped.

 

Edit: At least it feels like we are getting closer to the issue...

Edited by Angelblue05
  • Like 1
Link to comment
Share on other sites

Nope you are definitely not wasting my time :)

 

In fact I appreciate you testing and helping me get to the bottom of this.

 

Isnt this the good old series pooling issue on the addon side? I changed my collection 1 year ago to never again have to deal with this issue, at first it was herculean since I have so many TV Shows but it was the best choice. I think the problem still lies in the way how the addon retrieves the IDs from the table and comes across the same "scrapped" name on a diferente path?

Link to comment
Share on other sites

@@arrbee99

 

Restart Kodi or check for updates under addon settings > advanced. It should pick up on the changes. Try repairing your tv show library and let me know if it resolves your issue.

Note, this only fixes series pooling. I'm not exactly sure if that is your issue but let's try it anyway and hopefully we get a little further to solving this, thanks.

Link to comment
Share on other sites

Isnt this the good old series pooling issue on the addon side? I changed my collection 1 year ago to never again have to deal with this issue, at first it was herculean since I have so many TV Shows but it was the best choice. I think the problem still lies in the way how the addon retrieves the IDs from the table and comes across the same "scrapped" name on a diferente path?

 

Yeah previously that was the case, but I resolved this (or at least I thought I did, with 3.1x) but now it's really fixed according to my many tests.

Link to comment
Share on other sites

I left it alone for awhile and it updated the movies and added them all.

 

So patience was needed. :)

 

 

Glad because I'm over here adding movies and episodes and they all worked. I'm working on re-adding the backup option, so you'll be able to test that out too.

Edited by Angelblue05
  • Like 1
Link to comment
Share on other sites

@@arrbee99

 

Restart Kodi or check for updates under addon settings > advanced. It should pick up on the changes. Try repairing your tv show library and let me know if it resolves your issue.

Note, this only fixes series pooling. I'm not exactly sure if that is your issue but let's try it anyway and hopefully we get a little further to solving this, thanks.

 

Yep, that seemed to work - deleted the library then chugged its way through putting it all back plus those episodes it missed  :)

  • Like 1
Link to comment
Share on other sites

This thread is getting long. I marked it as fixed (it's getting a little hard to track outstanding issues).Post a new post for remaining issues.

Edited by Angelblue05
  • Like 1
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...