Jump to content

Chromecast Picker showing duplicates


tinskip
 Share

Recommended Posts

I run about a half dozen Chromecast devices on my (switched) network.  One Ultra, three Audio, one built-in (Sony Bravia), and three Home.  Each and every one of these devices shows up twice in the Cast device picker.  And more often than not, picking a device does not work, sometimes even trying both "instances" of the same device.  Only quitting the Emby app, and restarting it will fix the connection issue, but not the duplicate device one.

 

This could be due to my running Android Pie (Pixel 2xl), but anyhow is something that ought to be addressed.  Anyone else experiencing this problem?  BTW, it does not occur with any other cast-enabled devices.

 

Thanks!

Edited by juicyfruit
Link to comment
Share on other sites

Hi there, why would you say this? It works just fine in my testing. We get the list of available cast devices from using Google's cast api. I have a plethora of Chromecast devices on my network for testing and haven't seen any problems.

Link to comment
Share on other sites

I say this because I am a horrible person who is trying to make your life difficult.

 

Actually, it appears only actual Chromecast devices may be duplicated.

 

Are you testing with Android Pie? 

 

Please see screen attached.

post-342686-0-50687500-1534995882_thumb.png

Edited by juicyfruit
Link to comment
Share on other sites

Figured out the problem.  Somehow I wound up with two concurrent instances of the server running on my Mac.  I do not know how this could happen, since afaik you can only launch an app twice.  Killing both instances (via Activity Monitor), and re-launching, fixed the problems.  So not broken, sorry for the false alarm.

Link to comment
Share on other sites

Oops.  Not figured out.  Issue re-occurred.  I have a theory: Currently my DHCP lease is set to 24 hours. Perhaps a different IP address is being assigned on lease renew, causing whatever component is caching the Cast device list to duplicate receivers.  Seems like a stretch to me, because the router ought to just renew the lease with the same IP address, but have upped the lease time to test the theory anyway.

 

QQ: Where does the mDNS scan for cast devices occur?  Server (would make some sense since it has the media, which can be pulled directly), or the client (most probably)?

 

Anything else I can do to debug the issue?

 

Thanks!

Edited by juicyfruit
Link to comment
Share on other sites

Unstable HDCP leases was not the issue.  I'm still seeing the problem, and still do not know what triggers it.  I have attached three files:

 

- Before.png: Cast devices on Emby app after reboot.

- After.png: Cast devices on Emby app after things start to go South.

- Plex.png: Cast devices in Plex app (sorry).
 
In addition to the duplicate items, my Cast-enabled TV (XBR...) does not show up in Emby at all.
 
I am liking Emby more than Plex, other than this one snag, and I'd like to stick with it if possible.  Anything I can do to further debug this?
 

post-342686-0-72696000-1535246671_thumb.png

post-342686-0-73252100-1535246685_thumb.png

post-342686-0-00193300-1535246695_thumb.png

Link to comment
Share on other sites

  • 4 months later...
ROLHION MAISON

Just for information. Same problem on my chromecast interface. They are duplicate only on EMBY (not on DEEZER, ...).

Not duplicate on multiroom chromecast group.

 

Thanks in advance.

Link to comment
Share on other sites

Thanks for this - but it's no different for me unfortunately.

Like Rolhion, Chromecast groups appear correctly but each indivisible Chromecast appears twice. I've a tried a few other casting apps and all Chromecasts and groups appear correctly.

Cheers.

Link to comment
Share on other sites

I'm having the same issue, It appears as soon as a chromecast device is a member of a chromecast group, it is seen double by the emby app. Since a short while it is possible to add a video chromecast to a chromecast group, as soon as I did this (for test) my video chromecast appeared twice in de chromecast picker.

Link to comment
Share on other sites

  • 4 weeks later...

I am also having this issue. All my chromecasts show up as duplicate entries. And 1 of the duplicates does not work for each device.

 

I've tried restarting emby and restarting all my chromecast devices.

Link to comment
Share on other sites

  • 4 weeks later...
  • 2 weeks later...
  • 2 weeks later...

Sorry if somehow hijacking the thread but I also had the issue.

 

It seems resolved now when I just tested, but I can see all my Google Homes and also my Google Speaker Groups in the list. This isn't the case other streaming services so I believe they can be filtered?

 

Thanks

Link to comment
Share on other sites

No issue for hijacking the thread ;)
I have't got the time to test the app yet - and since I have had the issue on an older Device with an older Android version, I'm not sure, if this app could run on it.

I haven't setup a newer device for my streaming yet... something I should consider for this weekend... :)

Link to comment
Share on other sites

  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...