Jump to content
Happy2Play

ANSWERED AAC 5.1 No sound

Recommended Posts

Happy2Play

Roku will direct play movie but no sound do to audio being AAC 5.1.

 

VideoCodecH264
ProfileHigh
Level40
Resolution1920x800
Aspect Ratio2.40:1
InterlacedNo
Framerate23.97602
Bitrate2723 kbps
AudioLanguageeng
CodecAAC
Layout5.1
Bitrate408 kbps
Sample Rate48000 khz
DefaultYes
 
Server Version 3.0.5192.19560
Roku 1.17.2

Share this post


Link to post
Share on other sites
gcw07

Make sure you have 5.1 turned on in the Roku itself. 

Share this post


Link to post
Share on other sites
Happy2Play

It is AC3 5.1 work fine but all AAC 5.1 movies play with no audio.  The issue I believe is the server is Dierct Playing file instead of converting the audio since the Roku doesn't support AAC 5.1 only 2.0.

Edited by Happy2Play

Share this post


Link to post
Share on other sites
gcw07

Yeah more then likely it is trying to just pass through the AAC 5.1 to your audio system and maybe your audio system isn't decoding that?

Share this post


Link to post
Share on other sites
Happy2Play

I can remote play from web client to WDPlay on same tv and receiver and get sound from the same movie.

Edited by Happy2Play

Share this post


Link to post
Share on other sites
gcw07

I wonder if it doesn't even attempt to pass through that type of audio on the Roku. I will look through my collection and see if I can find anything with aac 5.1. Not sure I do, but will look to see to test against.

Share this post


Link to post
Share on other sites
Happy2Play

Most of my AAC 5.1 just hang at retrieving like shown here.

http://mediabrowser.tv/community/index.php?/topic/594-roku-public-beta/?p=27169

 

So far I have only seen one that plays with out audio.

 

*Looks like it played on the WDPlay because it transcoded the file.  Tested on Roku by changing video quality and it transcodes video and audio when lowering video quality.

Edited by Happy2Play

Share this post


Link to post
Share on other sites
gcw07

Yeah there is a problem with playback right now. We hope to have a fix for it soon. When we do, we will let you know and hopefully it fixes this too. If it doesn't let me know.

Share this post


Link to post
Share on other sites
Koleckai Silvestri

I wonder if it doesn't even attempt to pass through that type of audio on the Roku. I will look through my collection and see if I can find anything with aac 5.1. Not sure I do, but will look to see to test against.

I believe "Big Buck Bunny" is available in AAC 5.1 on their download page.

Share this post


Link to post
Share on other sites
gcw07

I believe "Big Buck Bunny" is available in AAC 5.1 on their download page.

Thanks Wayne. I'll look there for a video to test with.

Share this post


Link to post
Share on other sites
grape

Yeah there is a problem with playback right now. We hope to have a fix for it soon. When we do, we will let you know and hopefully it fixes this too. If it doesn't let me know.

 

Is it possible this playback problem is causing other audio stream issues.   I am having trouble with HD audio streams playing through the Roku 3.   I can get 2 channel audio and Dolby Digital.  This is happening for me on MKV's and playable iso's.  I would want the Roku to do a pass-thru on all audio streams as a preference.   I do notice that I am able to select various audio streams but the HD ones never play and a non-HD seems to be auto-selected when I attempt to select and HD stream.

Share this post


Link to post
Share on other sites
gcw07

Is it possible this playback problem is causing other audio stream issues.   I am having trouble with HD audio streams playing through the Roku 3.   I can get 2 channel audio and Dolby Digital.  This is happening for me on MKV's and playable iso's.  I would want the Roku to do a pass-thru on all audio streams as a preference.   I do notice that I am able to select various audio streams but the HD ones never play and a non-HD seems to be auto-selected when I attempt to select and HD stream.

ISO's will never have pass through just because the Roku can't decode an ISO. It can decode a specific type of mkv and a specific type of mp4 file, but not much else.

 

Right now it is only transcoding to 2 channel which is why you are getting non-HD streams to just come out as stereo. Hopefully we can fix that soon to at least start transmitting in 5.1. Also make sure you have turned on surround sound on the Roku itself. If it is set to stereo it will only playback in stereo.

Share this post


Link to post
Share on other sites
grape

ISO's will never have pass through just because the Roku can't decode an ISO. It can decode a specific type of mkv and a specific type of mp4 file, but not much else.

 

Right now it is only transcoding to 2 channel which is why you are getting non-HD streams to just come out as stereo. Hopefully we can fix that soon to at least start transmitting in 5.1. Also make sure you have turned on surround sound on the Roku itself. If it is set to stereo it will only playback in stereo.

Thanks for reply. I will be patient. Just a point of interest though, I am successfully playing an iso through the roku, just with 2 channel sound though. Not many of the iso's play but one created from AnyDVD (Man of Steel). I assume the sever side is taking care of decoding the iso. I have had pretty good luck getting Android devices to play the iso's also. Still in reading through the forum I am seeing that I probably should be going MKV, so I am looking into that. Thank you again.

 

Doug

Share this post


Link to post
Share on other sites
Koleckai Silvestri

Thanks for reply. I will be patient. Just a point of interest though, I am successfully playing an iso through the roku, just with 2 channel sound though. Not many of the iso's play but one created from AnyDVD (Man of Steel). I assume the sever side is taking care of decoding the iso. I have had pretty good luck getting Android devices to play the iso's also. Still in reading through the forum I am seeing that I probably should be going MKV, so I am looking into that. Thank you again.

 

Doug

 

 

The server will transcode ISOs into MP4 and AAC sound for the Roku.

  • Like 1

Share this post


Link to post
Share on other sites
Tikuf
The server will transcode ISOs into MP4 and AAC sound for the Roku.

 

No it won't

 

It will transcode to h264/aac hls

Share this post


Link to post
Share on other sites
Happy2Play

Any update on the AAC 5.1 issue?

Share this post


Link to post
Share on other sites
gcw07

Any update on the AAC 5.1 issue?

None at the moment, sorry.

Share this post


Link to post
Share on other sites
Happy2Play

AAC 5.1 audio is being transcoded like they should be now in v1.21.

  • Like 1

Share this post


Link to post
Share on other sites
Luke

Well done.

Share this post


Link to post
Share on other sites
djrecon

Any word on solving the AAC issue with Roku?

I have a Roku 3 with the latest software. I play everything forced direct, direct stream, and it won't play any audio from any AAC content on my plex. All other formats and speaker numbers work. It's just all the AAC files that are silent.

Share this post


Link to post
Share on other sites
Luke

Any word on solving the AAC issue with Roku?

I have a Roku 3 with the latest software. I play everything forced direct, direct stream, and it won't play any audio from any AAC content on my plex. All other formats and speaker numbers work. It's just all the AAC files that are silent.

 

Hi @@djrecon, welcome! We're very sorry to hear about this issue and we'd love to help you resolve it. In order for us to best do that, please discuss an example by supplying the information requested in how to report a media playback issue. Thanks !

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...