Jump to content

How set login screen to other LAN computers


Aker666
Go to solution Solved by mastrmind11,

Recommended Posts

Hi, I've discovered today Emby and I'm trying to configure it on an old lapop with Ubuntu Mate. I've the server up, working and tested with other laptops on the same LAN.

 

But I've noticed a problem, on Windows the server appears on "Network" as a "Multimedia Device". That's not the problem, the problem it's that if double click on it, I can enter on the library folder, or If I go to "Properties" and clic on the URL (for example): 192.168.0.13:8091, I open the web interface on and automatically logs with my server user with all access.

 

My question it's how I can set a login screen when someone wants to enter on the server, even if it's me from other laptop. I have my admin account linked with Emby Connect, I don't know if this detail helps with my problem.

 

Regards

EDIT 1:

Ok, searching a bit more on this forum I've found this thread: https://emby.media/community/index.php?/topic/59893-require-pin-for-accessing-user-accounts/

 

and on a comment:

 

Hi.  If you want to be able to switch between users (accounts) on the same app, then you don't want to use Emby Connect.  Connect is designed as an easy way to directly connect an app/device to a single user without having to know/type in the server address and credentials for the user.

 

If you want to have two accounts with different access, then you want to create two normal accounts on the server (not by email address), setup their access and passwords how you like, and then any local device should automatically find your server and present those two users as options at log-in.

 

Please let us know if this answers your question.

 

Thanks.

So, my first problem to ask for login it's solved. But I'm still able to access the folder via "Network" as the server it's listed as a "Multimedia Device" and if I do double click, I enter on the folder and see all the downloads. How I can restrict the folder of the library on the LAN?
 

 

Edited by Aker666
Link to post
Share on other sites
  • Solution
mastrmind11

Hi, I've discovered today Emby and I'm trying to configure it on an old lapop with Ubuntu Mate. I've the server up, working and tested with other laptops on the same LAN.

 

But I've noticed a problem, on Windows the server appears on "Network" as a "Multimedia Device". That's not the problem, the problem it's that if double click on it, I can enter on the library folder, or If I go to "Properties" and clic on the URL (for example): 192.168.0.13:8091, I open the web interface on and automatically logs with my server user with all access.

 

My question it's how I can set a login screen when someone wants to enter on the server, even if it's me from other laptop. I have my admin account linked with Emby Connect, I don't know if this detail helps with my problem.

 

Regards

 

EDIT 1:

Ok, searching a bit more on this forum I've found this thread: https://emby.media/community/index.php?/topic/59893-require-pin-for-accessing-user-accounts/

 

and on a comment:

 

Hi.  If you want to be able to switch between users (accounts) on the same app, then you don't want to use Emby Connect.  Connect is designed as an easy way to directly connect an app/device to a single user without having to know/type in the server address and credentials for the user.

 

If you want to have two accounts with different access, then you want to create two normal accounts on the server (not by email address), setup their access and passwords how you like, and then any local device should automatically find your server and present those two users as options at log-in.

 

Please let us know if this answers your question.

 

Thanks.

 

So, my first problem to ask for login it's solved. But I'm still able to access the folder via "Network" as the server it's listed as a "Multimedia Device" and if I do double click, I enter on the folder and see all the downloads. How I can restrict the folder of the library on the LAN?

 

Yes, the bold above is correct.  Also, do you have SMB sharing set up on your Linux server?  If so, disable it for the media shares and they won't be discoverable on your Windows machines.  If not, do you have DLNA enabled?  if I recall, windows sniffs out DLNA enabled devices and treats them to the old point-and-click behavior, so disable DLNA.

  • Like 1
Link to post
Share on other sites

Hi mastrmind11! You were right, I disabled DLNA on Emby options and the folder it's not shown any more and Windows can't detect the server.

Someday, if I want to get access again I know that I only have to enable DLNA, it's very easy on this way.

Thank you so much!

 
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...