Jump to content

AMF transcoding problem


laifisnau
 Share

Recommended Posts

laifisnau

Hello.

First of all, I apologize for my English (I'm Italian).

I write here because I have a problem with transcoding.

I have a system based on APU AMD Ryzen 2400G (VEGA 11 video card, lastest driver), windows 10 pro 64bit (with lastest update), 16GB ram, etc.

With none of my files (all HEVC) I can make transcoding work.

The encoding in h264 works (in the task manager I see that the video card is engaged at about 20%, the encoding section is 50% engaged) while the decoding is not (the decoding section remains at 0% while the cpu with video in 4k goes to 70 %).

I have already changed ffmpeg by putting a version with enabled -amf.

The same videos are easily decoded by video card watching them with vlc, mediaplayer, etc.

I enclose the two logs. The file in 4k is a 10bit HVEC from around 50Mbps, 1080p is a simple 8bit and 8Mbits HEVC movie.

 

Thanks for your help.

4k.txt

1080p.txt

Link to comment
Share on other sites

Yea I don't think there is decoding with amf, right? I think we need to use dxva2.

Link to comment
Share on other sites

laifisnau

Yes the decoding does not work (only the encoding in h264 works). But with VLC, Windows Media Player etc. hardware decoding seems to work (I see the decoding graphics section in the task manager at 50-60%). How should I do to enable DXVA2 in emby?

Edited by laifisnau
Link to comment
Share on other sites

You can't at this point. We're looking into it for the next release, thanks.

Link to comment
Share on other sites

  • 3 weeks later...
laifisnau
Hello. I have updated the server to version 3.5.0.0.

Dxva2 does not work yet

 



Stream mapping:
Stream #0:0 -> #0:0 (hevc (native) -> h264 (h264_amf))
Stream #0:1 -> #0:1 (dts (dca) -> mp3 (libmp3lame))
Press [q] to stop, [?] for help
[h264_amf @ 00000223ab278980] encoder->Init() failed with error 1
Error initializing output stream 0:0 -- Error while opening encoder for output stream #0:0 - maybe incorrect parameters such as bit_rate, rate, width or height
[libmp3lame @ 00000223ab1e66c0] 3 frames left in the queue on closing
Conversion failed!
ffmpeg version 4.0.1 Copyright (c) 2000-2018 the FFmpeg developers
built with gcc 7.3.1 (GCC) 20180710
configuration: --enable-gpl --enable-version3 --enable-sdl2 --enable-bzlib --enable-fontconfig --enable-gnutls --enable-iconv --enable-libass --enable-libbluray --enable-libfreetype --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-libshine --enable-libsnappy --enable-libsoxr --enable-libtheora --enable-libtwolame --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxml2 --enable-libzimg --enable-lzma --enable-zlib --enable-gmp --enable-libvidstab --enable-libvorbis --enable-libvo-amrwbenc --enable-libmysofa --enable-libspeex --enable-libxvid --enable-libaom --enable-libmfx --enable-amf --enable-ffnvcodec --enable-cuvid --enable-d3d11va --enable-nvenc --enable-nvdec --enable-dxva2 --enable-avisynth
libavutil 56. 14.100 / 56. 14.100
libavcodec 58. 18.100 / 58. 18.100
libavformat 58. 12.100 / 58. 12.100
libavdevice 58. 3.100 / 58. 3.100
libavfilter 7. 16.100 / 7. 16.100
libswscale 5. 1.100 / 5. 1.100
libswresample 3. 1.100 / 3. 1.100
libpostproc 55. 1.100 / 55. 1.100

Link to comment
Share on other sites

As you can see, dxva2 was used for decoding but there was possibly an encoding failure.

 

Make sure that windows is up to date and that your graphics drivers are up to date. Then if there's still an issue you could try turning off gpu encoding but leave decoding on.

Link to comment
Share on other sites

laifisnau
I ran windows update just before, the video card drivers are updated to the latest version.

 

Yes I have seen, but it always works as before (3.4.x.x), I was doing the decoding correctly but not the encoding.

But first the transcoded videos were enjoyable, but now they go to about 18fps

Link to comment
Share on other sites

laifisnau

It is not working well. With all the other software (vlc, wmp, plex with the monthly pass) the videos are played smoothly. Not with emby.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...