Jump to content


Photo

Nfo files started appearing

nfo

Best Answer Happy2Play , 02 June 2018 - 10:02 PM

As all the features have moved to per library, have you checked each library?

 

Dashboard-Library-select each library-enable Show Advanced settings-scroll to Metadata Savers

Go to the full post


  • Please log in to reply
13 replies to this topic

#1 Dataman100 OFFLINE  

Dataman100

    Member

  • Members
  • 12 posts
  • Local time: 06:56 PM

Posted 02 June 2018 - 09:36 PM

A few weeks ago, .nfo files started appearing in my main media folder.  Unfortunately, I don't know exactly when.  I'm guessing it started after one of the automatic sever upgrades.

 

I've made no changes to any of the settings in Emby, nor made any changes to any paths.  My metadata path is set to a folder under the main video folder.  Nfo files just started appearing for newly added video files in the main media folder.  I've never seen that before.  Was something changed in the handling of .nfo files?

 

Sorry I can't be more specific, but I don't really know when it started.

 

Thanks,

 

Dave

 



#2 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 15087 posts
  • Local time: 11:56 AM
  • LocationWashington State

Posted 02 June 2018 - 10:02 PM   Best Answer

As all the features have moved to per library, have you checked each library?

 

Dashboard-Library-select each library-enable Show Advanced settings-scroll to Metadata Savers


  • Dataman100 likes this

#3 Dataman100 OFFLINE  

Dataman100

    Member

  • Members
  • 12 posts
  • Local time: 06:56 PM

Posted 04 June 2018 - 02:17 AM

As all the features have moved to per library, have you checked each library?

 

Dashboard-Library-select each library-enable Show Advanced settings-scroll to Metadata Savers

 

Ahhh, that was it.  The NFO box was checked.  I unchecked it and it seems like it's not creating the .nfo files anymore.  Out of curiosity, where is it storing the metadata for the file now?  Is it in the folder I have under the main folder marked for metadata?  I only see .png files in there with the artwork.

 

Thanks,

 

Dave



#4 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 15087 posts
  • Local time: 11:56 AM
  • LocationWashington State

Posted 04 June 2018 - 02:18 AM

Ahhh, that was it.  The NFO box was checked.  I unchecked it and it seems like it's not creating the .nfo files anymore.  Out of curiosity, where is it storing the metadata for the file now?  Is it in the folder I have under the main folder marked for metadata?  I only see .png files in there with the artwork.

 

Thanks,

 

Dave

 

If nfo saver is disabled, the metadata is only written to the database.



#5 Dataman100 OFFLINE  

Dataman100

    Member

  • Members
  • 12 posts
  • Local time: 06:56 PM

Posted 04 June 2018 - 02:25 AM

If nfo saver is disabled, the metadata is only written to the database.

 

Got it.  Thanks!



#6 ebr ONLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 46057 posts
  • Local time: 02:56 PM

Posted 04 June 2018 - 08:15 AM

Saving this data in nfo files will greatly reduce the time it takes to re-build your library if ever necessary (like if you were to move the items to a new location).


  • FrostByte likes this

#7 Devdroid OFFLINE  

Devdroid

    Advanced Member

  • Members
  • 86 posts
  • Local time: 07:56 PM

Posted 05 June 2018 - 08:46 AM

Saving this data in nfo files will greatly reduce the time it takes to re-build your library if ever necessary (like if you were to move the items to a new location).

 

Also, you can store playback information in the NFO file, which will be nice to have if an emby import fails for some reason, or if there are no emby backup. 

 

It's probably good to leave it enabled. The NFO files are small and don't do any harm :)


Edited by Devdroid, 05 June 2018 - 08:47 AM.


#8 ebr ONLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 46057 posts
  • Local time: 02:56 PM

Posted 05 June 2018 - 08:52 AM

Also, you can store playback information in the NFO file, which will be nice to have if an emby import fails for some reason, or if there are no emby backup. 

 

That feature is intended for communication with external apps (Kodi) it can only save it for a single user and it will not be re-imported into Emby.

 

Just FYI...



#9 Spanky OFFLINE  

Spanky

    Newbie

  • Members
  • 8 posts
  • Local time: 06:56 PM

Posted 07 June 2018 - 10:22 AM

Does this feature still overwrite existing nfo files, that are supplied with scene releases?

 

If so, is there an easy way to stop this happening, while keeping both nfo files?

 

Thanks. 



#10 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 134611 posts
  • Local time: 02:56 PM

Posted 07 June 2018 - 11:12 AM

Just turn off nfo saving if you don't want that to happen. That's the only way.
  • angusleung likes this

#11 samhill5215 OFFLINE  

samhill5215

    Member

  • Members
  • 10 posts
  • Local time: 02:56 PM

Posted 18 June 2018 - 04:14 PM

Happy2play you mentioned turning off nfo creation was in advanced settings. It's visible in normal settings also. Has something changed? I'm running Version 3.4.1.0



#12 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 134611 posts
  • Local time: 02:56 PM

Posted 18 June 2018 - 04:58 PM

The nfo settings are immediately view-able just by clicking on a library in library setup.



#13 tixx OFFLINE  

tixx

    Advanced Member

  • Members
  • 34 posts
  • Local time: 06:56 PM

Posted 12 April 2019 - 04:59 AM

Ive just had to rebuild my library after an update which was a pain. If the nfo files help restore the data than this is great, however rather than having them inside a folder right next to the video files, is it possible to specify a directory to hold all the nfos in the one location?

 

e.g. if all the content is held at \\media\, have the ability to manually point to store the files under \\media\nfo\

 

If this is not possible, maybe look at implementing it in the future?
 

Thanks



#14 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 134611 posts
  • Local time: 02:56 PM

Posted 12 April 2019 - 09:00 AM

There currently is no setting for this. How would we know what nfo belongs to what video? That's why it's better to put them with the media





Also tagged with one or more of these keywords: nfo

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users