Jump to content


Photo

Cannot disable remote access

remote access

  • Please log in to reply
11 replies to this topic

#1 emby20180524 OFFLINE  

emby20180524

    Newbie

  • Members
  • 6 posts
  • Local time: 09:23 AM

Posted 24 May 2018 - 08:32 AM

Cannot disable "remote access".

 

Public IP always shown on Dashboard page.

 

Un-checking the "Allow remote connections to this Emby Server" box on the Advanced page and clicking Save results in nag messages but "remote access" remains turned on when return to Dashboard page.

 



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 138124 posts
  • Local time: 09:23 AM

Posted 24 May 2018 - 09:31 AM

Hi, try restarting emby server.

#3 emby20180524 OFFLINE  

emby20180524

    Newbie

  • Members
  • 6 posts
  • Local time: 09:23 AM

Posted 24 May 2018 - 11:22 AM

Hi, try restarting emby server.

Attempted full reboot of the computer where Emby is installed. No improvement.

 

Emby 3.4.1.0

Debian Stretch



#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 138124 posts
  • Local time: 09:23 AM

Posted 24 May 2018 - 11:47 AM

Did you read the nag message when clicking save?

It's not a nag message. Please read it and follow the instructions. Thanks.

#5 emby20180524 OFFLINE  

emby20180524

    Newbie

  • Members
  • 6 posts
  • Local time: 09:23 AM

Posted 24 May 2018 - 12:44 PM

Did you read the nag message when clicking save?

It's not a nag message. Please read it and follow the instructions. Thanks.

 

"Changing these values may cause instability or connectivity failures. If you experience any problems, we recommend changing the back to default."

 

There's no instability or connectivity failures. I just want the damn thing to stop serving my stuff to the whole world.

 

 

"To enable HTTPS for external connections you will nedd to supply a trusted SSL certificate ..."

 

I DON'T WANT EXTERNAL CONNECTIONS. I'M TRYING TO SWITCH IT OFF.

 

So, I did read the nag messages and they contained no valuable information.

 

What is wrong with Emby that it refuses to swich off "remote access"?



#6 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 138124 posts
  • Local time: 09:23 AM

Posted 24 May 2018 - 12:53 PM

This is happening because you must have changed the secure connections mode setting. Set it to disabled and then you should be able to save.



#7 emby20180524 OFFLINE  

emby20180524

    Newbie

  • Members
  • 6 posts
  • Local time: 09:23 AM

Posted 24 May 2018 - 01:34 PM

I was able to hack around the "Allow remote connections to this Emby Server" bug by first setting "Secure connection mode" to Disabled. This released whatever was causing Emby to ignore the checkbox setting.

 

However, "Remote (WAN) access" with my IP address is still displayed on the Dashboard which suggests that Emby is still (trying to) serve out to the Internet. I have changed the port to a nonsense number to prevent hackers from obviously attacking the default Emby port. However, why is this still "on" and how is this stopped?



#8 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 138124 posts
  • Local time: 09:23 AM

Posted 24 May 2018 - 01:35 PM

did you try restarting the server?



#9 emby20180524 OFFLINE  

emby20180524

    Newbie

  • Members
  • 6 posts
  • Local time: 09:23 AM

Posted 24 May 2018 - 01:53 PM

Attempted both "Restart" from the Dashboard page and rebooting the computer entirely. No improvement. "Allow remote connections to this Emby Server" remains un-checked but Emby is still showing "Remote (WAN) access: with IP address as if its still attempting to serve to the Internet.



#10 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 138124 posts
  • Local time: 09:23 AM

Posted 24 May 2018 - 10:40 PM

Ok I think it is likely just a display issue. I'll test this out. Thanks.

#11 soalokin OFFLINE  

soalokin

    Newbie

  • Members
  • 1 posts
  • Local time: 09:23 AM

Posted 03 July 2018 - 08:47 AM

I can confirm the same issues as the OP. 

 

Tested with Version 3.4.1.0

 

Did the suggested workaround successfully.

Dashboard still shows Remote WAN Access IP Address.

Hopefully its just a display bug.

Will have to dig into the router logs for upnp.

 

It seems like the remote WAN is not accessible, so that is good since I have it disabled in emby.

 

Edit, This is off of windows 64 bit as well. 


Edited by soalokin, 03 July 2018 - 08:48 AM.


#12 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 138124 posts
  • Local time: 09:23 AM

Posted 03 July 2018 - 09:06 AM

It is just display related, yes.





Also tagged with one or more of these keywords: remote access

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users