Jump to content

Fire TV (3rd gen) video playback issues


Diskkonnected
 Share

Recommended Posts

Diskkonnected

Hey team,

 

I'm having a weird issue with my 3rd gen Fire TV. When I go to play any video with DTS audio the video will not play, It doesn't lock up just sits at a black screen with the controls. All of these are direct plays are well... However, while the video is sitting on the back screen, if I change the display mode from 4k to 1080p it starts playing fine. Same if I change the bit rate so it changes to transcoding it starts playing. I have tried all the refresh rate switching options with no luck. Also, emby works fine on my fire TV stick that only supports 1080p.

 

Any thoughts? I have attached my emby server log.

 

 

Thanks,

EmbyServer.txt

Link to comment
Share on other sites

Isn't there also an ffmpeg log generated when you try to play one of these?

 

I don't think any Fires support DTS so at least the audio should be getting converted.

Link to comment
Share on other sites

Diskkonnected
I'm not seeing an FFmpeg log for this. If I change the display mode to 1080p to make it play, it plays fine with the DTS audio to my sound system... and it doesn't appear to be transcoding or converting anything

 

Pictures attached.

post-111941-0-84853100-1526492703_thumb.jpg

post-111941-0-16962100-1526492711_thumb.jpg

Link to comment
Share on other sites

Diskkonnected

Inside emby, after you start to play a video there is an option at the bottom where stats for nerds is located, that gives the option for display mode, by default its set to 2160/59.94 I change that to 1080/60.00 and the video will start to play.

Link to comment
Share on other sites

So, does it work properly if you enable the auto refresh rate switching option (under playback settings)?

Link to comment
Share on other sites

Diskkonnected

I have tired enabling that but it makes no difference, video wont play unless I manually change the display mode or change the bit rate to make it transcode

Link to comment
Share on other sites

Not sure what is going on but it seems like something with the connections.

 

Can you please follow the instructions to send a log from the app when you reproduce this issue?

 

Thanks.

Link to comment
Share on other sites

Diskkonnected
Logs sent.
 
The first 2 tries are 2 different movies not starting
the 3rd try is with changing the display mode so it will start to play.
 
Thanks, 
Link to comment
Share on other sites

 

These apps have the option to send an app log to us electronically.  You enter the settings page and turn on the "Debug Options".  Now there will be a new tile on your home page settings row labelled "Send Log".  Reproduce your problem and then use this button to send the log.  Then add the following information to your report in the forum:

 
  • Exactly what you were doing and what happened.  Include the name of whatever you played if it is a playback problem
  • The time you sent the log
  • The name of the Emby user on the local server that was logged in at the time
 
Link to comment
Share on other sites

Diskkonnected
Apologies,

 

1. Attempting to play to different movies with DTS audio and one with just dolby, started playing Red Sparrow first, movie would not play just sits at black screen. Navigated to Black Panther and started playing, movie sits at black screen. Exited out of Black panther, whet back in and started playing movie again, this time switching the display mode to 2160/50 same with 1080/60 but for this test I used 2160/50, movie starts to play fine. Exited movie, opened movie some kind of wonderful, movie played fine.

 

2. Time logs sent. 9:44am PST

 

3. User logged in Diskkonnected
Link to comment
Share on other sites

Whoa - these new Fire TVs are running a whole new version of Fire OS that is based on Android 7.1.  That's the first I've seen of that.

 

You aren't in any kind of Amazon beta program are you?

 

You have auto refresh rate switching turned on but your system doesn't have a refresh rate compatible with the content.  The content is 29.97 and your system only has 50, 59 and 60 available.

 

So we are not switching the display from whatever mode it is in by default.  What mode is that?  Look in the Fire settings for the display resolution/rate.

Link to comment
Share on other sites

Diskkonnected
Nope not in any beta program that I know of :)
 
The System video resolution is set for Auto(up to 4kUltra HD) so I'm assuming its running at the MAX which is 2160p 60hz
 
The only options the system has is
720p 50hz
720p 60hz
1080p 50hz
1080p 60hz
2160p 50hz
2160p 60hz
 
Why wouldn't this affect other movies though? Like I said the only movies I have issues playing are those with DTS auto and those play when I switch the display mode. Everything else plays like a champ.
Link to comment
Share on other sites

I think the DTS factor is a correlation, not a cause.  The issue almost has to be the refresh rate.

 

Can you try taking the Fire off of Auto and setting it to 2160/60 (although, you might actually get a better picture if you set it to 1080/60).

Link to comment
Share on other sites

Diskkonnected

Tried both resolutions 2160/60 and 1080/60 with no success. However, I noticed in emby when I hard set the system resolution I no longer get the option to change display modes when playing a video.

Link to comment
Share on other sites

However, I noticed in emby when I hard set the system resolution I no longer get the option to change display modes when playing a video.

 

FireOS must be doing something strange here because that means that your system is not reporting the ability to change modes then.

 

I still don't understand why the item won't play though until you manually force the mode change since we would have not even attempted a mode change since we couldn't find one that matched.

 

And, just to confirm, it still doesn't work if you disable our auto refresh rate switching...?

Link to comment
Share on other sites

  • 3 months later...

I confirm I have the same issue with the 2017 Fire 4K TV. I don't have the issue on my other older Fire TV HD box.

 

@@gnollo, what issue? did you read this topic?

Link to comment
Share on other sites

@@gnollo, what issue? did you read this topic?

Blank screen when playing most of my movies, all bluray rips with DTS. My other older model Fire TV downconverts dts but at least it plays the movies.

And yes Luke, I did read the topic [emoji23]

 

Sent from my SM-A520F using Tapatalk

Link to comment
Share on other sites

And please specify the version of the app because the issue in this thread was resolved with the last release.

 

Thanks.

  • Like 1
Link to comment
Share on other sites

I tested it yesterday night, rips with dolby play, the ones with DTS don't, but they do if I change the resolution to 1080/60 from within the "stuck" playback screen.

Will check versioning and provide logs tonight but I can tell you I bought the box last week and also downloaded Emby for the fire tv a few days later.

 

Sent from my SM-A520F using Tapatalk

Edited by gnollo
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...