Jump to content


Photo

Season ordering - metadata issues

Season Sort

  • Please log in to reply
3 replies to this topic

#1 AdrianW OFFLINE  

AdrianW

    Advanced Member

  • Super Testers
  • 2415 posts
  • Local time: 02:16 AM
  • LocationPerth, Australia

Posted 24 March 2014 - 05:05 PM

@Luke - I have a show that just started a new season, and strangely in the server web client Season 2 was displayed first and Season 1 second.

 

I tracked this down to the format of the season sort name changing. The first season has a sort name of "0001" and the second season has a sort name of "Season 2", I edited the sort name of season 1 to "Season 1" and now it sorts correctly.

 

All recently added seasons have this alphanumeric sort name (e.g. new shows like Believe, The 100, Resurrection) - whereas all prior seasons have the four digit numerics. 

 

This may be a problem for everyone when the new seasons kick off in September unless some kind of rescan can change the format of all the old ones.

 

I tried to find another example: "The Americans" just recently started season 2, and the sort names there are "0001" and "Season 2" but in this case they appear in the correct order in the web client. Interestingly though - the field "Season number" is blank for season 2, but populated with "1" for season 1.

 

 



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 135983 posts
  • Local time: 02:16 PM

Posted 24 March 2014 - 07:10 PM

0001, 0002 is our automatically generated sort name, provided we know the season number. if we don't know the season number it just defaults to the folder name.



#3 AdrianW OFFLINE  

AdrianW

    Advanced Member

  • Super Testers
  • 2415 posts
  • Local time: 02:16 AM
  • LocationPerth, Australia

Posted 24 March 2014 - 05:24 PM

Perhaps if you don't know the season number (missing TVDb data I guess) and if the folder name matches "Season n" then you should generate a 4 digit numeric sort name.

 

This had me confused for a while until I dug into the metadata editor.



#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 135983 posts
  • Local time: 02:16 PM

Posted 24 March 2014 - 07:41 PM

No I think this issue is that we don't have enough active members of our test group running with our metadata services disabled. It is possible that too many things are getting disabled, and in the case of seasons there's no xml file to fill in the missing number.







Also tagged with one or more of these keywords: Season, Sort

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users