Jump to content

WMC .MKV "cannot open the file"


spyke562
 Share

Go to solution Solved by ebr,

Recommended Posts

Hello Everyone,

 

I know there are plenty of questions around this topic that may have been answered.  However I think mine may be a bit different. 

 

I have two PCs, my 1st PC is doing the ripping with WMC with Auto Rip N Compress and hosting my Media Browser Server.  My second is my HTPC which I am using the Media Browser Client on.  After I rip my movies and put them in a file share which my HTPC has access to.  In WMC  I have the mapped drive added to my libraries.  I can play the ripped .mkv movies in Media Player as well as from the WMC Movie Library however I cannot play them through the Media Browser Client.  One thing is I can play only one moive, all others do not play in MB.  THe old version of Media Browser did work.  I can even see the metadata of all my movies.  I just get a "cannot ope the file" message when I attempt to play through Media Browser.  

 

Any suggestions?

 

I believe I have all the codecs and everything since my .mkvs are playing in WMC and Windows Media Player.

 

Thanks...

Edited by spyke562
Link to comment
Share on other sites

Oh wow, I was just here to post about the exact same issue!  

 

- This is a brand new Windows 7 64-bit built, and the only two things I had on there were LAV and Media Browser Classic.  

- I have all my media files and the server on another Windows 7 64-bit PC.

- WMP and Media Center (via "Video Library") plays MKV files just fine.

- MBC sees my library from the server PC and organized them perfectly.

- MBC plays regular AVI files fine, but NOT MKV.

 

I tried Media Browser Theatre and it plays MKV with the same setup just fine.  However, I'd like to keep using MBC until MBT is more refined and customizable.

Link to comment
Share on other sites

@spyke562

Please don't post logs like that on the forums. Please use  paste2.org or dropbox and post a link to it.

 

That said if you have transcoding logs from mkv playback it may mean that the permissions are wrong on the directory with all your movies in them .

 

Please check that MB has read and write access to your movies folder & rather than using a mapped drive please use unc path.

 

http://mediabrowser.tv/community/index.php?/topic/703-how-to-make-unc-folder-shares/

Edited by Tikuf
Link to comment
Share on other sites

  • Solution

The fact it is trying to transcode means that MBC cannot access the media directly.

 

Don't try and duplicate the mapped drives from the server on the client machine.  Instead either use the Path Substitution feature on the server or define the library on the server with UNC paths.  If the drives are not local to the server machine, you should do the latter as mapped drives are a very unreliable way to access network resources.

  • Like 1
Link to comment
Share on other sites

Hi Everyone,

 

Thanks for the pointers.  I will start trouble shooting my network locations in MB Server right now.  I don't understand how it can be a permissions issue if it plays one movie but not any other movie in the same folder location.  But I will follow the guide posted.

 

Also sorry for the logs post.

 

JAH, please post back if you find a solution.  I would be interested in reading it.

 

Thanks

Link to comment
Share on other sites

The reason you get inconsistent playback now is because we can't directly access any of your items and some of them can be transcoded and played successfully and others can't.  JAH's solution should be exactly the same.

Link to comment
Share on other sites

Hey ebr,

 

Thanks for the update.  I guess  I am kind of lost because if I am on my HTPC I can UNC to my library fine on my MB Server and see my movies in MBC on my HTPC.  Now that I removed my Library from the Folders menu in MB Server and added the Path Substitution I only see the add path in MBC but no contents.  And when I went back to the way  I previously had it I still only see the folder and no contents in MBC.  Arg.  I setup shares before so I dont know what i could be doing wrong....   

Link to comment
Share on other sites

Hi again,

 

I am a dorkus, I was putting the path in of my share in the Name field of the Add Media Folder prompt.  I ended up following the sharing directions on link posted above and simple selected that in the Add Media Folder wizard.

 

Thanks again.  Now I just just need to adjust my ripping process, somehow every movie I rip from my collection I see subtitles while playing it back.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...