Jump to content

Watched Status Not Updating

Blue Kachina

Go to solution Solved by Blue Kachina,

Recommended Posts

Blue Kachina

Hey all;

I seem to be running into the same problem that various other users have encountered, and have not yet found a fix for it.

I'm using the following:


Server Version:



MediaBrowser Classic Version: 3-14.1


MPC-HC Version:

1.7.3 (cb22afa)


MPC-HC is configured as my external player for everything except "Unknown" content.

When I set up MPC-HC as my external player, I used "MPC-HC" as the External Player Type, and I even hit the Configure my player button at the bottom.  This then modified my registry, and I had to provide admin access for it to do so.  No problems there.


Within the MediaBrowser Server settings, I have the following defined:

Min resume percentage: 5

(Titles are assumed unplayed if stopped before this time)

Max resume percentage:80

(Titles are assumed fully played if stopped after this time) 

Min resume duration (seconds):300

(Titles shorter than this will not be resumable)


With all of these settings, I would expect the media server to know when I have watched a video provided it was longer than 5 minutes in length, and that I watched at least 90 percent of it.


What happens though, is I will watch a TV episode that is longer than half an hour to its entirety... even letting MPC-HC close on its own accord, returning me back to MediaBrowser Classic.  After having done this however, the show is not marked as 'watched'.


I understand that the view of the show in MBC would not necessarily be refreshed upon immediately returning, however, even if I should exit MBC, and return to it... the show is still not marked as watched.


I'm guessing you're going to want some kind of logs so that you can help diagnose this.  If so, please indicate which logs you find would be helpful, and I will certainly provide them.


Thanks in advance for your help.

Link to comment
Share on other sites

  • Solution
Blue Kachina

Thanks for the response ebr;

I reviewed the log prior to posting it on here, only to find out that there were problems communicating with MPC-HC web server.

The web-server had somehow become switched off (possibly during the latest update to it?).


After turning it back on as per your screenshot from another thread, this feature is once again working for me.



Thanks for pointing me in the right direction.


  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...